ERROR: Part of your app is not valid

Hi, everyone,

When I enter a code to install an APP on some phones, I get the following error: Part of your app is not valid
One of your app’s resources (Application Descriptor) is not valid and must be fixed before it can be installed
Installation error: no file found for resource Application Descriptor

What is surprising is that I used the same code to install the same app on the other phones and it worked.

Thanks in advance

Hi,

This is generally the result of a Captive Portal between the phone and our backend web server.

If you navigate to https://www.commcarehq.org from the browser on the affected device, do you get redirected to an Auth portal or similar?

-Clayton

Hi Clayton! I’m having the same issue with one of my users. Is there a way to fix this?

Hi Hailey,

Are your users running with older (Android 4) devices?

If you are having issues with login or sync on older devices, we pushed a recent change to the play store to address issues with insufficient native SSL support on those old devices.

You can read more here: https://forum.dimagi.com/t/commcare-2-48-7-point-release/7488

Hi Clayton! They are using an Andriod version 10, with the latest 2.48.7 release of Commcare. Any other thoughts? Should I open a ticket?

Hi Hailey,

We’re introducing new Captive Portal detection in a future release, but for now the message would still appear in a similar way.

I would confirm a few things:

A) Are you entering a code for your app or scanning the QR Code? The app code could have confusing items (say, “O” v. “0”) so it would be worth testing from the qr code if you are entering the code manually.
B) Have you tried navigating to https://www.commcarehq.org from the devices where things are failing? You may spot issues there which will indicate what’s going wrong.

-Clayton