The new "markdown" formatting in forms editor

Exciting that you Dimagi folks have implemented the new Markdown formatting
in the forms editor.

I am curious, I am in the middle of one operation that that the markdown
feature actually makes less convenient. Is there a way to disable it
globally? (I see I can turn it off for just that one question.)

Thanks!
Eric

Hi Eric,

Sorry to hear that - would you mind telling us a bit more about the
operation you’re doing? Maybe we can brainstorm some workarounds.

Thanks,
Amelia

··· On Tue, Jun 30, 2015 at 3:42 AM Eric Stephan wrote:

Exciting that you Dimagi folks have implemented the new Markdown
formatting in the forms editor.

I am curious, I am in the middle of one operation that that the markdown
feature actually makes less convenient. Is there a way to disable it
globally? (I see I can turn it off for just that one question.)

Thanks!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hello all – I’ve been so busy, I sure took my time to reply to this thread
about the implementation of “markdown” in the forms editor.

Here is the situation in which this feature winds up actually hindering me.

I have several long forms where I use question numbering in each question’s
text. So before the text of each question, there is text like 1., 2., 3.,
25., etc.

The moment that markdown was introduced, whenever I go to edit one of those
questions, it automatically switches to markdown formatting because it sees
the numbering in the text.

But that is unhelpful for me, because some of my numbering is actually 5b.,
5c., etc., which does not get included in markdown.

And the markdown numbering, once it actually appears in the app, changes
its behavior to use automatic dynamic numbering, so it handles the
numbering itself, starting with 1 for the first item, rather than observing
the number that I had entered. But note that my own question numbering
has to remain aligned with the numbering used in other related forms, so in
many cases I force mine to be non sequential… after 7 might come 10,
because I want #10 on form 1 to be the same as #10 on forms 2 through 4,
etc.

So as it stands, each time I edit the text of a question, it immediately
turns on markdown and I have to manually turn it off each time. And those
times that I fail to turn it off, when the app is published and appears on
the smartphone, that question will be numbered 1., even if it appears in
the middle of my form after 37, and in the question text in the form editor
it was entered as 38.

So, for me, it would be ideal if there was a way to either (1) tell the app
configuration or the form editor to please turn off the markdown
functionality overall for this one app or form, or (2) to simply disable
the numbering feature of markdown, since that’s the only thing that causes
a problem for me.

Thanks!
Eric

Eric,

Could you report a bug about markdown automatically turning on? As far as I
know that should not be happening.

Also, just for the group record this numbering behavior is actually spec
compliant http://daringfireball.net/projects/markdown/syntax#list - you
can read some discussion about this here
http://meta.stackexchange.com/questions/137077/cant-start-a-numbered-list-on-a-number-other-than-1
.

Best,
Will

··· On Fri, Aug 21, 2015 at 1:03 AM, Eric Stephan wrote:

Hello all – I’ve been so busy, I sure took my time to reply to this
thread about the implementation of “markdown” in the forms editor.

Here is the situation in which this feature winds up actually hindering me.

I have several long forms where I use question numbering in each
question’s text. So before the text of each question, there is text like
1., 2., 3., 25., etc.

The moment that markdown was introduced, whenever I go to edit one of
those questions, it automatically switches to markdown formatting because
it sees the numbering in the text.

But that is unhelpful for me, because some of my numbering is actually
5b., 5c., etc., which does not get included in markdown.

And the markdown numbering, once it actually appears in the app, changes
its behavior to use automatic dynamic numbering, so it handles the
numbering itself, starting with 1 for the first item, rather than observing
the number that I had entered. But note that my own question numbering
has to remain aligned with the numbering used in other related forms, so in
many cases I force mine to be non sequential… after 7 might come 10,
because I want #10 on form 1 to be the same as #10 on forms 2 through 4,
etc.

So as it stands, each time I edit the text of a question, it immediately
turns on markdown and I have to manually turn it off each time. And those
times that I fail to turn it off, when the app is published and appears on
the smartphone, that question will be numbered 1., even if it appears in
the middle of my form after 37, and in the question text in the form editor
it was entered as 38.

So, for me, it would be ideal if there was a way to either (1) tell the
app configuration or the form editor to please turn off the markdown
functionality overall for this one app or form, or (2) to simply disable
the numbering feature of markdown, since that’s the only thing that causes
a problem for me.

Thanks!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi there – I just submitted an “issue” for now, thanks. If it would not
spring automatically into formatting mode, but instead required a person to
click the link in order to to turn on formatting, that would fix my problem
I think!

Also – yep, I didn’t think that the “numbering starting at 1” was a bug, I
knew it was the intended behavior for markdown. I was just describing one
additional aspect of the problem for me.

Eric

sorry, here is the bug page for the issue I
created: http://manage.dimagi.com/default.asp?179722_d6ut350j58gdqshh