Sync from android

Hi,
I have install comm-care HQ on Ubuntu 14.04. Its running on my PC IP
192.168.100.3:8000
After deploying an application and scanning a bar code its not installing
in android and gives me the following error

Couldn't find your application.please check and retype your code

Thanks

sheeraz

Hi Sheeraz,

Check out this link
https://github.com/dimagi/commcare-hq/blob/474ac90617896c05676de7f1e56fd0743d48fffa/corehq/apps/builds/README.md#syncing-local-hq-instance-with-an-android-phone
for syncing your local commcare to a phone.

cheers,
Cory

··· On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood wrote:

Hi,
I have install comm-care HQ on Ubuntu 14.04. Its running on my PC IP
192.168.100.3:8000
After deploying an application and scanning a bar code its not
installing in android and gives me the following error

Couldn't find your application.please check and retype your code

Thanks

sheeraz


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks Cory for your response

I follow the link you provided .Nginx is installed and running on my IP
address .
I run Comm-care HQ by using ./scripts/docker runserver
In local settings of docker I set base address as my IP address.
But when I type http://192.168.100.3/a/test/dashboard/project/ in my browser
it gives me the following error
404 Not Found

··· ------------------------------ nginx/1.4.6 (Ubuntu)

On Monday, October 3, 2016 at 5:50:09 PM UTC+5, Cory Zue wrote:

Hi Sheeraz,

Check out this link
https://github.com/dimagi/commcare-hq/blob/474ac90617896c05676de7f1e56fd0743d48fffa/corehq/apps/builds/README.md#syncing-local-hq-instance-with-an-android-phone
for syncing your local commcare to a phone.

cheers,
Cory

On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood <sheeraz...@gmail.com <javascript:>> wrote:

Hi,
I have install comm-care HQ on Ubuntu 14.04. Its running on my PC IP
192.168.100.3:8000
After deploying an application and scanning a bar code its not
installing in android and gives me the following error

Couldn't find your application.please check and retype your code

Thanks

sheeraz


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/d/optout.

Hi Sheeraz,

Would be good to check nginx access and nginx error logs.
Also once you get this sorted, you should restart the django server and
create a new deploy once you set the BASE_ADDRESS to have updated links in
app source files. And then attempt to scan and download your app.

Regards,
Manish

··· On Tue, Oct 4, 2016 at 12:35 PM, Sheeraz Mahmood wrote:

Thanks Cory for your response

I follow the link you provided .Nginx is installed and running on my IP
address .
I run Comm-care HQ by using ./scripts/docker runserver
In local settings of docker I set base address as my IP address.
But when I type http://192.168.100.3/a/test/dashboard/project/ in my
browser
it gives me the following error
404 Not Found

nginx/1.4.6 (Ubuntu)

On Monday, October 3, 2016 at 5:50:09 PM UTC+5, Cory Zue wrote:

Hi Sheeraz,

Check out this link
https://github.com/dimagi/commcare-hq/blob/474ac90617896c05676de7f1e56fd0743d48fffa/corehq/apps/builds/README.md#syncing-local-hq-instance-with-an-android-phone
for syncing your local commcare to a phone.

cheers,
Cory

On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood sheeraz...@gmail.com wrote:

Hi,
I have install comm-care HQ on Ubuntu 14.04. Its running on my PC IP
192.168.100.3:8000
After deploying an application and scanning a bar code its not
installing in android and gives me the following error

Couldn't find your application.please check and retype your code

Thanks

sheeraz


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks Manish for your response

Now I am able to scan app and login it on android comm-care HQ
However when I try to submit form it give me the following error

6, in send_to_kafka
web_1 | _send_to_kafka()
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 17, in
_send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/producer/keyed.py", line 42, in
send_messages
web_1 | partition = self._next_partition(topic, key)
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/producer/keyed.py", line 33, in
_next_partition
web_1 | self.client.load_metadata_for_topics(topic)
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/client.py", line 378, in
load_metadata_for_topics
web_1 | kafka.common.check_error(topic_metadata)
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/common.py", line 233, in
check_error
web_1 | raise error_class(response)
web_1 | LeaderNotAvailableError: TopicMetadata(topic=‘form-sql’,
error=5, partitions=[])
web_1 | [04/Oct/2016 11:56:13] "POST
/a/test-project/receiver/secure/138f1d2de43888021531d4d95d3e7698/ HTTP/1.0"
500 599819

··· On Tuesday, October 4, 2016 at 1:42:04 PM UTC+5, Manish Kangia wrote: > > Hi Sheeraz, > > Would be good to check nginx access and nginx error logs. > Also once you get this sorted, you should restart the django server and > create a new deploy once you set the BASE_ADDRESS to have updated links in > app source files. And then attempt to scan and download your app. > > Regards, > Manish > > On Tue, Oct 4, 2016 at 12:35 PM, Sheeraz Mahmood <sheeraz...@gmail.com > wrote: > >> Thanks Cory for your response >> >> I follow the link you provided .Nginx is installed and running on my IP >> address . >> I run Comm-care HQ by using ./scripts/docker runserver >> In local settings of docker I set base address as my IP address. >> But when I type http://192.168.100.3/a/test/dashboard/project/ in my >> browser >> it gives me the following error >> 404 Not Found >> ------------------------------ >> nginx/1.4.6 (Ubuntu) >> >> >> On Monday, October 3, 2016 at 5:50:09 PM UTC+5, Cory Zue wrote: >>> >>> Hi Sheeraz, >>> >>> Check out this link >>> >>> for syncing your local commcare to a phone. >>> >>> cheers, >>> Cory >>> >>> On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood wrote: >>> >>>> Hi, >>>> I have install comm-care HQ on Ubuntu 14.04. Its running on my PC IP >>>> 192.168.100.3:8000 >>>> After deploying an application and scanning a bar code its not >>>> installing in android and gives me the following error >>>> >>>> Couldn't find your application.please check and retype your code >>>> >>>> Thanks >>>> >>>> sheeraz >>>> >>>> -- >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "CommCare Developers" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to commcare-developers+unsubscribe@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

Thats great Sheeraz!
Can you share how you got that fixed? Would be good to have if someone
stumbles upon the same thing.

From the error message seems like Kafka isn’t set up properly or not
running. Are you running services using docker set up?
If not, you can use
https://github.com/dimagi/commcare-hq/blob/master/docker/README.md for
reference. Takes care of all dependencies.

··· On Tue, Oct 4, 2016 at 5:29 PM, Sheeraz Mahmood wrote:

Thanks Manish for your response

Now I am able to scan app and login it on android comm-care HQ
However when I try to submit form it give me the following error

6, in send_to_kafka
web_1 | _send_to_kafka()
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 17, in _send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File “/vendor/lib/python2.7/site-
packages/kafka/producer/keyed.py”, line 42, in send_messages
web_1 | partition = self._next_partition(topic, key)
web_1 | File “/vendor/lib/python2.7/site-
packages/kafka/producer/keyed.py”, line 33, in _next_partition
web_1 | self.client.load_metadata_for_topics(topic)
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/client.py”,
line 378, in load_metadata_for_topics
web_1 | kafka.common.check_error(topic_metadata)
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/common.py”,
line 233, in check_error
web_1 | raise error_class(response)
web_1 | LeaderNotAvailableError: TopicMetadata(topic=‘form-sql’,
error=5, partitions=[])
web_1 | [04/Oct/2016 11:56:13] “POST /a/test-project/receiver/
secure/138f1d2de43888021531d4d95d3e7698/ HTTP/1.0” 500 599819

On Tuesday, October 4, 2016 at 1:42:04 PM UTC+5, Manish Kangia wrote:

Hi Sheeraz,

Would be good to check nginx access and nginx error logs.
Also once you get this sorted, you should restart the django server and
create a new deploy once you set the BASE_ADDRESS to have updated links in
app source files. And then attempt to scan and download your app.

Regards,
Manish

On Tue, Oct 4, 2016 at 12:35 PM, Sheeraz Mahmood sheeraz...@gmail.com wrote:

Thanks Cory for your response

I follow the link you provided .Nginx is installed and running on my IP
address .
I run Comm-care HQ by using ./scripts/docker runserver
In local settings of docker I set base address as my IP address.
But when I type http://192.168.100.3/a/test/dashboard/project/ in my
browser
it gives me the following error
404 Not Found

nginx/1.4.6 (Ubuntu)

On Monday, October 3, 2016 at 5:50:09 PM UTC+5, Cory Zue wrote:

Hi Sheeraz,

Check out this link
https://github.com/dimagi/commcare-hq/blob/474ac90617896c05676de7f1e56fd0743d48fffa/corehq/apps/builds/README.md#syncing-local-hq-instance-with-an-android-phone
for syncing your local commcare to a phone.

cheers,
Cory

On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood sheeraz...@gmail.com wrote:

Hi,
I have install comm-care HQ on Ubuntu 14.04. Its running on my PC IP
192.168.100.3:8000
After deploying an application and scanning a bar code its not
installing in android and gives me the following error

Couldn't find your application.please check and retype your code

Thanks

sheeraz


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Manish,

I fixed it by set up nginx/sites-enabled/default file to listen only 

IPV=6
Yes, I am using Docker
Now when I try to submit form it shows me following error

web_1 | Internal Server Error:
/a/test-commcare/receiver/secure/2e44b229583520e48832789100203e7d/
web_1 | Traceback (most recent call last):
web_1 | File
"/vendor/lib/python2.7/site-packages/django/core/handlers/base.py", line
111, in get_response
web_1 | response = wrapped_callback(request, *callback_args,
**callback_kwargs)
web_1 | File
"/vendor/lib/python2.7/site-packages/django/views/decorators/csrf.py", line
57, in wrapped_view
web_1 | return view_func(*args, **kwargs)
web_1 | File
"/vendor/lib/python2.7/site-packages/django/views/decorators/http.py", line
41, in inner
web_1 | return func(request, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py", line 227, in
secure_post
web_1 | return decorated_view(request, domain, app_id=app_id)
web_1 | File “/mnt/commcare-hq/corehq/apps/ota/utils.py”, line
181, in _inner
web_1 | response = f(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 180, in safe_fn
web_1 | return _inner(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 305, in _inner
web_1 | return fn(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/auth.py”,
line 80, in wrapper
web_1 | return view(request, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 238, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 176, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py", line 207, in
_secure_post_basic
web_1 | authenticated=True,
web_1 | File “/mnt/commcare-hq/corehq/util/datadog/utils.py”,
line 22, in _inner
web_1 | response = fn(*args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py", line 83, in
_process_form
web_1 |
openrosa_headers=couchforms.get_openrosa_headers(request),
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/submission_post.py", line 244, in
get_response
web_1 | response, _, _ = self.run()
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/submission_post.py", line 154, in
run
web_1 | self.interface.save_processed_models([instance])
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/interfaces/processor.py", line 126,
in save_processed_models
web_1 | stock_result=stock_result,
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/backends/sql/processor.py", line
89, in save_processed_models
web_1 | cls._publish_changes(processed_forms, cases,
stock_result)
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/backends/sql/processor.py", line
94, in _publish_changes
web_1 | publish_form_saved(processed_forms.submitted)
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/change_publishers.py", line 23, in
publish_form_saved
web_1 | producer.send_change(topics.FORM_SQL,
change_meta_from_sql_form(form))
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 74, in
send_change
web_1 | send_to_kafka(self.producer, topic, change_meta)
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 26, in
send_to_kafka
web_1 | _send_to_kafka()
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 17, in
_send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/producer/keyed.py", line 43, in
send_messages
web_1 | return self._send_messages(topic, partition, *msg,
key=key)
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/producer/base.py", line 390, in
_send_messages
web_1 | fail_on_error=self.sync_fail_on_error
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/client.py", line 480, in
send_produce_request
web_1 | (not fail_on_error or not
self._raise_on_response_error(resp))]
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/client.py", line 247, in
_raise_on_response_error
web_1 | raise resp
web_1 | FailedPayloadsError
web_1 | ERROR:django.request:Internal Server Error:
/a/test-commcare/receiver/secure/2e44b229583520e48832789100203e7d/
web_1 | Traceback (most recent call last):
web_1 | File
"/vendor/lib/python2.7/site-packages/django/core/handlers/base.py", line
111, in get_response
web_1 | response = wrapped_callback(request, *callback_args,
**callback_kwargs)
web_1 | File
"/vendor/lib/python2.7/site-packages/django/views/decorators/csrf.py", line
57, in wrapped_view
web_1 | return view_func(*args, **kwargs)
web_1 | File
"/vendor/lib/python2.7/site-packages/django/views/decorators/http.py", line
41, in inner
web_1 | return func(request, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py", line 227, in
secure_post
web_1 | return decorated_view(request, domain, app_id=app_id)
web_1 | File “/mnt/commcare-hq/corehq/apps/ota/utils.py”, line
181, in _inner
web_1 | response = f(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 180, in safe_fn
web_1 | return _inner(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 305, in _inner
web_1 | return fn(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/auth.py”,
line 80, in wrapper
web_1 | return view(request, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 238, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/domain/decorators.py", line 176, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py", line 207, in
_secure_post_basic
web_1 | authenticated=True,
web_1 | File “/mnt/commcare-hq/corehq/util/datadog/utils.py”,
line 22, in _inner
web_1 | response = fn(*args, **kwargs)
web_1 | File
"/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py", line 83, in
_process_form
web_1 |
openrosa_headers=couchforms.get_openrosa_headers(request),
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/submission_post.py", line 244, in
get_response
web_1 | response, _, _ = self.run()
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/submission_post.py", line 154, in
run
web_1 | self.interface.save_processed_models([instance])
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/interfaces/processor.py", line 126,
in save_processed_models
web_1 | stock_result=stock_result,
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/backends/sql/processor.py", line
89, in save_processed_models
web_1 | cls._publish_changes(processed_forms, cases,
stock_result)
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/backends/sql/processor.py", line
94, in _publish_changes
web_1 | publish_form_saved(processed_forms.submitted)
web_1 | File
"/mnt/commcare-hq/corehq/form_processor/change_publishers.py", line 23, in
publish_form_saved
web_1 | producer.send_change(topics.FORM_SQL,
change_meta_from_sql_form(form))
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 74, in
send_change
web_1 | send_to_kafka(self.producer, topic, change_meta)
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 26, in
send_to_kafka
web_1 | _send_to_kafka()
web_1 | File
"/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 17, in
_send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/producer/keyed.py", line 43, in
send_messages
web_1 | return self._send_messages(topic, partition, *msg,
key=key)
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/producer/base.py", line 390, in
_send_messages
web_1 | fail_on_error=self.sync_fail_on_error
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/client.py", line 480, in
send_produce_request
web_1 | (not fail_on_error or not
self._raise_on_response_error(resp))]
web_1 | File
"/vendor/lib/python2.7/site-packages/kafka/client.py", line 247, in
_raise_on_response_error
web_1 | raise resp
web_1 | FailedPayloadsError

··· On Tuesday, October 4, 2016 at 6:05:14 PM UTC+5, Manish Kangia wrote: > > Thats great Sheeraz! > Can you share how you got that fixed? Would be good to have if someone > stumbles upon the same thing. > > From the error message seems like Kafka isn't set up properly or not > running. Are you running services using docker set up? > If not, you can use > https://github.com/dimagi/commcare-hq/blob/master/docker/README.md for > reference. Takes care of all dependencies. > > On Tue, Oct 4, 2016 at 5:29 PM, Sheeraz Mahmood <sheeraz...@gmail.com > wrote: > >> Thanks Manish for your response >> >> Now I am able to scan app and login it on android comm-care HQ >> However when I try to submit form it give me the following error >> >> 6, in send_to_kafka >> web_1 | _send_to_kafka() >> web_1 | File >> "/mnt/commcare-hq/corehq/apps/change_feed/producer.py", line 17, in >> _send_to_kafka >> web_1 | bytes(json.dumps(change_meta.to_json())), >> web_1 | File >> "/vendor/lib/python2.7/site-packages/kafka/producer/keyed.py", line 42, in >> send_messages >> web_1 | partition = self._next_partition(topic, key) >> web_1 | File >> "/vendor/lib/python2.7/site-packages/kafka/producer/keyed.py", line 33, in >> _next_partition >> web_1 | self.client.load_metadata_for_topics(topic) >> web_1 | File >> "/vendor/lib/python2.7/site-packages/kafka/client.py", line 378, in >> load_metadata_for_topics >> web_1 | kafka.common.check_error(topic_metadata) >> web_1 | File >> "/vendor/lib/python2.7/site-packages/kafka/common.py", line 233, in >> check_error >> web_1 | raise error_class(response) >> web_1 | LeaderNotAvailableError: >> TopicMetadata(topic='form-sql', error=5, partitions=[]) >> web_1 | [04/Oct/2016 11:56:13] "POST >> /a/test-project/receiver/secure/138f1d2de43888021531d4d95d3e7698/ HTTP/1.0" >> 500 599819 >> >> >> >> >> On Tuesday, October 4, 2016 at 1:42:04 PM UTC+5, Manish Kangia wrote: >>> >>> Hi Sheeraz, >>> >>> Would be good to check nginx access and nginx error logs. >>> Also once you get this sorted, you should restart the django server and >>> create a new deploy once you set the BASE_ADDRESS to have updated links in >>> app source files. And then attempt to scan and download your app. >>> >>> Regards, >>> Manish >>> >>> On Tue, Oct 4, 2016 at 12:35 PM, Sheeraz Mahmood wrote: >>> >>>> Thanks Cory for your response >>>> >>>> I follow the link you provided .Nginx is installed and running on my IP >>>> address . >>>> I run Comm-care HQ by using ./scripts/docker runserver >>>> In local settings of docker I set base address as my IP address. >>>> But when I type http://192.168.100.3/a/test/dashboard/project/ in my >>>> browser >>>> it gives me the following error >>>> 404 Not Found >>>> ------------------------------ >>>> nginx/1.4.6 (Ubuntu) >>>> >>>> >>>> On Monday, October 3, 2016 at 5:50:09 PM UTC+5, Cory Zue wrote: >>>>> >>>>> Hi Sheeraz, >>>>> >>>>> Check out this link >>>>> >>>>> for syncing your local commcare to a phone. >>>>> >>>>> cheers, >>>>> Cory >>>>> >>>>> On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood wrote: >>>>> >>>>>> Hi, >>>>>> I have install comm-care HQ on Ubuntu 14.04. Its running on my PC >>>>>> IP 192.168.100.3:8000 >>>>>> After deploying an application and scanning a bar code its not >>>>>> installing in android and gives me the following error >>>>>> >>>>>> Couldn't find your application.please check and retype your code >>>>>> >>>>>> Thanks >>>>>> >>>>>> sheeraz >>>>>> >>>>>> -- >>>>>> >>>>>> --- >>>>>> You received this message because you are subscribed to the Google >>>>>> Groups "CommCare Developers" group. >>>>>> To unsubscribe from this group and stop receiving emails from it, >>>>>> send an email to commcare-developers+unsubscribe@googlegroups.com. >>>>>> For more options, visit https://groups.google.com/d/optout. >>>>>> >>>>> >>>>> -- >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "CommCare Developers" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to commcare-developers+unsubscribe@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

Hey,

It looks like your kafka setup is incomplete. You can try restarting the
kafka container on docker and also running ./manage.py create_kafka_topics.

··· On Wed, Oct 5, 2016 at 2:22 AM, Sheeraz Mahmood wrote:

Hi Manish,

I fixed it by set up nginx/sites-enabled/default file to listen only

IPV=6
Yes, I am using Docker
Now when I try to submit form it shows me following error

web_1 | Internal Server Error: /a/test-commcare/receiver/
secure/2e44b229583520e48832789100203e7d/
web_1 | Traceback (most recent call last):
web_1 | File “/vendor/lib/python2.7/site-
packages/django/core/handlers/base.py”, line 111, in get_response
web_1 | response = wrapped_callback(request,
*callback_args, **callback_kwargs)
web_1 | File “/vendor/lib/python2.7/site-
packages/django/views/decorators/csrf.py”, line 57, in wrapped_view
web_1 | return view_func(*args, **kwargs)
web_1 | File “/vendor/lib/python2.7/site-
packages/django/views/decorators/http.py”, line 41, in inner
web_1 | return func(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py”,
line 227, in secure_post
web_1 | return decorated_view(request, domain,
app_id=app_id)
web_1 | File “/mnt/commcare-hq/corehq/apps/ota/utils.py”,
line 181, in _inner
web_1 | response = f(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 180, in safe_fn
web_1 | return _inner(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 305, in _inner
web_1 | return fn(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/auth.py”,
line 80, in wrapper
web_1 | return view(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 238, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 176, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py”,
line 207, in _secure_post_basic
web_1 | authenticated=True,
web_1 | File “/mnt/commcare-hq/corehq/util/datadog/utils.py”,
line 22, in _inner
web_1 | response = fn(*args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py”,
line 83, in process_form
web_1 | openrosa_headers=couchforms.
get_openrosa_headers(request),
web_1 | File “/mnt/commcare-hq/corehq/form_processor/submission_post.py”,
line 244, in get_response
web_1 | response, , _ = self.run()
web_1 | File “/mnt/commcare-hq/corehq/form_processor/submission_post.py”,
line 154, in run
web_1 | self.interface.save_processed_models([instance])
web_1 | File "/mnt/commcare-hq/corehq/form

processor/interfaces/processor.py", line 126, in save_processed_models
web_1 | stock_result=stock_result,
web_1 | File "/mnt/commcare-hq/corehq/form

processor/backends/sql/processor.py", line 89, in save_processed_models
web_1 | cls.publish_changes(processed_forms, cases,
stock_result)
web_1 | File "/mnt/commcare-hq/corehq/form

processor/backends/sql/processor.py", line 94, in publish_changes
web_1 | publish_form_saved(processed_forms.submitted)
web_1 | File "/mnt/commcare-hq/corehq/form

processor/change_publishers.py", line 23, in publish_form_saved
web_1 | producer.send_change(topics.FORM_SQL,
change_meta_from_sql_form(form))
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 74, in send_change
web_1 | send_to_kafka(self.producer, topic, change_meta)
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 26, in send_to_kafka
web_1 | _send_to_kafka()
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 17, in _send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File “/vendor/lib/python2.7/site-
packages/kafka/producer/keyed.py”, line 43, in send_messages
web_1 | return self._send_messages(topic, partition, *msg,
key=key)
web_1 | File “/vendor/lib/python2.7/site-
packages/kafka/producer/base.py”, line 390, in _send_messages
web_1 | fail_on_error=self.sync_fail_on_error
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/client.py”,
line 480, in send_produce_request
web_1 | (not fail_on_error or not
self._raise_on_response_error(resp))]
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/client.py”,
line 247, in _raise_on_response_error
web_1 | raise resp
web_1 | FailedPayloadsError
web_1 | ERROR:django.request:Internal Server Error:
/a/test-commcare/receiver/secure/2e44b229583520e48832789100203e7d/
web_1 | Traceback (most recent call last):
web_1 | File “/vendor/lib/python2.7/site-
packages/django/core/handlers/base.py”, line 111, in get_response
web_1 | response = wrapped_callback(request,
*callback_args, **callback_kwargs)
web_1 | File “/vendor/lib/python2.7/site-
packages/django/views/decorators/csrf.py”, line 57, in wrapped_view
web_1 | return view_func(*args, **kwargs)
web_1 | File “/vendor/lib/python2.7/site-
packages/django/views/decorators/http.py”, line 41, in inner
web_1 | return func(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py”,
line 227, in secure_post
web_1 | return decorated_view(request, domain,
app_id=app_id)
web_1 | File “/mnt/commcare-hq/corehq/apps/ota/utils.py”,
line 181, in _inner
web_1 | response = f(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 180, in safe_fn
web_1 | return _inner(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 305, in _inner
web_1 | return fn(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/auth.py”,
line 80, in wrapper
web_1 | return view(request, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 238, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/domain/decorators.py”,
line 176, in _inner
web_1 | return fn(request, domain, *args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py”,
line 207, in _secure_post_basic
web_1 | authenticated=True,
web_1 | File “/mnt/commcare-hq/corehq/util/datadog/utils.py”,
line 22, in _inner
web_1 | response = fn(*args, **kwargs)
web_1 | File “/mnt/commcare-hq/corehq/apps/receiverwrapper/views.py”,
line 83, in process_form
web_1 | openrosa_headers=couchforms.
get_openrosa_headers(request),
web_1 | File “/mnt/commcare-hq/corehq/form_processor/submission_post.py”,
line 244, in get_response
web_1 | response, , _ = self.run()
web_1 | File “/mnt/commcare-hq/corehq/form_processor/submission_post.py”,
line 154, in run
web_1 | self.interface.save_processed_models([instance])
web_1 | File "/mnt/commcare-hq/corehq/form

processor/interfaces/processor.py", line 126, in save_processed_models
web_1 | stock_result=stock_result,
web_1 | File "/mnt/commcare-hq/corehq/form

processor/backends/sql/processor.py", line 89, in save_processed_models
web_1 | cls.publish_changes(processed_forms, cases,
stock_result)
web_1 | File "/mnt/commcare-hq/corehq/form

processor/backends/sql/processor.py", line 94, in publish_changes
web_1 | publish_form_saved(processed_forms.submitted)
web_1 | File "/mnt/commcare-hq/corehq/form

processor/change_publishers.py", line 23, in publish_form_saved
web_1 | producer.send_change(topics.FORM_SQL,
change_meta_from_sql_form(form))
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 74, in send_change
web_1 | send_to_kafka(self.producer, topic, change_meta)
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 26, in send_to_kafka
web_1 | _send_to_kafka()
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 17, in _send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File “/vendor/lib/python2.7/site-
packages/kafka/producer/keyed.py”, line 43, in send_messages
web_1 | return self._send_messages(topic, partition, *msg,
key=key)
web_1 | File “/vendor/lib/python2.7/site-
packages/kafka/producer/base.py”, line 390, in _send_messages
web_1 | fail_on_error=self.sync_fail_on_error
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/client.py”,
line 480, in send_produce_request
web_1 | (not fail_on_error or not
self._raise_on_response_error(resp))]
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/client.py”,
line 247, in _raise_on_response_error
web_1 | raise resp
web_1 | FailedPayloadsError

On Tuesday, October 4, 2016 at 6:05:14 PM UTC+5, Manish Kangia wrote:

Thats great Sheeraz!
Can you share how you got that fixed? Would be good to have if someone
stumbles upon the same thing.

From the error message seems like Kafka isn’t set up properly or not
running. Are you running services using docker set up?
If not, you can use https://github.com/dimagi/
commcare-hq/blob/master/docker/README.md for reference. Takes care of
all dependencies.

On Tue, Oct 4, 2016 at 5:29 PM, Sheeraz Mahmood sheeraz...@gmail.com wrote:

Thanks Manish for your response

Now I am able to scan app and login it on android comm-care HQ
However when I try to submit form it give me the following error

6, in send_to_kafka
web_1 | _send_to_kafka()
web_1 | File “/mnt/commcare-hq/corehq/apps/change_feed/producer.py”,
line 17, in _send_to_kafka
web_1 | bytes(json.dumps(change_meta.to_json())),
web_1 | File “/vendor/lib/python2.7/site-pa
ckages/kafka/producer/keyed.py”, line 42, in send_messages
web_1 | partition = self._next_partition(topic, key)
web_1 | File “/vendor/lib/python2.7/site-pa
ckages/kafka/producer/keyed.py”, line 33, in _next_partition
web_1 | self.client.load_metadata_for_topics(topic)
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/client.py”,
line 378, in load_metadata_for_topics
web_1 | kafka.common.check_error(topic_metadata)
web_1 | File “/vendor/lib/python2.7/site-packages/kafka/common.py”,
line 233, in check_error
web_1 | raise error_class(response)
web_1 | LeaderNotAvailableError:
TopicMetadata(topic=‘form-sql’, error=5, partitions=[])
web_1 | [04/Oct/2016 11:56:13] “POST
/a/test-project/receiver/secure/138f1d2de43888021531d4d95d3e7698/
HTTP/1.0” 500 599819

On Tuesday, October 4, 2016 at 1:42:04 PM UTC+5, Manish Kangia wrote:

Hi Sheeraz,

Would be good to check nginx access and nginx error logs.
Also once you get this sorted, you should restart the django server and
create a new deploy once you set the BASE_ADDRESS to have updated links in
app source files. And then attempt to scan and download your app.

Regards,
Manish

On Tue, Oct 4, 2016 at 12:35 PM, Sheeraz Mahmood sheeraz...@gmail.com wrote:

Thanks Cory for your response

I follow the link you provided .Nginx is installed and running on my
IP address .
I run Comm-care HQ by using ./scripts/docker runserver
In local settings of docker I set base address as my IP address.
But when I type http://192.168.100.3/a/test/dashboard/project/ in my
browser
it gives me the following error
404 Not Found

nginx/1.4.6 (Ubuntu)

On Monday, October 3, 2016 at 5:50:09 PM UTC+5, Cory Zue wrote:

Hi Sheeraz,

Check out this link
https://github.com/dimagi/commcare-hq/blob/474ac90617896c05676de7f1e56fd0743d48fffa/corehq/apps/builds/README.md#syncing-local-hq-instance-with-an-android-phone
for syncing your local commcare to a phone.

cheers,
Cory

On Mon, Oct 3, 2016 at 4:54 AM, Sheeraz Mahmood <sheeraz...@gmail.com wrote:

Hi,
I have install comm-care HQ on Ubuntu 14.04. Its running on my PC
IP 192.168.100.3:8000
After deploying an application and scanning a bar code its not
installing in android and gives me the following error

Couldn't find your application.please check and retype your code

Thanks

sheeraz


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

This post was flagged by the community and is temporarily hidden.