Subscription level issues

We’re running a QA box (latest build as at today) as a monolith and are running into issues with the subscription level.

Right now, ENTERPRISE_MODE = True in our config and there doesn’t appear to be any way to access and modify the subscription level from the UI, it’s only available if I visit the following URL (entered manually):
https://mysite.com/a/myproject/settings/project/internal_subscription_management/

Despite having set it to ‘Contracted Partner’ and ‘Advanced’ software plan, we still don’t see the ‘Web Apps’ menu option in the main application:

Also, where do we increase the report builder report limit?

Thanks in advance!

Hi Ed,

For an enterprise environment, you can run the following command:

$ ./manage.py make_domain_enterprise_level <project name>

That should put your project on an unlimited plan, which will also remove the report builder limit.

I believe the “internal subscription management” page is hidden from the menus in ENTERPRISE_MODE, since there shouldn’t be a need to configure anything manually.

Thanks Ethan, I seem to be missing some info on where that command is run from. I can see manage.py in a number of places in the file system.
Thanks!

EDIT I see I can run it with
commcare-cloud django-manage xxxxx

EDIT again: I received an error:

cchq monolith django-manage make_domain_enterprise_level ZDIP

ssh 10.0.0.4 -o UserKnownHostsFile=/home/ccc/environments/monolith/known_hosts ‘sudo -u cchq bash -c “cd /home/cchq/www/monolith/current; python_env/bin/python manage.py make_domain_enterprise_level ZDIP”’
Ubuntu 18.04.2 LTS
/home/cchq/www/monolith/releases/2019-07-26_11.22/python_env/local/lib/python2.7/site-packages/psycopg2/init.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use “pip install psycopg2-binary” instead. For details see: http://initd.org/psycopg/docs/install.html#binary-install-from-pypi.
“”")
2019-07-30 10:35:22,550 INFO Raven is not configured (logging is disabled). Please see the documentation for more information.
2019-07-30 10:35:23,186 INFO AXES: BEGIN LOG
Traceback (most recent call last):
File “manage.py”, line 207, in
execute_from_command_line(sys.argv)
File “/home/cchq/www/monolith/releases/2019-07-26_11.22/python_env/local/lib/python2.7/site-packages/django/core/management/init.py”, line 364, in execute_from_command_line
utility.execute()
File “/home/cchq/www/monolith/releases/2019-07-26_11.22/python_env/local/lib/python2.7/site-packages/django/core/management/init.py”, line 356, in execute
self.fetch_command(subcommand).run_from_argv(self.argv)
File “/home/cchq/www/monolith/releases/2019-07-26_11.22/python_env/local/lib/python2.7/site-packages/django/core/management/base.py”, line 283, in run_from_argv
self.execute(*args, **cmd_options)
File “/home/cchq/www/monolith/releases/2019-07-26_11.22/python_env/local/lib/python2.7/site-packages/django/core/management/base.py”, line 330, in execute
output = self.handle(*args, **options)
File “/home/cchq/www/monolith/releases/2019-07-26_11.22/corehq/util/decorators.py”, line 25, in decorated
with self:
File “/home/cchq/www/monolith/releases/2019-07-26_11.22/corehq/util/decorators.py”, line 72, in enter
raise Exception(“This can only be called in DEBUG mode.”)
Exception: This can only be called in DEBUG mode.

Hi Ed, you’re right, sorry about that. It looks like that command is set up to only be allowed in testing environments, presumably to ensure no one mistakenly turns it on for a real project. Looking at this a little closer, I’m not sure we have a good way to enable subscriptions for self-hosted projects. I’ll forward this to our support team to see if they can address it properly.

In the meantime, in your first message, you showed a screenshot of the “Dimagi Internal Subscription Management” page. In the first dropdown, “Subscription Type”, you should see an option “Test or Demo Project”. That will also enable the same enterprise subscription as the command I referenced in my last message. Does that work for you?

1 Like

That looks spot on Ethan, thanks!