Stand alone setup question, Issues with final steps

After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “./manage.py syncdb –noinput

I get a bit of output first, please see attached, that ends with the following error:

restkit.errors.Unauthorized: {‘msg’: ‘’, ‘status_int’: 401, ‘response’: <couchdbkit.resource.CouchDBResponse object at 0x3ba2b50>}

I added the full text of the output as an attachment to keep things short.

During the setup I am able to access CouchDB and created the user and database as instructed.

Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated.

Many Thanks!

manage.py output (4.5 KB)

It looks like your couch authentication isn’t properly setup. I would
double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure
they are a valid admin user on your couch instance.

··· On Mon, Jul 6, 2015 at 12:58 PM, wrote:

After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “./manage.py syncdb –noinput

I get a bit of output first, please see attached, that ends with the following error:

restkit.errors.Unauthorized: {‘msg’: ‘’, ‘status_int’: 401, ‘response’: <couchdbkit.resource.CouchDBResponse object at 0x3ba2b50>}

I added the full text of the output as an attachment to keep things short.

During the setup I am able to access CouchDB and created the user and database as instructed.

Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated.

Many Thanks!


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Cory

Thanks for the response. I will check those two items and try again. I will
report back the results. Many Thanks!

··· On Monday, July 6, 2015 at 4:53:39 AM UTC-7, Cory Zue wrote: > > It looks like your couch authentication isn't properly setup. I would > double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure > they are a valid admin user on your couch instance. > > > > > On Mon, Jul 6, 2015 at 12:58 PM, <race...@comcast.net > wrote: > >> After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “*./manage.py syncdb –noinput*” >> >> I get a bit of output first, please see attached, that ends with the following error: >> >> >> >> *restkit.errors.Unauthorized: {'msg': '', 'status_int': 401, 'response': }* >> >> >> >> I added the full text of the output as an attachment to keep things short. >> >> >> >> During the setup I am able to access CouchDB and created the user and database as instructed. >> >> Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated. >> >> *Many Thanks!* >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to . >> For more options, visit https://groups.google.com/d/optout. >> > >

Yes, there is definitely something going on with authentication as you
suggested. To test I did the following. I created a new ID:

*username@mind-commcarehq:~$ curl -X PUT
"http://localhost:5984/_config/users/commcarehq4" -d
"commcarehq4"""username@mind-commcarehq:~$ *
Then I immediately tested to see if I could connect with that ID:

*username@mind-commcarehq:~$ curl -X POST http://localhost:5984/_session -d
’name=commcarehq4&password=commcarehq4’{“error”:“unauthorized”,“reason”:“Name
or password is incorrect.”}username@mind-commcarehq:~$ *

This is not the response that should come back. I also noticed that maybe
the /users/ in the CURL user creation command should probably be
/admins/ ? So, I removed couchDB and deleted the couchdb directories
under /var/lib and /etc. Then I installed couchDB again. This produced
similar results and everything I tried gave me an “already exists” error
message.

During this entire process I have made constant snapshots for this very
reason. So now I am going revert to a snapshot from before and start this
over. I will report back when complete.

Many thanks again for your help. Think I am on the right path now. I will
update you again in a bit.

··· On Monday, July 6, 2015 at 4:53:39 AM UTC-7, Cory Zue wrote: > > It looks like your couch authentication isn't properly setup. I would > double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure > they are a valid admin user on your couch instance. > > > > > On Mon, Jul 6, 2015 at 12:58 PM, <race...@comcast.net > wrote: > >> After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “*./manage.py syncdb –noinput*” >> >> I get a bit of output first, please see attached, that ends with the following error: >> >> >> >> *restkit.errors.Unauthorized: {'msg': '', 'status_int': 401, 'response': }* >> >> >> >> I added the full text of the output as an attachment to keep things short. >> >> >> >> During the setup I am able to access CouchDB and created the user and database as instructed. >> >> Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated. >> >> *Many Thanks!* >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to >> For more options, visit https://groups.google.com/d/optout. >> > >

Walking through the steps again with the one change to the couchdb user
creation as suggested works. I am signed into a working CommCareHQ
installation on a local VM. I am about to run some tests but all is looking
good at the moment. Just a bit more work and this should be ready for use…

Many thanks for your help! Many Thanks!

··· On Monday, July 6, 2015 at 4:53:39 AM UTC-7, Cory Zue wrote: > > It looks like your couch authentication isn't properly setup. I would > double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure > they are a valid admin user on your couch instance. > > > > > On Mon, Jul 6, 2015 at 12:58 PM, <race...@comcast.net > wrote: > >> After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “*./manage.py syncdb –noinput*” >> >> I get a bit of output first, please see attached, that ends with the following error: >> >> >> >> *restkit.errors.Unauthorized: {'msg': '', 'status_int': 401, 'response': }* >> >> >> >> I added the full text of the output as an attachment to keep things short. >> >> >> >> During the setup I am able to access CouchDB and created the user and database as instructed. >> >> Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated. >> >> *Many Thanks!* >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to >> For more options, visit https://groups.google.com/d/optout. >> > >

glad to hear it!

cheers

··· On Mon, Jul 13, 2015 at 12:23 PM, wrote:

Walking through the steps again with the one change to the couchdb user
creation as suggested works. I am signed into a working CommCareHQ
installation on a local VM. I am about to run some tests but all is looking
good at the moment. Just a bit more work and this should be ready for use…

Many thanks for your help! Many Thanks!

On Monday, July 6, 2015 at 4:53:39 AM UTC-7, Cory Zue wrote:

It looks like your couch authentication isn’t properly setup. I would
double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure
they are a valid admin user on your couch instance.

On Mon, Jul 6, 2015 at 12:58 PM, race...@comcast.net wrote:

After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “./manage.py syncdb –noinput

I get a bit of output first, please see attached, that ends with the following error:

restkit.errors.Unauthorized: {‘msg’: ‘’, ‘status_int’: 401, ‘response’: <couchdbkit.resource.CouchDBResponse object at 0x3ba2b50>}

I added the full text of the output as an attachment to keep things short.

During the setup I am able to access CouchDB and created the user and database as instructed.

Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated.

Many Thanks!


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Yes, almost there. However once logged in I am seeing in the under Admin
Reports System Info
the following:

Celery Monitor: Error with getting from celery_flower: socket.error:
[Errno 111] Connection refused

even though Celery Heartbeat says: “OK”

and

under ElasticSearch Status if I click* Index Status check* the following
is returned: [{“hqcases_7a8d2b81335e0a8cef1de718313a23b9”: {“status”:
false, “index”: “hqcases_7a8d2b81335e0a8cef1de718313a23b9”, “message”: “Not
in sync - query failed”}}, {“xforms_20150403-1728”: {“status”: false,
“index”: “xforms_20150403-1728”, “message”: “Not in sync - query failed”}},
{}, {}]

If this is something i should dig into in terms of Celery config just let
me know and I will but I am hoping I am just missing some quick
configuration change.

Many Thanks!

··· On Monday, July 13, 2015 at 3:37:21 AM UTC-7, Cory Zue wrote: > > glad to hear it! > > cheers > > On Mon, Jul 13, 2015 at 12:23 PM, <race...@comcast.net > wrote: > >> Walking through the steps again with the one change to the couchdb user >> creation as suggested works. I am signed into a working CommCareHQ >> installation on a local VM. I am about to run some tests but all is looking >> good at the moment. Just a bit more work and this should be ready for use.. >> >> Many thanks for your help! Many Thanks! >> >> >> >> On Monday, July 6, 2015 at 4:53:39 AM UTC-7, Cory Zue wrote: >>> >>> It looks like your couch authentication isn't properly setup. I would >>> double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure >>> they are a valid admin user on your couch instance. >>> >>> >>> >>> >>> On Mon, Jul 6, 2015 at 12:58 PM, wrote: >>> >>>> After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “*./manage.py syncdb –noinput*” >>>> >>>> I get a bit of output first, please see attached, that ends with the following error: >>>> >>>> >>>> >>>> *restkit.errors.Unauthorized: {'msg': '', 'status_int': 401, 'response': }* >>>> >>>> >>>> >>>> I added the full text of the output as an attachment to keep things short. >>>> >>>> >>>> >>>> During the setup I am able to access CouchDB and created the user and database as instructed. >>>> >>>> Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated. >>>> >>>> *Many Thanks!* >>>> >>>> -- >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "CommCare Developers" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to >> For more options, visit https://groups.google.com/d/optout. >> > >

Hey,

I think you can likely ignore both of those errors.

Celery Monitor: Error with getting from celery_flower: socket.error:
[Errno 111] Connection refused

Flower is a separate monitoring tool we install for celery. Not sure if we
have instructions for it but you can set it up according to their website
http://flower.readthedocs.org/en/latest/.

even though Celery Heartbeat says: “OK”

and

under ElasticSearch Status if I click* Index Status check* the
following is returned: [{“hqcases_7a8d2b81335e0a8cef1de718313a23b9”:
{“status”: false, “index”: “hqcases_7a8d2b81335e0a8cef1de718313a23b9”,
“message”: “Not in sync - query failed”}}, {“xforms_20150403-1728”:
{“status”: false, “index”: “xforms_20150403-1728”, “message”: "Not in sync

  • query failed"}}, {}, {}]

Do you have any data saved? I think that button only works if you have a
form and case saved. Also you need to be running the elasticsearch pillows.
(./manage.py run_ptop --all)

cheers,
Cory

··· > If this is something i should dig into in terms of Celery config just let > me know and I will but I am hoping I am just missing some quick > configuration change. > > Many Thanks! > > > > > > On Monday, July 13, 2015 at 3:37:21 AM UTC-7, Cory Zue wrote: >> >> glad to hear it! >> >> cheers >> >> On Mon, Jul 13, 2015 at 12:23 PM, wrote: >> >>> Walking through the steps again with the one change to the couchdb user >>> creation as suggested works. I am signed into a working CommCareHQ >>> installation on a local VM. I am about to run some tests but all is looking >>> good at the moment. Just a bit more work and this should be ready for use.. >>> >>> Many thanks for your help! Many Thanks! >>> >>> >>> >>> On Monday, July 6, 2015 at 4:53:39 AM UTC-7, Cory Zue wrote: >>>> >>>> It looks like your couch authentication isn't properly setup. I would >>>> double check your COUCH_USERNAME and COUCH_PASSWORD settings and make sure >>>> they are a valid admin user on your couch instance. >>>> >>>> >>>> >>>> >>>> On Mon, Jul 6, 2015 at 12:58 PM, wrote: >>>> >>>>> After following all of the steps here to install and configure the dependencies for a CommcareHQ installation on Ubuntu 12.05: https://github.com/dimagi/commcare-hq I managed to successfully make it to the “Set up your django environment” step and that is when my issues started. Up until this point the instructions as written worked for the most part. I was able to install the dependencies and test access to them just fine. However when I ran the first step of “Set up your django environment “ I get the an error when running “*./manage.py syncdb –noinput*” >>>>> >>>>> I get a bit of output first, please see attached, that ends with the following error: >>>>> >>>>> >>>>> >>>>> *restkit.errors.Unauthorized: {'msg': '', 'status_int': 401, 'response': }* >>>>> >>>>> >>>>> >>>>> I added the full text of the output as an attachment to keep things short. >>>>> >>>>> >>>>> >>>>> During the setup I am able to access CouchDB and created the user and database as instructed. >>>>> >>>>> Did I totally miss some step? Any pointers in the right direction for additional configuration notes that might help with this issue would be greatly appreciated. >>>>> >>>>> *Many Thanks!* >>>>> >>>>> -- >>>>> >>>>> --- >>>>> You received this message because you are subscribed to the Google >>>>> Groups "CommCare Developers" group. >>>>> To unsubscribe from this group and stop receiving emails from it, send >>>>> an email to >>>>> For more options, visit https://groups.google.com/d/optout. >>>>> >>>> >>>> -- >>> >>> --- >>> You received this message because you are subscribed to the Google >>> Groups "CommCare Developers" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> -- > > --- > You received this message because you are subscribed to the Google Groups > "CommCare Developers" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to commcare-developers+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout. >

Cory

Many Thanks!

I am working on the flower install now using the link you provided.

I am running elasticsearch pillows but this instance has no saved data, no
forms or cases at this time as you surmised already.

I will let project group test out site later today as this is just for
development, I believe they have forms ready. However I spoke with Ryan
Hartford at Dimagi.com today as I think the project should be using the
hosted version for their actual production.

Thanks again!

··· On Monday, July 13, 2015 at 5:28:19 AM UTC-7, Cory Zue wrote: > > Hey, > > I think you can likely ignore both of those errors. > >> >> >> *Celery Monitor*: Error with getting from celery_flower: socket.error: >> [Errno 111] Connection refused >> > > Flower is a separate monitoring tool we install for celery. Not sure if we > have instructions for it but you can set it up according to their website > . > > >> even though *Celery Heartbeat* says: "OK" >> >> and >> >> under E*lasticSearch Status* if I click* Index Status check* the >> following is returned: [{"hqcases_7a8d2b81335e0a8cef1de718313a23b9": >> {"status": false, "index": "hqcases_7a8d2b81335e0a8cef1de718313a23b9", >> "message": "Not in sync - query failed"}}, {"xforms_20150403-1728": >> {"status": false, "index": "xforms_20150403-1728", "message": "Not in sync >> - query failed"}}, {}, {}] >> > > Do you have any data saved? I think that button only works if you have a > form and case saved. Also you need to be running the elasticsearch pillows. > (./manage.py run_ptop --all) > > cheers, > Cory > >