"Server.received_on" in a strange format

Hi all –

One of my exports that I run often is showing its *Server.received_on *field
as being in a different format than all the other forms have always shown
it.

Usually that field appears in this format: 2015-11-19 08:01:40

But one of my forms now shows it as in this format:
2016-03-21T03:24:02.790366Z

Can you tell me what caused this different format … and any other
significance of this?

[The app is epm-laos, the form is the one called A4]

Thanks!
Eric

Just poking this thread… does anyone know why one of my forms has “server
received on” in a different format? I think it’s smart that this isn’t
indicating some odd configuration or app issue (though I don’t predict that
it is)

Thanks!
Eric

Hi Eric

The format I would expect to see for that field is the second one
(2016-03-21T03:24:02.790366Z).
Is it possible that anything in the export configuration changed e.g.
“Automatically
convert dates for Excel”?

I ran the export with the following filters and saw that all the
’received_on’ dates appear in the ISO format (YYYY-MM-DDTHH:MM:SS.ssssssZ)
and I also didn’t see any forms with the received on date of ‘2015-11-19’:

  • All users
  • Date range: 2015-08-21 to 2016-05-05

Having said that we have been doing some work on the exports backend
recently and it’s possible we’ve inadvertently changed something that would
affect this. Do you have an old export with the old date format that you
could send me for comparison (you can send it to me directly)?

··· On 5 May 2016 at 06:22, Eric Stephan wrote:

Just poking this thread… does anyone know why one of my forms has
"server received on" in a different format? I think it’s smart that this
isn’t indicating some odd configuration or app issue (though I don’t
predict that it is)

Thanks!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Hi! Thanks much. With your info, i think this is an easy issue. when I
make all of my reports, I always habituall click "convert dates for excel"
because my data is destined for excel so that seemed wise. Now I see that
just on that one form I did not click that option. So… trivial to fix!

Thanks much! I tend to get worked up over small things, imagining they are
harbingers of disaster

Eric

Glad it’s sorted out.

··· On 6 May 2016 at 07:00, Eric Stephan wrote:

Hi! Thanks much. With your info, i think this is an easy issue. when I
make all of my reports, I always habituall click "convert dates for excel"
because my data is destined for excel so that seemed wise. Now I see that
just on that one form I did not click that option. So… trivial to fix!

Thanks much! I tend to get worked up over small things, imagining they
are harbingers of disaster

Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa