Required Questions that were skipped

Hello-
I have been reviewing data and it looks like a whole set of questions were
skipped when they are in fact a required question. I’ve tried to re-create
this myself but when I try I keep getting the notification that I need to
respond to the questions that are highlighted in red.

Anyone have any ideas? I’d love to “find” the missing data if it’s
possible.

Thanks!
L

Hi Laura,

Questions are only required if the display condition is met. Is it
possible that there are display conditions on the required questions which
meant that sometimes they were not visible to users?

Another possibility is if some users worked on a different version of the
app in which not all of the same questions were required.

Thanks,

Jeremy

··· On Mon, Apr 25, 2016 at 6:02 PM, Laura Harrington wrote:

Hello-
I have been reviewing data and it looks like a whole set of questions were
skipped when they are in fact a required question. I’ve tried to re-create
this myself but when I try I keep getting the notification that I need to
respond to the questions that are highlighted in red.

Anyone have any ideas? I’d love to “find” the missing data if it’s
possible.

Thanks!
L


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Jeremy Wacksman
Dimagi http://www.dimagi.com, Inc.

Jeremy -
thanks for your response.

For the section where I’m not seeing data there is a display condition so
for the section depending on the interviewees title they woudl have been
asked a set of questions. So regardless some of the questions should have
been answered. That’s what’s perplexing.
Any other thoughts?
Thanks!
L

··· On Monday, April 25, 2016 at 3:12:38 PM UTC-7, Jeremy Wacksman wrote: > > Hi Laura, > > Questions are only required if the display condition is met. Is it > possible that there are display conditions on the required questions which > meant that sometimes they were not visible to users? > > Another possibility is if some users worked on a different version of the > app in which not all of the same questions were required. > > Thanks, > > Jeremy > > On Mon, Apr 25, 2016 at 6:02 PM, Laura Harrington <lkharr...@gmail.com > wrote: > >> Hello- >> I have been reviewing data and it looks like a whole set of questions >> were skipped when they are in fact a required question. I've tried to >> re-create this myself but when I try I keep getting the notification that I >> need to respond to the questions that are highlighted in red. >> >> Anyone have any ideas? I'd love to "find" the missing data if it's >> possible. >> >> Thanks! >> L >> >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Jeremy Wacksman > Dimagi , Inc. > >

Hi Laura,

To troubleshoot this issue I would try to zero in on a specific example
where you think there should be data and find that form via the Submit
History report (
https://confluence.dimagi.com/display/commcarepublic/Submit+History). That
will show you the raw data from the form and you can confirm that the form
was filled out as you expect, compare the version of the app
(Form|@Version) to a form that seemed correctly populated, and confirm that
the question ID did not get changed at some point.

Hope this helps!

Jeremy

··· On Mon, Apr 25, 2016 at 6:39 PM, Laura Harrington wrote:

Jeremy -
thanks for your response.

For the section where I’m not seeing data there is a display condition so
for the section depending on the interviewees title they woudl have been
asked a set of questions. So regardless some of the questions should have
been answered. That’s what’s perplexing.
Any other thoughts?
Thanks!
L

On Monday, April 25, 2016 at 3:12:38 PM UTC-7, Jeremy Wacksman wrote:

Hi Laura,

Questions are only required if the display condition is met. Is it
possible that there are display conditions on the required questions which
meant that sometimes they were not visible to users?

Another possibility is if some users worked on a different version of the
app in which not all of the same questions were required.

Thanks,

Jeremy

On Mon, Apr 25, 2016 at 6:02 PM, Laura Harrington lkharr...@gmail.com wrote:

Hello-
I have been reviewing data and it looks like a whole set of questions
were skipped when they are in fact a required question. I’ve tried to
re-create this myself but when I try I keep getting the notification that I
need to respond to the questions that are highlighted in red.

Anyone have any ideas? I’d love to “find” the missing data if it’s
possible.

Thanks!
L


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-user...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Jeremy Wacksman
Dimagi http://www.dimagi.com, Inc.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Jeremy Wacksman
Dimagi http://www.dimagi.com, Inc.