Question ID coming out with categoryID as well as question ID & custom form export not showing new version questions

Hi, 2 inter-related questions:

  1. when I download data using ‘export full forms’, the variable names
    (called question ID in the form) come out with their category name as well
    as their ID. For example I have a variable/ID called art_able that falls
    under a collection of questions in the same category/folder that has an ID
    called ‘linkage_to_care’. The data therefore comes out with the name
    ’|art_able |linkage_to_care|art_able’ when I want it to just be art_able.

  2. So to try to remedy for this I tried to create a custom form for export
    but when I select ‘forms’ I see the questions and display names from a
    previous version of the form and not the most recent one. This happens
    despite the export name at the top showing the correct date of the form.
    Not sure how to ‘refresh’ the form questions and display.

Please help!
Thank you.

Hi,

  1. when I download data using ‘export full forms’, the variable names

(called question ID in the form) come out with their category name as well
as their ID. For example I have a variable/ID called art_able that falls
under a collection of questions in the same category/folder that has an ID
called ‘linkage_to_care’. The data therefore comes out with the name
’|art_able |linkage_to_care|art_able’ when I want it to just be art_able.

This is expected behavior. You were right that you should use a custom
export to solve this.

  1. So to try to remedy for this I tried to create a custom form for export
    but when I select ‘forms’ I see the questions and display names from a
    previous version of the form and not the most recent one. This happens
    despite the export name at the top showing the correct date of the form.
    Not sure how to ‘refresh’ the form questions and display.

You can always see all possible questions by checking the box that says
"Show Deleted Questions and Advanced Properties". If there are questions
that aren’t showing up but are included in the most recent version of your
app you can report an issue and someone will take a look.

Cory

··· > Please help! > Thank you. > > -- > You received this message because you are subscribed to the Google Groups > "commcare-users" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to commcare-users+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout. >