Pushing new app/form versions over cellular data

Hi everyone,

My colleague was testing out our pilot CommCare app in rural Senegal and
was unable to update to the new version i deployed using 'Update CommCare’
on the menu on cellular data or on slower wifi in the field - however, it
worked when she was on better wifi, and I think she had some more luck on a
slower connection deleting the data and reinstalling from the bit.ly link.

We’re trying to get a sense of how realistic it is to deploy new versions
and under different conditions. Has anyone had experience updating to new
versions on cellular data or slower wifi successfully? Or do you only have
field agents update when there’s better internet connection (or the offline
install)? Any tips or advice for this?

Thanks!
Emily

Emily,

I’m curious, were you updating an app including multimedia, or just
including form content? We’ve had a lot of successes performing OTA updates
on low-bandwidth high-latency cellular connections in the past without
multimedia, but updating media files tends to make the process
significantly less reliable.

-Clayton

··· On Fri, Jul 18, 2014 at 5:49 AM, wrote:

Hi everyone,

My colleague was testing out our pilot CommCare app in rural Senegal and
was unable to update to the new version i deployed using 'Update CommCare’
on the menu on cellular data or on slower wifi in the field - however, it
worked when she was on better wifi, and I think she had some more luck on a
slower connection deleting the data and reinstalling from the bit.ly
link.

We’re trying to get a sense of how realistic it is to deploy new versions
and under different conditions. Has anyone had experience updating to new
versions on cellular data or slower wifi successfully? Or do you only have
field agents update when there’s better internet connection (or the offline
install)? Any tips or advice for this?

Thanks!
Emily


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Clayton,

The app did not include any multi-media, just form content. It seemed to just not get back the last step. Is there something I can try or a log I can get to help figure out what might be going on?

Thanks,
Emily

··· On Friday, July 18, 2014 at 8:17 PM, Clayton Sims wrote:

Emily,

I’m curious, were you updating an app including multimedia, or just including form content? We’ve had a lot of successes performing OTA updates on low-bandwidth high-latency cellular connections in the past without multimedia, but updating media files tends to make the process significantly less reliable.

-Clayton

On Fri, Jul 18, 2014 at 5:49 AM, <emily@aquaya.org (mailto:emily@aquaya.org)> wrote:

Hi everyone,

My colleague was testing out our pilot CommCare app in rural Senegal and was unable to update to the new version i deployed using ‘Update CommCare’ on the menu on cellular data or on slower wifi in the field - however, it worked when she was on better wifi, and I think she had some more luck on a slower connection deleting the data and reinstalling from the bit.ly (http://bit.ly) link.

We’re trying to get a sense of how realistic it is to deploy new versions and under different conditions. Has anyone had experience updating to new versions on cellular data or slower wifi successfully? Or do you only have field agents update when there’s better internet connection (or the offline install)? Any tips or advice for this?

Thanks!
Emily


You received this message because you are subscribed to the Google Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send an email to commcare-users+unsubscribe@googlegroups.com (mailto:commcare-users+unsubscribe@googlegroups.com).
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “commcare-users” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-users/TFfCmvVgsFI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to commcare-users+unsubscribe@googlegroups.com (mailto:commcare-users+unsubscribe@googlegroups.com).
For more options, visit https://groups.google.com/d/optout.

Emily,

What do you mean by the last step? Was it proceeding without issue until
the end and then choking before it could finish?

With network issues it’s a bit difficult to expose great debugging
information, unfortunately. It would be really helpful to know what the
screens say when the updates aren’t working.

-Clayton

··· On Mon, Jul 21, 2014 at 3:01 AM, 'Emily Kumpel' via commcare-users < commcare-users@googlegroups.com> wrote:

Hi Clayton,

The app did not include any multi-media, just form content. It seemed to
just not get back the last step. Is there something I can try or a log I
can get to help figure out what might be going on?

Thanks,
Emily

On Friday, July 18, 2014 at 8:17 PM, Clayton Sims wrote:

Emily,

I’m curious, were you updating an app including multimedia, or just
including form content? We’ve had a lot of successes performing OTA updates
on low-bandwidth high-latency cellular connections in the past without
multimedia, but updating media files tends to make the process
significantly less reliable.

-Clayton

On Fri, Jul 18, 2014 at 5:49 AM, emily@aquaya.org wrote:

Hi everyone,

My colleague was testing out our pilot CommCare app in rural Senegal and
was unable to update to the new version i deployed using 'Update CommCare’
on the menu on cellular data or on slower wifi in the field - however, it
worked when she was on better wifi, and I think she had some more luck on a
slower connection deleting the data and reinstalling from the bit.ly
link.

We’re trying to get a sense of how realistic it is to deploy new versions
and under different conditions. Has anyone had experience updating to new
versions on cellular data or slower wifi successfully? Or do you only have
field agents update when there’s better internet connection (or the offline
install)? Any tips or advice for this?

Thanks!
Emily


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/TFfCmvVgsFI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Clayton,

According to my colleague, when she tried to update, it would find the 8 or 9 updates to do and start doing/installing them and on the last update there would be ‘unknown error.’ Then she was given the option of either Retrying the update or…there was a second option that started with an R that might have been Reinstall updates. It happened when she was on cellular data or lower bandwidth wifi, but worked once she got back to better wifi.

Thanks,
Emily

··· On Monday, July 21, 2014 at 5:46 PM, Clayton Sims wrote:

Emily,

What do you mean by the last step? Was it proceeding without issue until the end and then choking before it could finish?

With network issues it’s a bit difficult to expose great debugging information, unfortunately. It would be really helpful to know what the screens say when the updates aren’t working.

-Clayton

On Mon, Jul 21, 2014 at 3:01 AM, ‘Emily Kumpel’ via commcare-users <commcare-users@googlegroups.com (mailto:commcare-users@googlegroups.com)> wrote:

Hi Clayton,

The app did not include any multi-media, just form content. It seemed to just not get back the last step. Is there something I can try or a log I can get to help figure out what might be going on?

Thanks,
Emily

On Friday, July 18, 2014 at 8:17 PM, Clayton Sims wrote:

Emily,

I’m curious, were you updating an app including multimedia, or just including form content? We’ve had a lot of successes performing OTA updates on low-bandwidth high-latency cellular connections in the past without multimedia, but updating media files tends to make the process significantly less reliable.

-Clayton

On Fri, Jul 18, 2014 at 5:49 AM, <emily@aquaya.org (mailto:emily@aquaya.org)> wrote:

Hi everyone,

My colleague was testing out our pilot CommCare app in rural Senegal and was unable to update to the new version i deployed using ‘Update CommCare’ on the menu on cellular data or on slower wifi in the field - however, it worked when she was on better wifi, and I think she had some more luck on a slower connection deleting the data and reinstalling from the bit.ly (http://bit.ly) link.

We’re trying to get a sense of how realistic it is to deploy new versions and under different conditions. Has anyone had experience updating to new versions on cellular data or slower wifi successfully? Or do you only have field agents update when there’s better internet connection (or the offline install)? Any tips or advice for this?

Thanks!
Emily


You received this message because you are subscribed to the Google Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send an email to commcare-users+unsubscribe@googlegroups.com (mailto:commcare-users+unsubscribe@googlegroups.com).
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “commcare-users” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-users/TFfCmvVgsFI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to commcare-users+unsubscribe@googlegroups.com (mailto:commcare-users+unsubscribe@googlegroups.com).

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send an email to commcare-users+unsubscribe@googlegroups.com (mailto:commcare-users+unsubscribe@googlegroups.com).
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the Google Groups “commcare-users” group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-users/TFfCmvVgsFI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to commcare-users+unsubscribe@googlegroups.com (mailto:commcare-users+unsubscribe@googlegroups.com).
For more options, visit https://groups.google.com/d/optout.

Emily,

Strange. Can you let me know the name of your CommCareHQ project space so I
can review the device logs and see if there’s anything that stands out?

-Clayton

··· On Tue, Jul 22, 2014 at 2:45 AM, 'Emily Kumpel' via commcare-users < commcare-users@googlegroups.com> wrote:

Hi Clayton,

According to my colleague, when she tried to update, it would find the 8
or 9 updates to do and start doing/installing them and on the last update
there would be ‘unknown error.’ Then she was given the option of either
Retrying the update or…there was a second option that started with an R
that might have been Reinstall updates. It happened when she was on
cellular data or lower bandwidth wifi, but worked once she got back to
better wifi.

Thanks,
Emily

On Monday, July 21, 2014 at 5:46 PM, Clayton Sims wrote:

Emily,

What do you mean by the last step? Was it proceeding without issue until
the end and then choking before it could finish?

With network issues it’s a bit difficult to expose great debugging
information, unfortunately. It would be really helpful to know what the
screens say when the updates aren’t working.

-Clayton

On Mon, Jul 21, 2014 at 3:01 AM, ‘Emily Kumpel’ via commcare-users < commcare-users@googlegroups.com> wrote:

Hi Clayton,

The app did not include any multi-media, just form content. It seemed to
just not get back the last step. Is there something I can try or a log I
can get to help figure out what might be going on?

Thanks,
Emily

On Friday, July 18, 2014 at 8:17 PM, Clayton Sims wrote:

Emily,

I’m curious, were you updating an app including multimedia, or just
including form content? We’ve had a lot of successes performing OTA updates
on low-bandwidth high-latency cellular connections in the past without
multimedia, but updating media files tends to make the process
significantly less reliable.

-Clayton

On Fri, Jul 18, 2014 at 5:49 AM, emily@aquaya.org wrote:

Hi everyone,

My colleague was testing out our pilot CommCare app in rural Senegal and
was unable to update to the new version i deployed using 'Update CommCare’
on the menu on cellular data or on slower wifi in the field - however, it
worked when she was on better wifi, and I think she had some more luck on a
slower connection deleting the data and reinstalling from the bit.ly
link.

We’re trying to get a sense of how realistic it is to deploy new versions
and under different conditions. Has anyone had experience updating to new
versions on cellular data or slower wifi successfully? Or do you only have
field agents update when there’s better internet connection (or the offline
install)? Any tips or advice for this?

Thanks!
Emily


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/TFfCmvVgsFI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/TFfCmvVgsFI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.