Problems posting completed form data to CommCareHQ

Hi all,

I have been having some issues with uploading completed forms to CommCareHQ.
I think I have looked into all the obvious problems. I have confirmed that
the settings in the profile.xml file to point to the correct URL’s at
CommCareHQ and I have uploaded the proper XForms to CommCareHQ. However,
when I attempt to send data to CommCareHQ from the phone emulator, I receive
the following message on the phone screen: “Successfully Submitted. Your
data is safe, but we made a small mistake. We’re working on it.” The log
messages in the emulator console seem to suggest the transmission took place
without an error (I receive a 200 message). However, when I look at the
submissions tab in CommCareHQ I see no record of that submission.

I have tried several things to help debug the problem. I wrote a simple
curl script to POST the raw XML data from the form to CommCareHQ.
Surprisingly, this worked! I now have several “submissions” in CommCareHQ
all uploaded manually using this curl script.

I also created a simple web app and attempted to POST to it (instead of
CommCareHQ) via the phone. And that appears to work fine. My web app
received the data. I also POSTed to my web app via my curl script to see
how the submissions differed. As far as I could tell the submissions
appeared identical with the exception of some header fields.

I have tried several different CommCare builds, from default(tip) to
CommCare 1.0, all with the same results.

Has anybody else ran into this problem or have any ideas of where to look
next?

Best,
Stephen