Pagination not working in one of our reports

Hello,

for some reason pagination stopped working in
’custom.m4change.reports.mcct_project_review.McctProjectReview’ and I’m not
quite sure as to what might be the cause. We haven’t modified the code in
over two weeks and whenever I try to change the report’s page, nothing
happens, and it used to work without a problem. There are no errors, and no
debug info in the console. This happens both locally and on production.
Does anyone have an idea what might be broken here?

Regards
Lech

Could be related to this: https://github.com/dimagi/commcare-hq/pull/3505

··· On 28 May 2014 12:29, Lech Różański wrote:

Hello,

for some reason pagination stopped working in
’custom.m4change.reports.mcct_project_review.McctProjectReview’ and I’m not
quite sure as to what might be the cause. We haven’t modified the code in
over two weeks and whenever I try to change the report’s page, nothing
happens, and it used to work without a problem. There are no errors, and no
debug info in the console. This happens both locally and on production.
Does anyone have an idea what might be broken here?

Regards
Lech


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Lech, did you have a chance to look into this further?

I don’t think that commit should have affected you since
self.is_rendered_as_email should be false which should revert to the
previous behavior - but that does seem like suspicious timing.

Cory

··· On Wed, May 28, 2014 at 3:56 AM, Simon Kelly wrote:

Could be related to this: https://github.com/dimagi/commcare-hq/pull/3505

On 28 May 2014 12:29, Lech Różański lrozanski@soldevelo.com wrote:

Hello,

for some reason pagination stopped working in
’custom.m4change.reports.mcct_project_review.McctProjectReview’ and I’m not
quite sure as to what might be the cause. We haven’t modified the code in
over two weeks and whenever I try to change the report’s page, nothing
happens, and it used to work without a problem. There are no errors, and no
debug info in the console. This happens both locally and on production.
Does anyone have an idea what might be broken here?

Regards
Lech


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hello Simon,

I don’t think that’s the problem, as I have tried resetting the master
branch about 100+ commits and the problem persists.

Regards
Lech

··· On 05/28/2014 12:56 PM, Simon Kelly wrote: > Could be related to this: https://github.com/dimagi/commcare-hq/pull/3505 > > > On 28 May 2014 12:29, Lech Różański <lrozanski@soldevelo.com > wrote: > > Hello, > > for some reason pagination stopped working in > 'custom.m4change.reports.mcct_project_review.McctProjectReview' > and I'm not quite sure as to what might be the cause. We haven't > modified the code in over two weeks and whenever I try to change > the report's page, nothing happens, and it used to work without a > problem. There are no errors, and no debug info in the console. > This happens both locally and on production. Does anyone have an > idea what might be broken here? > > Regards > Lech > -- > > --- > You received this message because you are subscribed to the Google > Groups "CommCare Developers" group. > To unsubscribe from this group and stop receiving emails from it, > send an email to commcare-developers+unsubscribe@googlegroups.com > . > For more options, visit https://groups.google.com/d/optout. > > > > > -- > Simon Kelly > Senior Engineer | Dimagi South Africa > -- > > --- > You received this message because you are subscribed to the Google > Groups "CommCare Developers" group. > To unsubscribe from this group and stop receiving emails from it, send > an email to commcare-developers+unsubscribe@googlegroups.com > . > For more options, visit https://groups.google.com/d/optout.

There seems to be something odd going on with the group. Recently some of
my e-mails don’t appear in the discussion, and I send them as I always
have, so I’m not quite sure what’s going on here. I sent this yesterday:

Hello Simon,

I don’t think that’s the problem, as I have tried resetting the master

branch about 100+ commits and the problem persists.

Regards

Lech

Lech

··· On Wednesday, 28 May 2014 18:22:53 UTC+2, Cory Zue wrote: > > Lech, did you have a chance to look into this further? > > I don't think that commit should have affected you since > self.is_rendered_as_email should be false which should revert to the > previous behavior - but that does seem like suspicious timing. > > Cory > > > On Wed, May 28, 2014 at 3:56 AM, Simon Kelly <ske...@dimagi.com wrote: > >> Could be related to this: https://github.com/dimagi/commcare-hq/pull/3505 >> >> >> On 28 May 2014 12:29, Lech Różański <lroz...@soldevelo.com >wrote: >> >>> Hello, >>> >>> for some reason pagination stopped working in >>> 'custom.m4change.reports.mcct_project_review.McctProjectReview' and I'm not >>> quite sure as to what might be the cause. We haven't modified the code in >>> over two weeks and whenever I try to change the report's page, nothing >>> happens, and it used to work without a problem. There are no errors, and no >>> debug info in the console. This happens both locally and on production. >>> Does anyone have an idea what might be broken here? >>> >>> Regards >>> Lech >>> >>> -- >>> >>> --- >>> You received this message because you are subscribed to the Google >>> Groups "CommCare Developers" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to commcare-developers+unsubscribe@googlegroups.com >>> . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> >> >> -- >> Simon Kelly >> Senior Engineer | Dimagi South Africa >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

I’ll try and take a look today and see if I can reproduce it.

··· On 29 May 2014 08:52, Lech Różański wrote:

There seems to be something odd going on with the group. Recently some of
my e-mails don’t appear in the discussion, and I send them as I always
have, so I’m not quite sure what’s going on here. I sent this yesterday:

Hello Simon,

I don’t think that’s the problem, as I have tried resetting the master

branch about 100+ commits and the problem persists.

Regards

Lech

Lech

On Wednesday, 28 May 2014 18:22:53 UTC+2, Cory Zue wrote:

Lech, did you have a chance to look into this further?

I don’t think that commit should have affected you since
self.is_rendered_as_email should be false which should revert to the
previous behavior - but that does seem like suspicious timing.

Cory

On Wed, May 28, 2014 at 3:56 AM, Simon Kelly ske...@dimagi.com wrote:

Could be related to this: https://github.com/
dimagi/commcare-hq/pull/3505

On 28 May 2014 12:29, Lech Różański lroz...@soldevelo.com wrote:

Hello,

for some reason pagination stopped working in
’custom.m4change.reports.mcct_project_review.McctProjectReview’ and
I’m not quite sure as to what might be the cause. We haven’t modified the
code in over two weeks and whenever I try to change the report’s page,
nothing happens, and it used to work without a problem. There are no
errors, and no debug info in the console. This happens both locally and on
production. Does anyone have an idea what might be broken here?

Regards
Lech


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Struggling to get any data to show up in that report. What data should I
need?

··· On 28 May 2014 12:58, Lech Różański wrote:

Hello Simon,

I don’t think that’s the problem, as I have tried resetting the master
branch about 100+ commits and the problem persists.

Regards
Lech

On 05/28/2014 12:56 PM, Simon Kelly wrote:

Could be related to this: https://github.com/dimagi/commcare-hq/pull/3505

On 28 May 2014 12:29, Lech Różański lrozanski@soldevelo.com wrote:

Hello,

for some reason pagination stopped working in
’custom.m4change.reports.mcct_project_review.McctProjectReview’ and I’m not
quite sure as to what might be the cause. We haven’t modified the code in
over two weeks and whenever I try to change the report’s page, nothing
happens, and it used to work without a problem. There are no errors, and no
debug info in the console. This happens both locally and on production.
Does anyone have an idea what might be broken here?

Regards
Lech


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Hi,

this link should help:
https://www.commcarehq.org/a/test-pathfinder/reports/custom/mcct_project_review_page/?location_id=&range=2014-05-01+to+2014-05-30&case_search=&service_type_filter=all#
.

Regards
Lech

··· On Friday, 30 May 2014 15:40:39 UTC+2, skelly wrote: > > Struggling to get any data to show up in that report. What data should I > need? > > > On 28 May 2014 12:58, Lech Różański <lroz...@soldevelo.com > wrote: > >> Hello Simon, >> >> I don't think that's the problem, as I have tried resetting the master >> branch about 100+ commits and the problem persists. >> >> Regards >> Lech >> >> >> On 05/28/2014 12:56 PM, Simon Kelly wrote: >> >> Could be related to this: https://github.com/dimagi/commcare-hq/pull/3505 >> >> >> On 28 May 2014 12:29, Lech Różański <lroz...@soldevelo.com > wrote: >> >>> Hello, >>> >>> for some reason pagination stopped working in >>> 'custom.m4change.reports.mcct_project_review.McctProjectReview' and I'm not >>> quite sure as to what might be the cause. We haven't modified the code in >>> over two weeks and whenever I try to change the report's page, nothing >>> happens, and it used to work without a problem. There are no errors, and no >>> debug info in the console. This happens both locally and on production. >>> Does anyone have an idea what might be broken here? >>> >>> Regards >>> Lech >>> -- >>> >>> --- >>> You received this message because you are subscribed to the Google >>> Groups "CommCare Developers" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to commcare-developers+unsubscribe@googlegroups.com >>> . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> >> >> -- >> Simon Kelly >> Senior Engineer | Dimagi South Africa >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Simon Kelly > Senior Engineer | Dimagi South Africa >

OK, this looks exactly like the issue we had on case re-assignment screen
related to the knockout upgrade. Here’s the PR that fixed that issue:

··· On 30 May 2014 15:43, Lech Różański wrote:

Hi,

this link should help:
https://www.commcarehq.org/a/test-pathfinder/reports/custom/mcct_project_review_page/?location_id=&range=2014-05-01+to+2014-05-30&case_search=&service_type_filter=all#
.

Regards
Lech

On Friday, 30 May 2014 15:40:39 UTC+2, skelly wrote:

Struggling to get any data to show up in that report. What data should I
need?

On 28 May 2014 12:58, Lech Różański lroz...@soldevelo.com wrote:

Hello Simon,

I don’t think that’s the problem, as I have tried resetting the master
branch about 100+ commits and the problem persists.

Regards
Lech

On 05/28/2014 12:56 PM, Simon Kelly wrote:

Could be related to this: https://github.com/
dimagi/commcare-hq/pull/3505

On 28 May 2014 12:29, Lech Różański lroz...@soldevelo.com wrote:

Hello,

for some reason pagination stopped working in
’custom.m4change.reports.mcct_project_review.McctProjectReview’ and
I’m not quite sure as to what might be the cause. We haven’t modified the
code in over two weeks and whenever I try to change the report’s page,
nothing happens, and it used to work without a problem. There are no
errors, and no debug info in the console. This happens both locally and on
production. Does anyone have an idea what might be broken here?

Regards
Lech


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa