Offline install of my own commcare app: can't access the sd-ram card, only google drive

Hi all –

Since the wifi here is not reliable, I am trying to do a fully offline
install of (1) the overall CommCare app, (2) the barcode scanner app (for
future use), and (3) my own commcare app that will run within CommCare.

– No problem with the first two of those installs, thanks to the help from
william pride.

– however, for installing my own commcare app into CommCare, I have a
problem. I have put my own commcare app’s commcare.ccz file onto the same
micro-SD card that I’ve put into a phone. Then I go into CommCare, and
choose “offline install” from the three-dot menu. It gives me a basic file
identification field with a folder button to the right, and says “Install
your CommCare application from a .zip file.” All good. But when I press
the “folder icon” button to try to navigate to identify that commcare.ccz
file, CommCare opens a window titled “My Drive,” which I believe is for
Google Drive. I can’t use that method because right now I will not be able
to get the many phones I’m installing onto wifi. But this window offers no
way to use a method other than “My Drive.”

So:

(1) How do I tell this file locator window to also offer methods to reach
either into the phone’s own file system or, preferably, reach into the
sd-RAM card I have plugged inm

(2) if the option is that it can’t reach the SDram and has to actually
reach only to the phone’s own memory (and once I’ve learned how to get it
to reach the phone’s memory as mentioned in the item above), what folder in
the phone’s own memory should I copy the .ccz file into so that CommCare
will find it easiest from the open window?

Thanks for your help!!!
Eric

(I realized it might be relevant – you might wonder what file manager app
that I am using. Well, again, since I’m doing a fresh install on all these
phones and hope to do it totally offline and not have to access wifi, I am
not downloading ES File Manager or something. but the phones have a file
manager on it called “File Manager,” whose icon is a tall yellow envelope.
That has worked fine for the installing of my two APK files, but of course
my challange now is the commcare CCZ file. – Eric)

Eric,

This is likely happening because your Android OS has Google Drive
registered as the default application to handle the “Choose File” action
that CommCare initiates here. For your user case, you’ll need to clear this
default. You usually do this by going to Settings -> Applications -> Select
Relevant Application (in your case Google Drive) -> Clear Defaults. Then,
the next time you click the folder button in CommCare, you should be
prompted to select a file chooser and can choose a new one.

In many devices you can also navigate to the file on your SD with a file
chooser, tap the .ccz file, and CommCare will automatically recognize this
file and initiate the offline install process. Unfortunately, this method
isn’t 100% reliable due to some standard inconsistencies across API
versions and file chooser apps.

Best,
Will

··· On Wed, Apr 22, 2015 at 11:17 PM, Eric Stephan wrote:

Hi all –

Since the wifi here is not reliable, I am trying to do a fully offline
install of (1) the overall CommCare app, (2) the barcode scanner app (for
future use), and (3) my own commcare app that will run within CommCare.

– No problem with the first two of those installs, thanks to the help
from william pride.

– however, for installing my own commcare app into CommCare, I have a
problem. I have put my own commcare app’s commcare.ccz file onto the same
micro-SD card that I’ve put into a phone. Then I go into CommCare, and
choose “offline install” from the three-dot menu. It gives me a basic file
identification field with a folder button to the right, and says “Install
your CommCare application from a .zip file.” All good. But when I press
the “folder icon” button to try to navigate to identify that commcare.ccz
file, CommCare opens a window titled “My Drive,” which I believe is for
Google Drive. I can’t use that method because right now I will not be able
to get the many phones I’m installing onto wifi. But this window offers no
way to use a method other than “My Drive.”

So:

(1) How do I tell this file locator window to also offer methods to reach
either into the phone’s own file system or, preferably, reach into the
sd-RAM card I have plugged inm

(2) if the option is that it can’t reach the SDram and has to actually
reach only to the phone’s own memory (and once I’ve learned how to get it
to reach the phone’s memory as mentioned in the item above), what folder in
the phone’s own memory should I copy the .ccz file into so that CommCare
will find it easiest from the open window?

Thanks for your help!!!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Great info, and along the lines of what I’d been trying, but seems not
to quite work out for me –

– these phones are straight out of the box, and when I go to settings -
applications, Google Drive is not one of the applications listed. And
I’ve not seen google drive listed anywhere on the app.

– Also to note, when I go to phones that are TRULY out of the box and I
have never configured things on them when connected to wifi… when I go
to CommCare and click the “folder” button to get it to access something –
it actually doesn’t give me a “My Drive” window because I’ve never even
told it any google credentials. So it puts a black message at bottom saying
"You must have at least 1 google account set up before you can use this
application." So this is an out of the box phone (Alcatel Pop C1, also
called, in the “about phone” area, the “ONE TOUCH 4015X”, running I believe
the newest Jelly Bean) … and the only things installed on it are CommCare
and Barcode Scanner, both via SDram card.

– in my scan down the applications in the Settings-Applications list, I
dont’ see any other “cloud storage” or file-storage type apps…

– So, it seems like out of the box it hard-defaults to Google Drive, even
though google drive isn’t installed yet (must be natively installed.) Can
you think of another settings or config location that might stand in for
adjusting that hard default? or any other thoughts? Jeez, what a hardcore
approach to force the google defailt.

– Not that it’s relevant, but when I open up the settings -apps-- commcare
entry, it has no defaults set at all, and it actually does say that it has
data stored, but both when I try my issue when it has that initial data
present, as well as after I’ve chosen Clear Data, the problem remains…

Thanks for your thoughts!!
Eric

Eric,

Hmm, that does sound like a frustrating default behavior, though Google
certainly has a track record of doing this (and the EU anti trust lawsuits
to show for it).

Looks like the Android application is actually called “Drive”. In the
applications tab, if you swipe to the “All” category, you should see the
"Drive" app there. You could try removing the defaults there, or even
disabling the application temporarily (since, of course, they won’t let you
uninstall this app).

I’ll definitely second Patrick’s recommendation that you get the ES File
Explorer application as well so that once you do the steps above you can
use this in Drive’s place.

Best,
Will

··· On Thu, Apr 23, 2015 at 12:19 AM, Eric Stephan wrote:

Great info, and along the lines of what I’d been trying, but seems not
to quite work out for me –

– these phones are straight out of the box, and when I go to settings -
applications, Google Drive is not one of the applications listed. And
I’ve not seen google drive listed anywhere on the app.

– Also to note, when I go to phones that are TRULY out of the box and I
have never configured things on them when connected to wifi… when I go
to CommCare and click the “folder” button to get it to access something –
it actually doesn’t give me a “My Drive” window because I’ve never even
told it any google credentials. So it puts a black message at bottom saying
"You must have at least 1 google account set up before you can use this
application." So this is an out of the box phone (Alcatel Pop C1, also
called, in the “about phone” area, the “ONE TOUCH 4015X”, running I
believe the newest Jelly Bean) … and the only things installed on it are
CommCare and Barcode Scanner, both via SDram card.

– in my scan down the applications in the Settings-Applications list, I
dont’ see any other “cloud storage” or file-storage type apps…

– So, it seems like out of the box it hard-defaults to Google Drive, even
though google drive isn’t installed yet (must be natively installed.) Can
you think of another settings or config location that might stand in for
adjusting that hard default? or any other thoughts? Jeez, what a hardcore
approach to force the google defailt.

– Not that it’s relevant, but when I open up the settings -apps–
commcare entry, it has no defaults set at all, and it actually does say
that it has data stored, but both when I try my issue when it has that
initial data present, as well as after I’ve chosen Clear Data, the problem
remains…

Thanks for your thoughts!!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Eric,

I would highly recommend you use ES file explorer for carrying out
offline install (standard practice for many at Dimagi).
You could also create an apk version of ES file explorer to save you time
.

Finally, you could save the CCZ folder to the Download folder in the
phone’s memory, or you could directly create a new folder in the memory
of the phone with the name of your project (whatever works best for you)

Thanks,
Patrick

··· 2015-04-23 4:19 GMT+00:00 Eric Stephan :

Great info, and along the lines of what I’d been trying, but seems not
to quite work out for me –

– these phones are straight out of the box, and when I go to settings -
applications, Google Drive is not one of the applications listed. And
I’ve not seen google drive listed anywhere on the app.

– Also to note, when I go to phones that are TRULY out of the box and I
have never configured things on them when connected to wifi… when I go
to CommCare and click the “folder” button to get it to access something –
it actually doesn’t give me a “My Drive” window because I’ve never even
told it any google credentials. So it puts a black message at bottom saying
"You must have at least 1 google account set up before you can use this
application." So this is an out of the box phone (Alcatel Pop C1, also
called, in the “about phone” area, the “ONE TOUCH 4015X”, running I
believe the newest Jelly Bean) … and the only things installed on it are
CommCare and Barcode Scanner, both via SDram card.

– in my scan down the applications in the Settings-Applications list, I
dont’ see any other “cloud storage” or file-storage type apps…

– So, it seems like out of the box it hard-defaults to Google Drive, even
though google drive isn’t installed yet (must be natively installed.) Can
you think of another settings or config location that might stand in for
adjusting that hard default? or any other thoughts? Jeez, what a hardcore
approach to force the google defailt.

– Not that it’s relevant, but when I open up the settings -apps–
commcare entry, it has no defaults set at all, and it actually does say
that it has data stored, but both when I try my issue when it has that
initial data present, as well as after I’ve chosen Clear Data, the problem
remains…

Thanks for your thoughts!!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Patrick Keating

Field Manager | Gestionnaire sur terrain
West Africa | Afrique de l’Ouest
Dimagi, Inc
Mob: +221775716949 Skype: patby19
http://www.dimagi.com

Eric,

As a heads up, we’re working to improve this function in the future to work
more reliably with Android’s new defaults so you won’t need to use an
external file browser.

When we release that fix it’ll be noted in the app release notes for the
upcoming version.

Sorry about the trouble!

-Clayton

··· On Thu, Apr 23, 2015 at 8:19 AM, William Pride wrote:

Eric,

Hmm, that does sound like a frustrating default behavior, though Google
certainly has a track record of doing this (and the EU anti trust lawsuits
to show for it).

Looks like the Android application is actually called “Drive”. In the
applications tab, if you swipe to the “All” category, you should see the
"Drive" app there. You could try removing the defaults there, or even
disabling the application temporarily (since, of course, they won’t let you
uninstall this app).

I’ll definitely second Patrick’s recommendation that you get the ES File
Explorer application as well so that once you do the steps above you can
use this in Drive’s place.

Best,
Will

On Thu, Apr 23, 2015 at 12:19 AM, Eric Stephan estephan@fhi360.org wrote:

Great info, and along the lines of what I’d been trying, but seems not
to quite work out for me –

– these phones are straight out of the box, and when I go to settings -
applications, Google Drive is not one of the applications listed. And
I’ve not seen google drive listed anywhere on the app.

– Also to note, when I go to phones that are TRULY out of the box and I
have never configured things on them when connected to wifi… when I go
to CommCare and click the “folder” button to get it to access something –
it actually doesn’t give me a “My Drive” window because I’ve never even
told it any google credentials. So it puts a black message at bottom saying
"You must have at least 1 google account set up before you can use this
application." So this is an out of the box phone (Alcatel Pop C1, also
called, in the “about phone” area, the “ONE TOUCH 4015X”, running I
believe the newest Jelly Bean) … and the only things installed on it are
CommCare and Barcode Scanner, both via SDram card.

– in my scan down the applications in the Settings-Applications list, I
dont’ see any other “cloud storage” or file-storage type apps…

– So, it seems like out of the box it hard-defaults to Google Drive,
even though google drive isn’t installed yet (must be natively installed.)
Can you think of another settings or config location that might stand in
for adjusting that hard default? or any other thoughts? Jeez, what a
hardcore approach to force the google defailt.

– Not that it’s relevant, but when I open up the settings -apps–
commcare entry, it has no defaults set at all, and it actually does say
that it has data stored, but both when I try my issue when it has that
initial data present, as well as after I’ve chosen Clear Data, the problem
remains…

Thanks for your thoughts!!
Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.