'NoneType' object has no attribute '__getitem__'

I get the bellow error when i go to web users and roles. Any ideas on how to solve this error? much appreciated.

‘NoneType’ object has no attribute ‘getitem

Request Method: GET
Request URL: http://localhost:8000/a/xxxxxxxxx/settings/users/web/
Django Version: 1.8.17
Exception Type: TypeError
Exception Value:

‘NoneType’ object has no attribute ‘getitem

Exception Location: /home/commcarehq/commcare-hq/corehq/apps/users/models.py
in ids_of_assigned_users, line 331
Python Executable: /home/commcarehq/bin/python2
Python Version: 2.7.12
Python Path:

[’/home/commcarehq/commcare-hq’,
’/home/commcarehq/commcare-hq/custom/_legacy’,
’/home/commcarehq/commcare-hq/corehq/ex-submodules’,
’/home/commcarehq/commcare-hq/submodules/django-prbac-src’,
’/home/commcarehq/commcare-hq/submodules/couchdbkit-aggregate’,
’/home/commcarehq/commcare-hq/submodules/python-digest’,
’/home/commcarehq/commcare-hq/submodules/touchforms-src’,
’/home/commcarehq/commcare-hq/submodules/xml2json’,
’/home/commcarehq/commcare-hq/submodules/vellum’,
’/home/commcarehq/commcare-hq/submodules/commcare-translations’,
’/home/commcarehq/commcare-hq/submodules/django-digest-src’,
’/home/commcarehq/commcare-hq/submodules/django-no-exceptions’,
’/home/commcarehq/commcare-hq/submodules/langcodes’,
’/home/commcarehq/commcare-hq/submodules/dimagi-utils-src’,
’/home/commcarehq/commcare-hq/submodules/auditcare-src’,
’/home/commcarehq/commcare-hq/submodules/formtranslate-src’,
’/home/commcarehq/bin’,
’/home/commcarehq/lib/python2.7’,
’/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu’,
’/home/commcarehq/lib/python2.7/lib-tk’,
’/home/commcarehq/lib/python2.7/lib-old’,
’/home/commcarehq/lib/python2.7/lib-dynload’,
’/usr/lib/python2.7’,
’/usr/lib/python2.7/plat-x86_64-linux-gnu’,
’/usr/lib/python2.7/lib-tk’,
’/home/commcarehq/local/lib/python2.7/site-packages’,
’/home/commcarehq/local/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/commcare-hq/submodules’]

That could be because elasticsearch isn’t running or the query is failing
for some reason. I’d make sure it’s up and running, and that you can
connect to it. If not, it’s hard to guess why that might be, but that’s
where I’d start looking.

··· On Tue, Jan 24, 2017 at 4:50 AM, mukopaje singogo wrote:

I get the bellow error when i go to web users and roles. Any ideas on how to solve this error? much appreciated.

‘NoneType’ object has no attribute ‘getitem

Request Method: GET
Request URL: http://localhost:8000/a/xxxxxxxxx/settings/users/web/
Django Version: 1.8.17
Exception Type: TypeError
Exception Value:

‘NoneType’ object has no attribute ‘getitem

Exception Location: /home/commcarehq/commcare-hq/corehq/apps/users/models.py
in ids_of_assigned_users, line 331
Python Executable: /home/commcarehq/bin/python2
Python Version: 2.7.12
Python Path:

[’/home/commcarehq/commcare-hq’,
’/home/commcarehq/commcare-hq/custom/_legacy’,
’/home/commcarehq/commcare-hq/corehq/ex-submodules’,
’/home/commcarehq/commcare-hq/submodules/django-prbac-src’,
’/home/commcarehq/commcare-hq/submodules/couchdbkit-aggregate’,
’/home/commcarehq/commcare-hq/submodules/python-digest’,
’/home/commcarehq/commcare-hq/submodules/touchforms-src’,
’/home/commcarehq/commcare-hq/submodules/xml2json’,
’/home/commcarehq/commcare-hq/submodules/vellum’,
’/home/commcarehq/commcare-hq/submodules/commcare-translations’,
’/home/commcarehq/commcare-hq/submodules/django-digest-src’,
’/home/commcarehq/commcare-hq/submodules/django-no-exceptions’,
’/home/commcarehq/commcare-hq/submodules/langcodes’,
’/home/commcarehq/commcare-hq/submodules/dimagi-utils-src’,
’/home/commcarehq/commcare-hq/submodules/auditcare-src’,
’/home/commcarehq/commcare-hq/submodules/formtranslate-src’,
’/home/commcarehq/bin’,
’/home/commcarehq/lib/python2.7’,
’/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu’,
’/home/commcarehq/lib/python2.7/lib-tk’,
’/home/commcarehq/lib/python2.7/lib-old’,
’/home/commcarehq/lib/python2.7/lib-dynload’,
’/usr/lib/python2.7’,
’/usr/lib/python2.7/plat-x86_64-linux-gnu’,
’/usr/lib/python2.7/lib-tk’,
’/home/commcarehq/local/lib/python2.7/site-packages’,
’/home/commcarehq/local/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/commcare-hq/submodules’]


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks ethan,
You were right about elasticsearch I actually thought it would start
automatically when my supervisor is restarted. Whats the best way to
automatically start Kafka and elasticsearch on ubuntu start-up (i am using
ubuntu 16.04) i have tried a few init.d files but havent worked well,
anything you would recommend.

Kind regards.

··· On Tue, Jan 24, 2017 at 4:40 PM, Ethan Soergel wrote:

That could be because elasticsearch isn’t running or the query is failing
for some reason. I’d make sure it’s up and running, and that you can
connect to it. If not, it’s hard to guess why that might be, but that’s
where I’d start looking.

On Tue, Jan 24, 2017 at 4:50 AM, mukopaje singogo mukopaje@gmail.com wrote:

I get the bellow error when i go to web users and roles. Any ideas on how to solve this error? much appreciated.

‘NoneType’ object has no attribute ‘getitem

Request Method: GET
Request URL: http://localhost:8000/a/xxxxxxxxx/settings/users/web/
Django Version: 1.8.17
Exception Type: TypeError
Exception Value:

‘NoneType’ object has no attribute ‘getitem

Exception Location: /home/commcarehq/commcare-hq/corehq/apps/users/models.py
in ids_of_assigned_users, line 331
Python Executable: /home/commcarehq/bin/python2
Python Version: 2.7.12
Python Path:

[’/home/commcarehq/commcare-hq’,
’/home/commcarehq/commcare-hq/custom/_legacy’,
’/home/commcarehq/commcare-hq/corehq/ex-submodules’,
’/home/commcarehq/commcare-hq/submodules/django-prbac-src’,
’/home/commcarehq/commcare-hq/submodules/couchdbkit-aggregate’,
’/home/commcarehq/commcare-hq/submodules/python-digest’,
’/home/commcarehq/commcare-hq/submodules/touchforms-src’,
’/home/commcarehq/commcare-hq/submodules/xml2json’,
’/home/commcarehq/commcare-hq/submodules/vellum’,
’/home/commcarehq/commcare-hq/submodules/commcare-translations’,
’/home/commcarehq/commcare-hq/submodules/django-digest-src’,
’/home/commcarehq/commcare-hq/submodules/django-no-exceptions’,
’/home/commcarehq/commcare-hq/submodules/langcodes’,
’/home/commcarehq/commcare-hq/submodules/dimagi-utils-src’,
’/home/commcarehq/commcare-hq/submodules/auditcare-src’,
’/home/commcarehq/commcare-hq/submodules/formtranslate-src’,
’/home/commcarehq/bin’,
’/home/commcarehq/lib/python2.7’,
’/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu’,
’/home/commcarehq/lib/python2.7/lib-tk’,
’/home/commcarehq/lib/python2.7/lib-old’,
’/home/commcarehq/lib/python2.7/lib-dynload’,
’/usr/lib/python2.7’,
’/usr/lib/python2.7/plat-x86_64-linux-gnu’,
’/usr/lib/python2.7/lib-tk’,
’/home/commcarehq/local/lib/python2.7/site-packages’,
’/home/commcarehq/local/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/commcare-hq/submodules’]


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I think we use upstart. You can browse our ansible role for more
specifics:

··· On Wed, Jan 25, 2017 at 2:33 AM, mukopaje singogo wrote:

Thanks ethan,
You were right about elasticsearch I actually thought it would start
automatically when my supervisor is restarted. Whats the best way to
automatically start Kafka and elasticsearch on ubuntu start-up (i am using
ubuntu 16.04) i have tried a few init.d files but havent worked well,
anything you would recommend.

Kind regards.

On Tue, Jan 24, 2017 at 4:40 PM, Ethan Soergel esoergel@dimagi.com wrote:

That could be because elasticsearch isn’t running or the query is failing
for some reason. I’d make sure it’s up and running, and that you can
connect to it. If not, it’s hard to guess why that might be, but that’s
where I’d start looking.

On Tue, Jan 24, 2017 at 4:50 AM, mukopaje singogo mukopaje@gmail.com wrote:

I get the bellow error when i go to web users and roles. Any ideas on how to solve this error? much appreciated.

‘NoneType’ object has no attribute ‘getitem

Request Method: GET
Request URL: http://localhost:8000/a/xxxxxxxxx/settings/users/web/
Django Version: 1.8.17
Exception Type: TypeError
Exception Value:

‘NoneType’ object has no attribute ‘getitem

Exception Location: /home/commcarehq/commcare-hq/corehq/apps/users/models.py
in ids_of_assigned_users, line 331
Python Executable: /home/commcarehq/bin/python2
Python Version: 2.7.12
Python Path:

[’/home/commcarehq/commcare-hq’,
’/home/commcarehq/commcare-hq/custom/_legacy’,
’/home/commcarehq/commcare-hq/corehq/ex-submodules’,
’/home/commcarehq/commcare-hq/submodules/django-prbac-src’,
’/home/commcarehq/commcare-hq/submodules/couchdbkit-aggregate’,
’/home/commcarehq/commcare-hq/submodules/python-digest’,
’/home/commcarehq/commcare-hq/submodules/touchforms-src’,
’/home/commcarehq/commcare-hq/submodules/xml2json’,
’/home/commcarehq/commcare-hq/submodules/vellum’,
’/home/commcarehq/commcare-hq/submodules/commcare-translations’,
’/home/commcarehq/commcare-hq/submodules/django-digest-src’,
’/home/commcarehq/commcare-hq/submodules/django-no-exceptions’,
’/home/commcarehq/commcare-hq/submodules/langcodes’,
’/home/commcarehq/commcare-hq/submodules/dimagi-utils-src’,
’/home/commcarehq/commcare-hq/submodules/auditcare-src’,
’/home/commcarehq/commcare-hq/submodules/formtranslate-src’,
’/home/commcarehq/bin’,
’/home/commcarehq/lib/python2.7’,
’/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu’,
’/home/commcarehq/lib/python2.7/lib-tk’,
’/home/commcarehq/lib/python2.7/lib-old’,
’/home/commcarehq/lib/python2.7/lib-dynload’,
’/usr/lib/python2.7’,
’/usr/lib/python2.7/plat-x86_64-linux-gnu’,
’/usr/lib/python2.7/lib-tk’,
’/home/commcarehq/local/lib/python2.7/site-packages’,
’/home/commcarehq/local/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/lib/python2.7/site-packages/newrelic-2.78.0.57’,
’/home/commcarehq/commcare-hq/submodules’]


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.