Lookup tables were working fine, but now spaces in answer options cause App Preview error

Hi Will,

I can confirm that this is now resolved, thanks. Not sure why it was still
persisting earlier this week.

The limitation on Select Multiple options which are space-separated also
makes sense, thanks for pointing that out.

Regards,
Andrew

··· On 6 July 2017 at 15:59, William Pride wrote:

Andrew,

This should be fixed as of approximately last Wednesday. If this issue is
persisting for you please report a bug
https://confluence.dimagi.com/display/commcarepublic/Bug+Reports.

One point of clarification: while spaces should now be allowed in Select
One (IE Multiple Choice) question values, they will not be allowed for
Select Multiple (IE Checkbox) question value. This conforms with XForms
standard and prevents data issues as Checkbox selections are stored in a
space separated list so spaces interfere with this storage mechanism.

Cheers,
Will

On Mon, Jul 3, 2017 at 4:51 AM, Andrew Cawood acawood777@gmail.com wrote:

Hi Will,

Just noting that the fix doesn’t seem to have propogated yet - I still
see the issue on my side. If you update me once it is pushed I can check
again for you.

Thanks and regards,
Andrew

On Saturday, 1 July 2017 07:42:03 UTC+2, Andrew Cawood wrote:

Hi Will,

Great, thanks for the speedy fix! The change doesn’t seem to have
propogated yet (Formplayer version 2.36), will check it on Monday again.

Regards,
Andrew

On Friday, 30 June 2017 16:18:09 UTC+2, William Pride wrote:

Hi Andrew,

Looks like this was caused by a bug released recently. I’ve submitted a
fix for this issue so it should be resolved later this afternoon EST.

Cheers,
Will

On Thu, Jun 29, 2017 at 4:06 PM, Andrew Cawood acawo...@gmail.com wrote:

I have a form with 2 lookup tables, first to select municipality, and
then to select ward (filtered acording to municipality).
These forms have been working fine for several months and the lookup
table has not been changed.

When viewing the form in the App Preview I get the following error
after selecting municipality and attempting to go to the next question:

Select answer options cannot contain spaces. Question
org.javarosa.form.api.FormEntryPrompt@44627a6d with answer Ward 1

It seems to be objecting to “Ward 1”, the first option in the lookup
table.

Note that this works fine in the app itself.

Is there any way around this? It used to work fine in the App Preview

  • has something been changed?

Thanks,
Andrew


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-user...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/commcare-users/Ky3he5YcyXY/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.