Lookup tables and multiple languages

I have created some lookup table using two languages following the
instructions here:

https://confluence.dimagi.com/display/commcarepublic/Using+Lookup+Tables+with+Multiple+Languages

The lookup questions work, however they only work when the hidden lang-code
label is in a particular position:

  • The label is at the beginning of the form
  • The label is not in a group or a question list
  • The label still displays at the beginning of the form (despite the
    display criteria of 1=2)

If I place it anywhere else, the drop down list options are blank because
the form fails to set the correct lang-code.

Where is the best place to put the hidden label to make sure it gets
evaluated properly and it is not shown the user?

https://lh3.googleusercontent.com/-NoEFTO4kjio/WXgXklu4srI/AAAAAAAAsTU/LZw0TyJLH3sqvC5igMHfsmxBOhOl-nb-QCLcBGAs/s1600/Lookup%2BQuestions%2BLanguage%2BLabel.png

Hi Adi,

It’s quite surprising to me that the label is not hiding hiding due if your
display condition is 1 = 2. If that is currently still happening in your
form, can you submit a bug using the Report an Issue menu in CommCare?

-Clayton

··· On Wed, Jul 26, 2017 at 12:19 AM, Adi Smith wrote:

I have created some lookup table using two languages following the
instructions here:

https://confluence.dimagi.com/display/commcarepublic/Using+
Lookup+Tables+with+Multiple+Languages

The lookup questions work, however they only work when the hidden
lang-code label is in a particular position:

  • The label is at the beginning of the form
  • The label is not in a group or a question list
  • The label still displays at the beginning of the form (despite the
    display criteria of 1=2)

If I place it anywhere else, the drop down list options are blank because
the form fails to set the correct lang-code.

Where is the best place to put the hidden label to make sure it gets
evaluated properly and it is not shown the user?

https://lh3.googleusercontent.com/-NoEFTO4kjio/WXgXklu4srI/AAAAAAAAsTU/LZw0TyJLH3sqvC5igMHfsmxBOhOl-nb-QCLcBGAs/s1600/Lookup%2BQuestions%2BLanguage%2BLabel.png


You received this message because you are subscribed to the Google Groups
“commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Note 1=2 is one of those display conditions that doesn’t work in the app
preview when 1 question per screen is turned on. It works with the 1
question per screen setting turned off, or on a mobile device. If you
haven’t tested outside of app preview that’s quite likely what the problem
is.

Cheers,
Amber.

··· On Friday, August 4, 2017 at 6:01:59 AM UTC+8, Clayton Sims wrote: > > Hi Adi, > > It's quite surprising to me that the label is not hiding hiding due if > your display condition is 1 = 2. If that is currently still happening in > your form, can you submit a bug using the Report an Issue menu in CommCare? > > -Clayton > > On Wed, Jul 26, 2017 at 12:19 AM, Adi Smith <adis...@gmail.com > wrote: > >> I have created some lookup table using two languages following the >> instructions here: >> >> >> https://confluence.dimagi.com/display/commcarepublic/Using+Lookup+Tables+with+Multiple+Languages >> >> The lookup questions work, however they only work when the hidden >> lang-code label is in a particular position: >> >> - The label is at the beginning of the form >> - The label is not in a group or a question list >> - The label still displays at the beginning of the form (despite the >> display criteria of 1=2) >> >> If I place it anywhere else, the drop down list options are blank because >> the form fails to set the correct *lang-code.* >> >> Where is the best place to put the hidden label to make sure it gets >> evaluated properly and it is not shown the user? >> >> >> >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

Hey all,

I’ve verified that this is happening for me as well on a test form - it
appears that in App Preview the display condition of the first question in
a form is not evaluated when the form is initially opened. I’ve filed a
ticket to look into this bug and will update this thread once we’ve
deployed a fix.

Cheers,
Will

··· On Thu, Aug 3, 2017 at 10:57 PM, wrote:

Note 1=2 is one of those display conditions that doesn’t work in the app
preview when 1 question per screen is turned on. It works with the 1
question per screen setting turned off, or on a mobile device. If you
haven’t tested outside of app preview that’s quite likely what the problem
is.

Cheers,
Amber.

On Friday, August 4, 2017 at 6:01:59 AM UTC+8, Clayton Sims wrote:

Hi Adi,

It’s quite surprising to me that the label is not hiding hiding due if
your display condition is 1 = 2. If that is currently still happening in
your form, can you submit a bug using the Report an Issue menu in CommCare?

-Clayton

On Wed, Jul 26, 2017 at 12:19 AM, Adi Smith adis...@gmail.com wrote:

I have created some lookup table using two languages following the
instructions here:

https://confluence.dimagi.com/display/commcarepublic/Using+L
ookup+Tables+with+Multiple+Languages

The lookup questions work, however they only work when the hidden
lang-code label is in a particular position:

  • The label is at the beginning of the form
  • The label is not in a group or a question list
  • The label still displays at the beginning of the form (despite the
    display criteria of 1=2)

If I place it anywhere else, the drop down list options are blank
because the form fails to set the correct lang-code.

Where is the best place to put the hidden label to make sure it gets
evaluated properly and it is not shown the user?

https://lh3.googleusercontent.com/-NoEFTO4kjio/WXgXklu4srI/AAAAAAAAsTU/LZw0TyJLH3sqvC5igMHfsmxBOhOl-nb-QCLcBGAs/s1600/Lookup%2BQuestions%2BLanguage%2BLabel.png


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-user...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

3 years later. Any news?