List Users API

Hi all,

I’m trying to use the List Users API. This has worked in the past, so I’m
not sure what I’m doing wrong.

I’ve tried using both the full users API and the specific users API:

https://www.commcarehq.org/a/[domain]/api/v0.4/user/?format=json
https://www.commcarehq.org/a/[domain]/api/v0.4/user/[userid]/?format=json

Unfortunately, each one is returning HTTP 500 and {“error_message”: “Sorry,
this request could not be processed. Please try again later.”}

Is anyone else using this successfully? Perhaps I am forgetting a step from
last time I did this…

Thanks,
Brian

Hey Brian,

The user APIs were down for part of yesterday due to an upgrade. The
problem should have been resolved around 11:30pm EDT. Can you confirm it’s
working again?

thanks,
Cory

··· On Thu, May 2, 2013 at 7:56 PM, Brian DeRenzi wrote:

Hi all,

I’m trying to use the List Users API. This has worked in the past, so I’m
not sure what I’m doing wrong.

I’ve tried using both the full users API and the specific users API:

https://www.commcarehq.org/a/[domain]/api/v0.4/user/?format=json
https://www.commcarehq.org/a/[domain]/api/v0.4/user/[userid]/?format=json

Unfortunately, each one is returning HTTP 500 and {“error_message”:
“Sorry, this request could not be processed. Please try again later.”}

Is anyone else using this successfully? Perhaps I am forgetting a step
from last time I did this…

Thanks,
Brian


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey Cory,

All seems to be working now, thanks.

For the future, there’s not a status page for various CCHQ functionality I
should check, right? I’m thinking something like github/AWS/skype/etc.

https://status.github.com/

Brian

··· On Fri, May 3, 2013 at 6:55 AM, Cory Zue wrote:

Hey Brian,

The user APIs were down for part of yesterday due to an upgrade. The
problem should have been resolved around 11:30pm EDT. Can you confirm it’s
working again?

thanks,
Cory

On Thu, May 2, 2013 at 7:56 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Hi all,

I’m trying to use the List Users API. This has worked in the past, so I’m
not sure what I’m doing wrong.

I’ve tried using both the full users API and the specific users API:

https://www.commcarehq.org/a/[domain]/api/v0.4/user/?format=json
https://www.commcarehq.org/a/[domain]/api/v0.4/user/[userid]/?format=json

Unfortunately, each one is returning HTTP 500 and {“error_message”:
“Sorry, this request could not be processed. Please try again later.”}

Is anyone else using this successfully? Perhaps I am forgetting a step
from last time I did this…

Thanks,
Brian


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey Cory,

All seems to be working now, thanks.

For the future, there’s not a status page for various CCHQ functionality I
should check, right? I’m thinking something like github/AWS/skype/etc.

https://status.github.com/

Nope, but this is a great suggestion and something we’d like to setup
sometime soon. We currently announce all planned downtime downtime on this
list, as well as any major unplanned disruptions. This one was a borderline
call that we maybe got wrong.

thanks,
Cory

··· On Fri, May 3, 2013 at 10:22 AM, Brian DeRenzi wrote:

Brian

On Fri, May 3, 2013 at 6:55 AM, Cory Zue czue@dimagi.com wrote:

Hey Brian,

The user APIs were down for part of yesterday due to an upgrade. The
problem should have been resolved around 11:30pm EDT. Can you confirm it’s
working again?

thanks,
Cory

On Thu, May 2, 2013 at 7:56 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Hi all,

I’m trying to use the List Users API. This has worked in the past, so I’m
not sure what I’m doing wrong.

I’ve tried using both the full users API and the specific users API:

https://www.commcarehq.org/a/[domain]/api/v0.4/user/?format=json
https://www.commcarehq.org/a/[domain]/api/v0.4/user/[userid]/?format=json

Unfortunately, each one is returning HTTP 500 and {“error_message”:
“Sorry, this request could not be processed. Please try again later.”}

Is anyone else using this successfully? Perhaps I am forgetting a step
from last time I did this…

Thanks,
Brian


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.