Install error on local {production install instructions) some apps not working......?

All seemed well on this install on my local ubuntu 16.04
server…Commcare HQ web site comes up and I am able to navigate
througout the application and create forms as well…

however when i go to the lookup table applicaition on the Manage table
application this is showing up… I have the default host set in the
localsettings.py and the django.config…not sure what im
missing…if the host was not correct the whole application would not
work…correct? so why just this part.(at least this is the first one
that I found)

Any help getting this troubleshot would be appreciated.

I followed the production install instructions
here…https://github.com/dimagi/commcare-hq/blob/master/PRODUCTION-INSTALL.md
ubuntu server 16.04 LTS with 16g ram

DisallowedHost at /a/localdev/fixtures/edit_lookup_tables/

Invalid HTTP_HOST header: ‘192.168.1.52:8000’. You may need to add u’192.168.1.52’ to ALLOWED_HOSTS.

Request Method: GET
Request URL:
http://192.168.1.52:8000/a/localdev/fixtures/edit_lookup_tables/
Django Version: 1.10.7
Exception Type: DisallowedHost
Exception Value:

Invalid HTTP_HOST header: ‘192.168.1.52:8000’. You may need to add u’192.168.1.52’ to ALLOWED_HOSTS.

Exception Location: /home/commcarehq/local/lib/python2.7/site-packages/django/http/request.py
in get_host, line 113
Python Executable: /home/commcarehq/bin/python
Python Version: 2.7.12
Python Path:

[’/home/commcarehq/commcare-hq’,
‘custom/_legacy’,
‘corehq/ex-submodules’,
‘submodules/langcodes’,
‘submodules/couchdbkit-aggregate’,
‘submodules/django-prbac-src’,
‘submodules/vellum’,
‘submodules/formtranslate-src’,
‘submodules/xml2json’,
‘submodules/django-digest-src’,
‘submodules/django-no-exceptions’,
‘submodules/commcare-translations’,
‘submodules/auditcare-src’,
‘submodules/dimagi-utils-src’,
‘submodules/touchforms-src’,
‘submodules/python-digest’,
’/home/commcarehq/lib/python2.7’,
’/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu’,
’/home/commcarehq/lib/python2.7/lib-tk’,
’/home/commcarehq/lib/python2.7/lib-old’,
’/home/commcarehq/lib/python2.7/lib-dynload’,
’/usr/lib/python2.7’,
’/usr/lib/python2.7/plat-x86_64-linux-gnu’,
’/usr/lib/python2.7/lib-tk’,
’/home/commcarehq/local/lib/python2.7/site-packages’,
‘submodules’]

Server time: Sat, 8 Jul 2017 00:38:46 +0000

Hi John,

Responded inline next to the error.

All seemed well on this install on my local ubuntu 16.04
server…Commcare HQ web site comes up and I am able to navigate
througout the application and create forms as well…

however when i go to the lookup table applicaition on the Manage table
application this is showing up… I have the default host set in the
localsettings.py and the django.config…not sure what im
missing…if the host was not correct the whole application would not
work…correct? so why just this part.(at least this is the first one
that I found)

Any help getting this troubleshot would be appreciated.

I followed the production install instructions here…
https://github.com/dimagi/commcare-hq/blob/master/PRODUCTION-INSTALL.md
ubuntu server 16.04 LTS with 16g ram

DisallowedHost at /a/localdev/fixtures/edit_lookup_tables/

Invalid HTTP_HOST header: ‘192.168.1.52:8000’. You may need to add u’192.168.1.52’ to ALLOWED_HOSTS.

Looks like you’ll need to add your IP address to your ALLOWED_HOSTS
setting. https://docs.djangoproject.com/en/1.11/ref/settings/#allowed-hosts

··· On Fri, Jul 7, 2017 at 10:38 PM John Harper wrote:

Request Method: GET
Request URL:
http://192.168.1.52:8000/a/localdev/fixtures/edit_lookup_tables/
Django Version: 1.10.7
Exception Type: DisallowedHost
Exception Value:

Invalid HTTP_HOST header: ‘192.168.1.52:8000’. You may need to add u’192.168.1.52’ to ALLOWED_HOSTS.

Exception Location: /home/commcarehq/local/lib/python2.7/site-packages/django/http/request.py
in get_host, line 113
Python Executable: /home/commcarehq/bin/python
Python Version: 2.7.12
Python Path:

[’/home/commcarehq/commcare-hq’,
‘custom/_legacy’,
‘corehq/ex-submodules’,
‘submodules/langcodes’,
‘submodules/couchdbkit-aggregate’,
‘submodules/django-prbac-src’,
‘submodules/vellum’,
‘submodules/formtranslate-src’,
‘submodules/xml2json’,
‘submodules/django-digest-src’,
‘submodules/django-no-exceptions’,
‘submodules/commcare-translations’,
‘submodules/auditcare-src’,
‘submodules/dimagi-utils-src’,
‘submodules/touchforms-src’,
‘submodules/python-digest’,
’/home/commcarehq/lib/python2.7’,
’/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu’,
’/home/commcarehq/lib/python2.7/lib-tk’,
’/home/commcarehq/lib/python2.7/lib-old’,
’/home/commcarehq/lib/python2.7/lib-dynload’,
’/usr/lib/python2.7’,
’/usr/lib/python2.7/plat-x86_64-linux-gnu’,
’/usr/lib/python2.7/lib-tk’,
’/home/commcarehq/local/lib/python2.7/site-packages’,
‘submodules’]

Server time: Sat, 8 Jul 2017 00:38:46 +0000


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I had set it up on a virtual machine some time ago. You should go with
Johns Suggestion, it worked for me a while back. I also want to reinstall
it. Ive been having problems with getting the formplayer run through the
docker image & not getting through this forum. I think i will try to
reinstall the production version and see if the same problem persists.

··· On Saturday, July 8, 2017 at 5:38:01 AM UTC+3, John Harper wrote: > > All seemed well on this install on my local ubuntu 16.04 > server.......Commcare HQ web site comes up and I am able to navigate > througout the application and create forms as well.......... > > however when i go to the lookup table applicaition on the Manage table > application this is showing up.... I have the default host set in the > localsettings.py and the django.config.......not sure what im > missing........if the host was not correct the whole application would not > work........correct? so why just this part.(at least this is the first one > that I found) > > Any help getting this troubleshot would be appreciated. > > I followed the production install instructions here..... > https://github.com/dimagi/commcare-hq/blob/master/PRODUCTION-INSTALL.md > ubuntu server 16.04 LTS with 16g ram > > > > DisallowedHost at /a/localdev/fixtures/edit_lookup_tables/ > > Invalid HTTP_HOST header: '192.168.1.52:8000'. You may need to add u'192.168.1.52' to ALLOWED_HOSTS. > > Request Method: GET > Request URL: > http://192.168.1.52:8000/a/localdev/fixtures/edit_lookup_tables/ > Django Version: 1.10.7 > Exception Type: DisallowedHost > Exception Value: > > Invalid HTTP_HOST header: '192.168.1.52:8000'. You may need to add u'192.168.1.52' to ALLOWED_HOSTS. > > Exception Location: /home/commcarehq/local/lib/python2.7/site-packages/django/http/request.py > in get_host, line 113 > Python Executable: /home/commcarehq/bin/python > Python Version: 2.7.12 > Python Path: > > ['/home/commcarehq/commcare-hq', > 'custom/_legacy', > 'corehq/ex-submodules', > 'submodules/langcodes', > 'submodules/couchdbkit-aggregate', > 'submodules/django-prbac-src', > 'submodules/vellum', > 'submodules/formtranslate-src', > 'submodules/xml2json', > 'submodules/django-digest-src', > 'submodules/django-no-exceptions', > 'submodules/commcare-translations', > 'submodules/auditcare-src', > 'submodules/dimagi-utils-src', > 'submodules/touchforms-src', > 'submodules/python-digest', > '/home/commcarehq/lib/python2.7', > '/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu', > '/home/commcarehq/lib/python2.7/lib-tk', > '/home/commcarehq/lib/python2.7/lib-old', > '/home/commcarehq/lib/python2.7/lib-dynload', > '/usr/lib/python2.7', > '/usr/lib/python2.7/plat-x86_64-linux-gnu', > '/usr/lib/python2.7/lib-tk', > '/home/commcarehq/local/lib/python2.7/site-packages', > 'submodules'] > > Server time: Sat, 8 Jul 2017 00:38:46 +0000 >

Thanks for the reply on this…I am a database guy and know my way
around linux enough to muddle through most any problem…this one is
stumping me.

There is several settings.py files for the nginx and django settings from
which I believe im set up correctly. the system is still in debug mode so
the host should still respond to
[192.168.1.52, localhost, 127.0.0.1] in the settings. if i use just the ip
i get the BAD GATEWAY error.

This may be a kafka setting involving the published.host settings and the
broker connection. I am picking through the log files and identifying the
errors. I post anything i may find.

I have a working development box hosted on Digital ocean but I wanted to
get a “working” production mode server working prior to building one on
another cloud box…

I am doing a local box for a group I belong to …shameless plug here [
The British Columbia Off road Association] we have over 1500 members that
have the need to identify trash, dump sites and abandoned equipment along
thousands of of miles of forest roads and jeep trails. The group donates
their time several times a year to actively remove this from the trails and
keep the areas clean for all to use…
That many users is more than the group can support as a non-profit so this
is the solution…i hope.

Any help you can lend is always appreciated…

··· On Sunday, July 9, 2017 at 11:44:14 PM UTC-7, Mr. Gat wrote: > > I had set it up on a virtual machine some time ago. You should go with > Johns Suggestion, it worked for me a while back. I also want to reinstall > it. Ive been having problems with getting the formplayer run through the > docker image & not getting through this forum. I think i will try to > reinstall the production version and see if the same problem persists. > > On Saturday, July 8, 2017 at 5:38:01 AM UTC+3, John Harper wrote: >> >> All seemed well on this install on my local ubuntu 16.04 >> server.......Commcare HQ web site comes up and I am able to navigate >> througout the application and create forms as well.......... >> >> however when i go to the lookup table applicaition on the Manage table >> application this is showing up.... I have the default host set in the >> localsettings.py and the django.config.......not sure what im >> missing........if the host was not correct the whole application would not >> work........correct? so why just this part.(at least this is the first one >> that I found) >> >> Any help getting this troubleshot would be appreciated. >> >> I followed the production install instructions here..... >> https://github.com/dimagi/commcare-hq/blob/master/PRODUCTION-INSTALL.md >> ubuntu server 16.04 LTS with 16g ram >> >> >> >> DisallowedHost at /a/localdev/fixtures/edit_lookup_tables/ >> >> Invalid HTTP_HOST header: '192.168.1.52:8000'. You may need to add u'192.168.1.52' to ALLOWED_HOSTS. >> >> Request Method: GET >> Request URL: >> http://192.168.1.52:8000/a/localdev/fixtures/edit_lookup_tables/ >> Django Version: 1.10.7 >> Exception Type: DisallowedHost >> Exception Value: >> >> Invalid HTTP_HOST header: '192.168.1.52:8000'. You may need to add u'192.168.1.52' to ALLOWED_HOSTS. >> >> Exception Location: /home/commcarehq/local/lib/python2.7/site-packages/django/http/request.py >> in get_host, line 113 >> Python Executable: /home/commcarehq/bin/python >> Python Version: 2.7.12 >> Python Path: >> >> ['/home/commcarehq/commcare-hq', >> 'custom/_legacy', >> 'corehq/ex-submodules', >> 'submodules/langcodes', >> 'submodules/couchdbkit-aggregate', >> 'submodules/django-prbac-src', >> 'submodules/vellum', >> 'submodules/formtranslate-src', >> 'submodules/xml2json', >> 'submodules/django-digest-src', >> 'submodules/django-no-exceptions', >> 'submodules/commcare-translations', >> 'submodules/auditcare-src', >> 'submodules/dimagi-utils-src', >> 'submodules/touchforms-src', >> 'submodules/python-digest', >> '/home/commcarehq/lib/python2.7', >> '/home/commcarehq/lib/python2.7/plat-x86_64-linux-gnu', >> '/home/commcarehq/lib/python2.7/lib-tk', >> '/home/commcarehq/lib/python2.7/lib-old', >> '/home/commcarehq/lib/python2.7/lib-dynload', >> '/usr/lib/python2.7', >> '/usr/lib/python2.7/plat-x86_64-linux-gnu', >> '/usr/lib/python2.7/lib-tk', >> '/home/commcarehq/local/lib/python2.7/site-packages', >> 'submodules'] >> >> Server time: Sat, 8 Jul 2017 00:38:46 +0000 >> >