Importing Cases

I tried importing cases from an Excel spreadsheet for the first time
yesterday. A couple of things confused me a bit.

  1. What does “this field is a date” do? I found the only way I could
    successfully import dates was to have text fields in the spreadsheet
    formated as YYYY-MM-DD, and not ticking the “field is date” box. When I
    tried using Excel dates and ticking the “field is date” box, I just got
    numbers (the Excel date values), which CommCare did not treat as dates.

  2. All integer numeric fields (including Excel dates) were imported as
    whatever.0. This probably doesn’t matter too much in some cases, but I can
    see how it might cause problems. Is there someway (apart from forcing all
    the fields in the Excel sheet to be text fields), that 1 can be imported as
    1, not 1.0?

Thanks.

Hi James,

Sorry to hear you had a rough experience with the importer.

  1. Since Excel stores dates as numbers (the numbers you got during your
    import), the “this field is a date” checkbox exists to let the importer
    tool know it is a date value and not just a number. This seems to be
    working for me for uploading excel date type fields and checking that box.
    Would you be able to send me an example spreadsheet you are using that
    isn’t working properly? You can send to me directly instead of the group if
    you prefer.

  2. I am seeing this as well currently and will look into it.

Tyler Wymer

··· On Fri, Sep 6, 2013 at 6:37 AM, james beard wrote:

I tried importing cases from an Excel spreadsheet for the first time
yesterday. A couple of things confused me a bit.

  1. What does “this field is a date” do? I found the only way I could
    successfully import dates was to have text fields in the spreadsheet
    formated as YYYY-MM-DD, and not ticking the “field is date” box. When I
    tried using Excel dates and ticking the “field is date” box, I just got
    numbers (the Excel date values), which CommCare did not treat as dates.

  2. All integer numeric fields (including Excel dates) were imported as
    whatever.0. This probably doesn’t matter too much in some cases, but I can
    see how it might cause problems. Is there someway (apart from forcing all
    the fields in the Excel sheet to be text fields), that 1 can be imported as
    1, not 1.0?

Thanks.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks. I’ve just tried to reproduce problem 1 with a file I could send
you, but it seems to be working. Maybe it was user-error last week. Sorry
for disturbance.

··· On Friday, September 6, 2013 3:39:10 PM UTC, twymer wrote: > > Hi James, > > Sorry to hear you had a rough experience with the importer. > > 1. Since Excel stores dates as numbers (the numbers you got during your > import), the "this field is a date" checkbox exists to let the importer > tool know it is a date value and not just a number. This seems to be > working for me for uploading excel date type fields and checking that box. > Would you be able to send me an example spreadsheet you are using that > isn't working properly? You can send to me directly instead of the group if > you prefer. > > 2. I am seeing this as well currently and will look into it. > > Tyler Wymer > > > On Fri, Sep 6, 2013 at 6:37 AM, james beard <james.b...@gmail.com wrote: > >> I tried importing cases from an Excel spreadsheet for the first time >> yesterday. A couple of things confused me a bit. >> >> 1. What does "this field is a date" do? I found the only way I could >> successfully import dates was to have text fields in the spreadsheet >> formated as YYYY-MM-DD, and _not_ ticking the "field is date" box. When I >> tried using Excel dates and ticking the "field is date" box, I just got >> numbers (the Excel date values), which CommCare did not treat as dates. >> >> 2. All integer numeric fields (including Excel dates) were imported as >> whatever.0. This probably doesn't matter too much in some cases, but I can >> see how it might cause problems. Is there someway (apart from forcing all >> the fields in the Excel sheet to be text fields), that 1 can be imported as >> 1, not 1.0? >> >> Thanks. >> >> >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/groups/opt_out. >> > >