Imported cases not showing in exports


On our local instance, imported cases are synced to the phone but do not show on exports nor on the case list report. Any clue on the possible issue?



That sounds like it could be an issue with the cases getting into Elasticsearch. Are you running the case-pillow process?

1 Like

Yes case-pillow is running.

Could you check the logs for that process to ensure it is processing correctly.

Side note: I see that you are running 'errand-boy' which is not necessary anymore. You can see that change log for when that was removed here.

I check this file /home/cchq/www/monolith/log/pillowtop-case-pillow-0.log (Is this the right file?)

I don't really know what it should contain, so I don't really know if the current content is right

Does this mean anything to you ?

Would a kafka service interruption explain the problem described above?


Hi @Simon_Kelly

Is there a command to trigger the update of ES manually?


It seems that the data that is not showing up in the exports was imported while Kafka was down. I've tried importing data with all services running and it shows in exports.

If you know the approximate date when the import was done you can run this command:

python resave_failed_forms_and_cases [domain] [start date] [end date]

The start date and end date arguments should be formatted as YYYY-MM-DD.

Besides that, even if Kafka was down I would have expected the import to fail or at least the data to get re-tried at a later time. Are you running the submission_reprocessing_queue? I didn't see it in the list of processes. If it is not running I would recommend running it.

You can see the configuration we are using here. You only need the 'survey', 'schedule_instances' and 'sms' ones if you are doing SMS messaging but I would recommend you run the submission_reprocessing_queue and then pillow_retry_queue.


This is how we updated our app-process.yml file:


We are able to update the config and it seems that the reprocessing queue is identified but it seems to be blocked:

Since we are running a fairly old version of CommCare, we were wondering if the config file is OK? Or how can we unblock the queue?



You could check the celery queue process logs to see if it is process - it may just be that there's a backlog.

Otherwise the config looks fine.

We managed to fix the problem. There was a port conflict with Kafka and the backup tool running in the background. We also had to restart supervisor services to take into account the newly configured queues (we are finalizing that piece).

Great that you got it sorted!