FW: Msakhi Mobile data

Hi Girdhari,

We believe you are encountering a bug that exists in older versions of
CommCare that causes sending to be very slow when there are many pending log
files on the phone. An upgrade to the latest phone software should fix this.
To upgrade, go to Applications, click Edit, then under Advanced Settings -->
Build Settings choose “CommCare 1.2.0”. Then make a new build and install it
onto the phones.

As always please report back if you continue to have problems.

thanks,
Cory

··· -- Cory L. Zue Dimagi, Inc http://www.dimagi.com/

On Thu, Aug 4, 2011 at 12:29 AM, Girdhari Bora gbora@intrahealth.orgwrote:

Dear Cory,****


I am sending you all the related files from one of the CommCare
applications which is giving trouble and is getting stuck while submitting
the form data. The application gets stuck at the last prompt and in some
cases take 15-20 mins.****


This issue is still ON and I can send more data if you need but I request
for its early redressal as we need the data. I reiterate that the
application is working fine with DATA NOT being sent and till we have a
solution for the existing issue we may have to work on the same build.****


Please tell if you need more data.****


Warm regards,****

girdhari****




Hi Girdhari,****


And just in case Clayton’s email wasn’t clear, your data is NOT being saved
until you change this setting back. If you are expecting to see and work
with this data you should change the setting back and update the phones as
soon as possible.****


Cory****

On Fri, Jul 29, 2011 at 8:28 PM, Amelia Sagoff amsagoff@gmail.com wrote:


Hi Girdhari,****


Do you have any more specifics about at which points the application is
stalling/getting stuck?****


Also, it would be very helpful if you could copy over one of the
problematic installations (jar/jad and all app created rms files) and send
it to us.****


Thanks,
Amelia****


On Thu, Jul 28, 2011 at 7:45 AM, Girdhari Bora gbora@intrahealth.org
wrote:****

Hello Amelia,****


I had marked “Record submission format” as don’t save in the main
application edit page. Please find the screen shot for your perusal.****


[image: Record submission format.JPG]****


Does this not mean, data will not be submitted back? I had just modified
this attribute à saved à build. I could not find the data reported in
CommCare when I used it, can you please confirm.****


What this did was that application was running smoothly. Earlier the
application was getting stuck on some prompts (for 15 mins in some cases). I
assumed that the above feature do not send back the data , as Cory had
already suggested the problem to be some GPRS issue while data submit.****


Please ask for any other info needed.****



Warm regards,****

girdhari****




From: Amelia Sagoff [mailto:amsagoff@gmail.com]
Sent: Wednesday, July 27, 2011 7:10 PM
To: Girdhari Bora
Cc: Cory Zue; commcare-users@googlegroups.com; Laboni Jana; neal lesh;
Mohini Bhavsar; derek.treatman@gmail.com****

Subject: Re: mSakhi (commcare) application error****


Hi Girdhari,****


I have downloaded and installed your latest build, and the application runs
and submits data just fine. You can see my submissions as “demo_user” in
the submission log on CommCareHQ.****


I suspect there is a configuration problem on your phones? Check out this
troubleshooting page on the wiki:
https://wiki.commcarehq.org/display/commcarepublic/CommCare+is+Broken!**
**


If you reply with more details about the problems and errors you’re
encountering, our team can better help you!****


Good luck,****

Amelia****

On Wed, Jul 27, 2011 at 7:50 AM, Girdhari Bora gbora@intrahealth.org
wrote:****

Dear Cory (and Team),****


We have tested the current version of mSakhi application in all the
mobiles and are unable to run the application with the GPRS submit ON. I
have recompiled the application after turning OFF the data submit feature
and its running fine.****


As the data is getting submitted forms wise and we have to capture that
data, can you please suggest some way around ?****


We urgently need to work on this as we may lose some significant data,
which we are planning to use for the impact study.****


Warm regards,****

girdhari****



From: Cory Zue [mailto:czue@dimagi.com]
Sent: Monday, July 18, 2011 10:16 AM
To: Girdhari Bora
Cc: amsagoff@gmail.com; commcare-users@googlegroups.com; Laboni Jana
Subject: Re: mSakhi (commcare) application error****


Hi Girdhari,

I don’t have specifics, but this sounds like the phone is having GPRS
issues.

You might like to run through the GPRS setup instructions and see if that
can resolve anything.
https://wiki.commcarehq.org/display/commcarepublic/GPRS+Setup

Also check in the phone’s browser to see if you can access the net.

And always check the date and time settings.

Cory****

On Sun, Jul 17, 2011 at 11:09 PM, Girdhari Bora gbora@intrahealth.org
wrote:****

Dear Amelia,****


Can you please comment on the below mail. I am going to Bahraich tonight
and will be looking at the things myself, though if you have time. Kindly
look into it.****


Regards,****

girdhari****




From: Manish Sharma
Sent: Sunday, July 17, 2011 3:21 PM
To: Aditya Tomar
Cc: Laboni Jana; Amod Kumar; Girdhari Bora
Subject: RE: mSakhi and DHIS2****


Dear Sir ****

Please find attached success story of m-sakhi and status of application.
there are in all mobile of m sakhi shown application error given below.***
*

mt****

mt****

unhandled exception in gui-iclp=>jd[null]****


in risiya block all 5 asha working using it demo mode because application
not accept feach data given application error is *java.io.IOexception[61-error in HTTP operation]



please kindly guide and suggest me for application error.****


With best regards****

Manish ****



Amelia Sagoff****



Amelia Sagoff****



Hi Girdhari,

··· ** > > **1. **Except the first prompt all other prompts are coming with an > OK (*see image below*)for the previous prompt. We don’t need that, can we > fix this ? >

This is a result of the images being resized to fit on the screen. I believe
that manually resizing the images to make sure they take the full
height/width of the screen should resolve this. Take a look at this guide
which should give you rough guidelines for sizing. In the screenshot you
sent, the correct size for a Nokia 2700 or C201 would be 225x175.

https://wiki.commcarehq.org/display/commcarepublic/Images+in+CommCare



  1.   **The last prompt of a form is showing an OK message. We do not
    

need this as well and moreover CHWs are not used to this confirmation
prompt. Can we fix this as well.

Someone on the mobile team should be able to confirm whether this is
configurable.

thanks,
Cory

Girdhari,

Is the last prompt you’re referring to here a normal prompt that looks like
a question in CommCare, or the full screen message which is displayed?

-Clayton

··· On Sun, Aug 7, 2011 at 10:45 AM, Cory Zue wrote:

Hi Girdhari,

**

**1. **Except the first prompt all other prompts are coming with an
OK (see image below)for the previous prompt. We don’t need that, can
we fix this ?

This is a result of the images being resized to fit on the screen. I
believe that manually resizing the images to make sure they take the full
height/width of the screen should resolve this. Take a look at this guide
which should give you rough guidelines for sizing. In the screenshot you
sent, the correct size for a Nokia 2700 or C201 would be 225x175.

https://wiki.commcarehq.org/display/commcarepublic/Images+in+CommCare



  1.   **The last prompt of a form is showing an OK message. We do not
    

need this as well and moreover CHWs are not used to this confirmation
prompt. Can we fix this as well.

Someone on the mobile team should be able to confirm whether this is
configurable.

thanks,
Cory

Hi Girdhari,

  1. There is a feature in CommCare HQ (currently in beta) that will let you
    specify your own translations of these default messages. Under the
    application, check out “User Interface Translations
    (Beta)https://www.commcarehq.org/a/demo/apps/view/3adc6d3b773f9de9ea08da00ac684b15/#”.
    I think the string you want to change is “sending.view.done”

  2. Now that the form heading bar is gone, you’ve noticed there’s some extra
    space on the screen. The result is that a bit of the previous prompt shows.
    If you resize the picture to make it a bit taller, it will take up that
    extra space so the previous prompt does not show. As Cory mentioned, you
    can find the correct sizing here:
    https://wiki.commcarehq.org/display/commcarepublic/Images+in+CommCare

Hope this helps!
Amelia

··· On Tue, Aug 9, 2011 at 6:24 AM, Girdhari Bora wrote:

Dear Clayton,****


**1. The last prompt is the full screen message which says “Form
Complete,Thanks!” (see image) and needs OK to be pressed to move ahead,
I think it must have had its utility in some cases but in our case we do not
need it and moreover as it is in English it is quite awkward for a CHW to
see it.

[image: form complete.JPG]****


1. The other issue is the prompts do not show the Form
Heading(Name)
when I build the app with CommCare 1.2.0, resulting in display
of a label
on the screen showing the earlier prompt name with an OK (see
image). This is again awkward to view.


[image: without head label.JPG]****



I hope that clarifies. Please ask if need to know anything more.****



warm regards,****

girdhari****



From: Clayton Sims [mailto:csims@dimagi.com]
Sent: Monday, August 08, 2011 8:08 PM
To: commcare-users@googlegroups.com
Cc: Girdhari Bora; Amelia Sagoff; derek.treatman@gmail.com; neal lesh;
Mohini Bhavsar; Amod Kumar

Subject: Re: FW: Msakhi Mobile data****


Girdhari,****


Is the last prompt you’re referring to here a normal prompt that looks like
a question in CommCare, or the full screen message which is displayed?****


-Clayton****

On Sun, Aug 7, 2011 at 10:45 AM, Cory Zue czue@dimagi.com wrote:****

Hi Girdhari,****



  1.   Except the first prompt all other prompts are coming with an OK (
    

see image below)for the previous prompt. We don’t need that, can we fix
this ?****


This is a result of the images being resized to fit on the screen. I
believe that manually resizing the images to make sure they take the full
height/width of the screen should resolve this. Take a look at this guide
which should give you rough guidelines for sizing. In the screenshot you
sent, the correct size for a Nokia 2700 or C201 would be 225x175.****


https://wiki.commcarehq.org/display/commcarepublic/Images+in+CommCare ****


  1.   The last prompt of a form is showing an OK message. We do not
    

need this as well and moreover CHWs are not used to this confirmation
prompt. Can we fix this as well.****


Someone on the mobile team should be able to confirm whether this is
configurable.****


thanks,****

Cory****



Amelia Sagoff