Form disappeared after completion

Hi,

Yesterday afternoon, one of our mobile workers experienced a disappearing
survey. He completed the registration form and the baseline survey as per
usual, and he saved and submitted both forms as per usual. He then synced
the tablet. He experienced no error messages or unusual behaviour during
this process.

However, when he went back to review his daily work for reporting, the
baseline survey was no longer visible on the tablet. On CommCare HQ, I can
see the registration form, but there is no baseline survey.

He’s using a Samsung galaxy tablet.

Any ideas on what might have happened, and more importantly, is there any
way to find and retrieve this survey?

Many thanks,
Julia

Hi Julia,

I have been experiencing a similar problem, where my mobile worker will
fill in a form and save and submit, but then some time later when accessing
the app to complete other forms that form will have disappeared, and
because i have case filters, certain actions are prevented, ie in our app
students complete a clock in form when they start their day, then they will
fill in skills forms while at the site and before leaving they fill in a
clock out form - skills forms can only be completed if you are clocked in
and if you cannot clock in again if you’re already clocked in. So students
clock in in the morning and when they try to fill in skills form s it will
show that they have not clocked in (as the form has disappeared), but now
the app will not let them clock in again.

Anyway, I initially suspected that students could have had the autoupdate
feature on playstore enabled and if an update occurred while clocked it, it
froze that form and reset the app, but then i found some students do not
have autoupdate enabled so that theory fell flat. Any ideas from the
CommCare team?

Confused,
Ameera

··· On Friday, 13 March 2015 09:37:30 UTC+2, Julia de Kadt wrote: > > Hi, > > Yesterday afternoon, one of our mobile workers experienced a disappearing > survey. He completed the registration form and the baseline survey as per > usual, and he saved and submitted both forms as per usual. He then synced > the tablet. He experienced no error messages or unusual behaviour during > this process. > > However, when he went back to review his daily work for reporting, the > baseline survey was no longer visible on the tablet. On CommCare HQ, I can > see the registration form, but there is no baseline survey. > > He's using a Samsung galaxy tablet. > > Any ideas on what might have happened, and more importantly, is there any > way to find and retrieve this survey? > > Many thanks, > Julia >

Hi Julia,

I’m going to look into this more as a support issue. I’ll communicate with you further from the ticket that I’ll create now and I’ll respond to this thread with what we find.

Thanks,

Nate

··· > On Mar 13, 2015, at 3:37 AM, Julia de Kadt wrote: > > Hi, > > Yesterday afternoon, one of our mobile workers experienced a disappearing survey. He completed the registration form and the baseline survey as per usual, and he saved and submitted both forms as per usual. He then synced the tablet. He experienced no error messages or unusual behaviour during this process. > > However, when he went back to review his daily work for reporting, the baseline survey was no longer visible on the tablet. On CommCare HQ, I can see the registration form, but there is no baseline survey. > > He's using a Samsung galaxy tablet. > > Any ideas on what might have happened, and more importantly, is there any way to find and retrieve this survey? > > Many thanks, > Julia > -- > You received this message because you are subscribed to the Google Groups "commcare-users" group. > To unsubscribe from this group and stop receiving emails from it, send an email to commcare-users+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout.

yes , My project and my mobile worker already faced like those type
problem. suppose our mobile worker filled up form in the field then synced
to sever, but server get empty or data not seen in tablet. Commcare user
need to log in and log out, this is common rule. But commcarehq may be
’login’ work only fixed period. So after the fixed time of login system
expired it does not work really. If it shows us login mode that login may
be fake. When we entered the data in fake login tablet then we loss data
and it may be disappear. My experience will be useful for you. So I want to
share you that if you are starting to work with commcare you must logout
once more then login again before start to enter data. This act do not
recover your missed data but next time this problem will not seen or repeat
may be. thank you.

··· On Sun, Mar 15, 2015 at 7:33 PM, Ameera Hamid wrote:

Hi Julia,

I have been experiencing a similar problem, where my mobile worker will
fill in a form and save and submit, but then some time later when accessing
the app to complete other forms that form will have disappeared, and
because i have case filters, certain actions are prevented, ie in our app
students complete a clock in form when they start their day, then they will
fill in skills forms while at the site and before leaving they fill in a
clock out form - skills forms can only be completed if you are clocked in
and if you cannot clock in again if you’re already clocked in. So students
clock in in the morning and when they try to fill in skills form s it will
show that they have not clocked in (as the form has disappeared), but now
the app will not let them clock in again.

Anyway, I initially suspected that students could have had the autoupdate
feature on playstore enabled and if an update occurred while clocked it, it
froze that form and reset the app, but then i found some students do not
have autoupdate enabled so that theory fell flat. Any ideas from the
CommCare team?

Confused,
Ameera

On Friday, 13 March 2015 09:37:30 UTC+2, Julia de Kadt wrote:

Hi,

Yesterday afternoon, one of our mobile workers experienced a disappearing
survey. He completed the registration form and the baseline survey as per
usual, and he saved and submitted both forms as per usual. He then synced
the tablet. He experienced no error messages or unusual behaviour during
this process.

However, when he went back to review his daily work for reporting, the
baseline survey was no longer visible on the tablet. On CommCare HQ, I can
see the registration form, but there is no baseline survey.

He’s using a Samsung galaxy tablet.

Any ideas on what might have happened, and more importantly, is there any
way to find and retrieve this survey?

Many thanks,
Julia


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi CommCare-Users,

I just wanted to follow up with the resolution for this ticket, as
promised. We found that this form was lost because the user was logged out
during form completion. The user was logged out in accordance with our
CommCare session timeout, which occurs after 24 hours of being logged in.

We are making a change that will prevent the form loss from happening in
the future if a user is logged out in this way.

Thanks,

··· -- Nate Haduch

Technical Support Analyst
Dimagi, Inc | 585 Massachusetts Ave | Suite 3 | Cambridge, MA 02139
web: http://www.dimagi.com/

On Mon, Mar 16, 2015 at 2:21 PM, Nate nhaduch@dimagi.com wrote:

Hi Julia,

I’m going to look into this more as a support issue. I’ll communicate with
you further from the ticket that I’ll create now and I’ll respond to this
thread with what we find.

Thanks,

Nate

On Mar 13, 2015, at 3:37 AM, Julia de Kadt jdekadt@gmail.com wrote:

Hi,

Yesterday afternoon, one of our mobile workers experienced a disappearing
survey. He completed the registration form and the baseline survey as per
usual, and he saved and submitted both forms as per usual. He then synced
the tablet. He experienced no error messages or unusual behaviour during
this process.

However, when he went back to review his daily work for reporting, the
baseline survey was no longer visible on the tablet. On CommCare HQ, I can
see the registration form, but there is no baseline survey.

He’s using a Samsung galaxy tablet.

Any ideas on what might have happened, and more importantly, is there any
way to find and retrieve this survey?

Many thanks,
Julia


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for this feedback Nate! Very Helpful!!

··· On Thursday, 19 March 2015 15:38:26 UTC+2, nhaduch wrote: > > Hi CommCare-Users, > > I just wanted to follow up with the resolution for this ticket, as > promised. We found that this form was lost because the user was logged out > during form completion. The user was logged out in accordance with our > CommCare session timeout, which occurs after 24 hours of being logged in. > > We are making a change that will prevent the form loss from happening in > the future if a user is logged out in this way. > > Thanks, > > -- > Nate Haduch > > Technical Support Analyst > Dimagi, Inc | 585 Massachusetts Ave | Suite 3 | Cambridge, MA 02139 > web: http://www.dimagi.com/ > > > On Mon, Mar 16, 2015 at 2:21 PM, Nate <nha...@dimagi.com > wrote: > >> Hi Julia, >> >> I'm going to look into this more as a support issue. I'll communicate >> with you further from the ticket that I'll create now and I'll respond to >> this thread with what we find. >> >> Thanks, >> >> Nate >> >> On Mar 13, 2015, at 3:37 AM, Julia de Kadt <jde...@gmail.com > wrote: >> >> Hi, >> >> Yesterday afternoon, one of our mobile workers experienced a disappearing >> survey. He completed the registration form and the baseline survey as per >> usual, and he saved and submitted both forms as per usual. He then synced >> the tablet. He experienced no error messages or unusual behaviour during >> this process. >> >> However, when he went back to review his daily work for reporting, the >> baseline survey was no longer visible on the tablet. On CommCare HQ, I can >> see the registration form, but there is no baseline survey. >> >> He's using a Samsung galaxy tablet. >> >> Any ideas on what might have happened, and more importantly, is there any >> way to find and retrieve this survey? >> >> Many thanks, >> Julia >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> >> > > > >