Excel Dashboard integration

I have a paid account and a local server install for development and
testing and was wondering if someone can illuminate how to activate the
excel dashboard integration portion of the data module? looking high and
low and have not found a feature flag that makes any sense…

Hi John,

Have you seen the tutorial here?
https://confluence.dimagi.com/display/commcarepublic/Tutorial%3A+Create+an+Excel+Dashboard.
One thing to note is that you will need the Standard Plan or higher in
order for you to see the Excel Dashboard feature.

Ben

··· On Wed, May 31, 2017 at 2:58 AM, John Harper <john.harper@grableservices.com wrote:

I have a paid account and a local server install for development and
testing and was wondering if someone can illuminate how to activate the
excel dashboard integration portion of the data module? looking high and
low and have not found a feature flag that makes any sense…


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

yep on my local install is this issue…the option is not on the Data
Module. I am looking on how to enable this on my local VM instance for
testing…

any help would be appreciated. I am assuming that this is a preview or
Feature flag settings but I am not seeing the thing that I am missing.

··· On Wednesday, May 31, 2017 at 12:16:33 AM UTC-7, Ben Rudolph wrote: > > Hi John, > > Have you seen the tutorial here? > https://confluence.dimagi.com/display/commcarepublic/Tutorial%3A+Create+an+Excel+Dashboard. > One thing to note is that you will need the Standard Plan or higher in > order for you to see the Excel Dashboard feature. > > Ben > > On Wed, May 31, 2017 at 2:58 AM, John Harper <john....@grableservices.com > wrote: > >> I have a paid account and a local server install for development and >> testing and was wondering if someone can illuminate how to activate the >> excel dashboard integration portion of the data module? looking high and >> low and have not found a feature flag that makes any sense........ >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

Hi John,

Perhaps that item is show based on this condition:
https://github.com/dimagi/commcare-hq/blob/master/corehq/tabs/tabclasses.py#L453.
Maybe you can debug why that is returning false?

Ben

··· On Wed, May 31, 2017 at 5:11 PM, John Harper <john.harper@grableservices.com wrote:

yep on my local install is this issue…the option is not on the
Data Module. I am looking on how to enable this on my local VM instance
for testing…

any help would be appreciated. I am assuming that this is a preview or
Feature flag settings but I am not seeing the thing that I am missing.

On Wednesday, May 31, 2017 at 12:16:33 AM UTC-7, Ben Rudolph wrote:

Hi John,

Have you seen the tutorial here? https://confluence.dimag
i.com/display/commcarepublic/Tutorial%3A+Create+an+Excel+Dashboard. One
thing to note is that you will need the Standard Plan or higher in order
for you to see the Excel Dashboard feature.

Ben

On Wed, May 31, 2017 at 2:58 AM, John Harper <john....@grableservices.com wrote:

I have a paid account and a local server install for development and
testing and was wondering if someone can illuminate how to activate the
excel dashboard integration portion of the data module? looking high and
low and have not found a feature flag that makes any sense…


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

As a sanity check, can you confirm that your test domain has a subscription
plan that’s Standard or higher? For testing, the easiest way to set this
is:

$ ./manage.py make_domain_enterprise_level your-domain-name
··· On Wed, May 31, 2017 at 12:49 PM, Ben Rudolph wrote:

Hi John,

Perhaps that item is show based on this condition: https://github.com/
dimagi/commcare-hq/blob/master/corehq/tabs/tabclasses.py#L453. Maybe you
can debug why that is returning false?

Ben

On Wed, May 31, 2017 at 5:11 PM, John Harper <john.harper@grableservices. com> wrote:

yep on my local install is this issue…the option is not on the
Data Module. I am looking on how to enable this on my local VM instance
for testing…

any help would be appreciated. I am assuming that this is a preview or
Feature flag settings but I am not seeing the thing that I am missing.

On Wednesday, May 31, 2017 at 12:16:33 AM UTC-7, Ben Rudolph wrote:

Hi John,

Have you seen the tutorial here? https://confluence.dimag
i.com/display/commcarepublic/Tutorial%3A+Create+an+Excel+Dashboard. One
thing to note is that you will need the Standard Plan or higher in order
for you to see the Excel Dashboard feature.

Ben

On Wed, May 31, 2017 at 2:58 AM, John Harper < john....@grableservices.com> wrote:

I have a paid account and a local server install for development and
testing and was wondering if someone can illuminate how to activate the
excel dashboard integration portion of the data module? looking high and
low and have not found a feature flag that makes any sense…


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

im assuming that I run this in the /home/commcarehq/commcare-hq/
directory…should i be in the active invironment?

I ran this against my demo domain as such…

log in as commcarehq user

cd /home/commcarehq/

source bin/activate

cd /home/commcarehq/commcare-hq/

./manage.py make_domain_enterprise_level demo

this returned no errors …no log

not sure if it accomplished anything that helped.

··· On Wednesday, May 31, 2017 at 10:53:47 AM UTC-7, Ethan Soergel wrote: > > As a sanity check, can you confirm that your test domain has a > subscription plan that's Standard or higher? For testing, the easiest way > to set this is: > > $ ./manage.py make_domain_enterprise_level your-domain-name > > > On Wed, May 31, 2017 at 12:49 PM, Ben Rudolph <brud...@dimagi.com > wrote: > >> Hi John, >> >> Perhaps that item is show based on this condition: >> https://github.com/dimagi/commcare-hq/blob/master/corehq/tabs/tabclasses.py#L453. >> Maybe you can debug why that is returning false? >> >> Ben >> >> On Wed, May 31, 2017 at 5:11 PM, John Harper <john....@grableservices.com > wrote: >> >>> yep on my local install is this issue.........the option is not on the >>> Data Module. I am looking on how to enable this on my local VM instance >>> for testing............ >>> >>> any help would be appreciated. I am assuming that this is a preview or >>> Feature flag settings but I am not seeing the thing that I am missing. >>> >>> On Wednesday, May 31, 2017 at 12:16:33 AM UTC-7, Ben Rudolph wrote: >>>> >>>> Hi John, >>>> >>>> Have you seen the tutorial here? >>>> https://confluence.dimagi.com/display/commcarepublic/Tutorial%3A+Create+an+Excel+Dashboard. >>>> One thing to note is that you will need the Standard Plan or higher in >>>> order for you to see the Excel Dashboard feature. >>>> >>>> Ben >>>> >>>> On Wed, May 31, 2017 at 2:58 AM, John Harper < john....@grableservices.com> wrote: >>>> >>>>> I have a paid account and a local server install for development and >>>>> testing and was wondering if someone can illuminate how to activate the >>>>> excel dashboard integration portion of the data module? looking high and >>>>> low and have not found a feature flag that makes any sense........ >>>>> >>>>> -- >>>>> >>>>> --- >>>>> You received this message because you are subscribed to the Google >>>>> Groups "CommCare Developers" group. >>>>> To unsubscribe from this group and stop receiving emails from it, send >>>>> an email to commcare-developers+unsubscribe@googlegroups.com. >>>>> For more options, visit https://groups.google.com/d/optout. >>>>> >>>> >>>> -- >>> >>> --- >>> You received this message because you are subscribed to the Google >>> Groups "CommCare Developers" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to commcare-developers+unsubscribe@googlegroups.com >>> . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > >