Excel Dashboard Integration issue

Hi guys

a little bit of a weird one here.

I’ve got a bunch of Excel dashboards that read from our feeds without a hitch. except, recently I had a new team member join and they’re running Office 365 as opposed to what the rest of us run, office 2013.

For some reason, the same credentials that are working on other machines are not working on the one machine that’s running office 365. I get the following error

and then, i tried opening one of the dashboards i know are working on that machine and i got the following error when i clicked on “data->refresh” for the sheet where the query lives: “An unexpected error has occurred.”

and when i tried to refresh all, i got a message saying that "the data range failed to refresh: webquerynamehere. Continue to refresh?

the only difference is the excel version. anyone else had a problem like this?

Also, when the same credentials are used on my machine there are no problems.
i’m 100% sure it’s something to do with excel, and it’s likely me not checking some checkbox or button somewhere.

Any help here would be appreciated. otherwise, i might have to rollback to 2013.

Is this the web/browser version of Office 365 or a software client install? (apologies if I’m behind, 365 used to be the web branding, but Microsoft changes product label meanings all the time).

Googling around a bit it looks like Microsoft might have switched at some point to unifying the backend for data feeds between a few services which might explain why the new version is doing something different. Is there a data source authentication setting in the Data Source config dialog?

-Clayton

Hi Clayton,

It’s an offline install version but uses single sign on for authentication. yeah, i think you might be on to something there.
it’s a similarly designed interface but has many more options at some point. There’s basic, windows, API, and none i believe for authentication. I pick the basic option and I go ahead. I then get some options as to how to interpret the data coming in “HTML, XML, JSON, CSV, TEXT, etc…”

it just keeps failing at the authentication point.

do you think it’s worth using the API authentication mode?

I’m experiencing the same issue and found a workaround described here: https://social.technet.microsoft.com/Forums/office/en-US/f3099495-eba9-4600-85c5-131257564c82/get-data-from-web-with-authentication-connection-error?forum=excel

This seems to help with establishing the connection, but I don’t know if it help in addressing this specific issue in refreshing the data from an already established one.

Thanks!

I have given that a shot, but i’m afraid i got the same results. they may harmonized the infrastructure with patch releases.