Error : Unable to find lookup table: jr://fixture/item-list

Hi , hope every one is safe during these days

im using look up tables in an App in commcare but i keep on getting the following error

Unable to find lookup table: jr://fixture/item-list:Admin1

Admin1 is the question id

the Instance URI : jr://fixture/item-list:State

I tried the following solutions:

  • login as one of the mobile workers
  • make the table visible to all users
  • sync data

it’s weird because this same table works in a different App and we have mirror the settings for both

your help is much appreciated

Regards

Hi Maria,

If Admin1 is your question ID and you are seeing the error

Unable to find lookup table: jr://fixture/item-list:Admin1

That strongly implies something is misconfigured with the Question’s Lookup Table data source, as that message implies that the form is looking for a lookup table with the ID ‘Admin1’, so I wonder whether something didn’t get entered into the wrong field accidentally.

It’s hard to know more without more context on your form configuration, but my first instinct would be to recreate the lookup table from scratch to make sure it’s set up as you are expecting.

-Clayton

Hi, I have the same problem with the lookup table.
Unable to find lookup table: jr://fixture/item-list:activity_detail

This happens when I increase the number of rows in the lookup table.
Is there a limit to number of rows for the lookup table ?

Thank you

Hi there
Im still trying to troubleshoot it
its weird because this error message is popping to my colleagues in the field but not to me, even after reviewing user’s access ,mirror profiles and reconfiguring tables …
Good luck with that

It’s unlikely that this is related to the number of rows in the lookup table. The error means that the lookup table isn’t available on the user’s device. Broadly speaking there are two possible causes of this:

  1. The name of the lookup table is incorrect. I’d be sure to follow the instructions on the wiki in setting up the questions, and be certain the name matches the lookup table ID exactly.
    https://confluence.dimagi.com/display/commcarepublic/Setup+a+Question+with+Filtered+Choices

  2. The lookup table isn’t being sent to the user’s device. This could happen because the table isn’t configured as “visible to all users”, or if you’re using multiple project spaces, perhaps the lookup table isn’t set up on all spaces.

The OTA Restore API is a very technical tool that could be useful to determine which of these is the case. That will display the raw data that gets sent to the users’ devices. You can check for the lookup table there - it should appear up something like:

  <fixture id="item-list:district" user_id="abc123">
    <district_list>
      ...
    </district_list>
  </fixture>

Thank you Ethan! Appreciated

I am not sure what solved one of my errorrs but after going to the android tablet screen and going in the settings , I cleared the user data and it worked for me.
May be there was something else that I did too, but this helped me.
Yeah Also Since last time, I removed a large lookup table also.

1 Like