Error Building commcare-odk?

Hi:

Trying to run commcare-odk from source so I can work on a
biometric authentication feature.

Followed to the letter all steps in commcare-odk/README.md

But I get the following message when I tried to compile:

Error:Configuration with name ‘default’ not found.

Attaching screenshot of the Error Show in my Android Studio

Any suggestions ?

     Thanks.

                     Daniel

Hello,

Did you add the project to Android Studio via the Import Project option? If
not you may be running into this issue
http://stackoverflow.com/questions/23527091/module-is-not-backed-by-gradle
.

If that doesn’t help, it would be helpful to post the IDE output log under
Help -> Show Log.

Best,
Will

··· On Fri, Sep 25, 2015 at 1:51 PM, Daniel Kornhauser wrote:

Hi:

Trying to run commcare-odk from source so I can work on a
biometric authentication feature.

Followed to the letter all steps in commcare-odk/README.md

But I get the following message when I tried to compile:

Error:Configuration with name ‘default’ not found.

Attaching screenshot of the Error Show in my Android Studio

Any suggestions ?

     Thanks.

                     Daniel


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks William !

Attaching my log and a screenshot of my SDK manager.

Looked again the stack overflow link you sent but did not find any useful
suggestions.

I imported it via Import Project option as stated in the bullet points of
Readme.md:

  • From the Android Studio Welcome dashboard, click “Import project
    (Eclipse ADT, Gradle, etc.)”
  • Select AndroidStudioProjects > CommCareODK > commcare-odk and hit OK
  • Click “Cancel” on the Gradle Sync modal (this just declines Android
    Studio’s overzealous offer to do some automatic stuff we don’t want)
  • Click “Cancel” on the Import Gradle Project popup (also just declining
    something automatic that we don’t want)
Any other suggestion ?

       Daniel

idea.log (72 KB)

··· On Fri, Sep 25, 2015 at 2:06 PM, William Pride wrote:

Hello,

Did you add the project to Android Studio via the Import Project option?
If not you may be running into this issue
http://stackoverflow.com/questions/23527091/module-is-not-backed-by-gradle
.

If that doesn’t help, it would be helpful to post the IDE output log under
Help -> Show Log.

Best,
Will

On Fri, Sep 25, 2015 at 1:51 PM, Daniel Kornhauser danielke@gmail.com wrote:

Hi:

Trying to run commcare-odk from source so I can work on a
biometric authentication feature.

Followed to the letter all steps in commcare-odk/README.md

But I get the following message when I tried to compile:

Error:Configuration with name ‘default’ not found.

Attaching screenshot of the Error Show in my Android Studio

Any suggestions ?

     Thanks.

                     Daniel


You received this message because you are subscribed to the Google Groups
“CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “CommCare Developers” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-developers/EXSMXw_Mk-w/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hey Daniel,

Looking at the top of your log it looks like the gradle import is failing:

Failed to import Gradle project at
’/Users/dkor/AndroidStudioProjects/CommCareODK/commcare-odk’

So I’m guessing that Android Studio is just importing the files but not
setting up the Gradle project. Not sure but I think the issue is that
you’re running Gradle 2.2:

Could not run build action using Gradle distribution ‘
https://services.gradle.org/distributions/gradle-2.2-bin.zip’.

And I believe we require Gradle 2.4. I’d recommend upgrading your Gradle
version, then trying the setup (including project import) from scratch.
I’ll update the Readme to reflect this requirement.

Best,
Will

··· On Fri, Sep 25, 2015 at 2:34 PM, Daniel Kornhauser wrote:

Thanks William !

Attaching my log and a screenshot of my SDK manager.

Looked again the stack overflow link you sent but did not find any useful
suggestions.

I imported it via Import Project option as stated in the bullet points of
Readme.md:

  • From the Android Studio Welcome dashboard, click “Import project
    (Eclipse ADT, Gradle, etc.)”
  • Select AndroidStudioProjects > CommCareODK > commcare-odk and hit OK
  • Click “Cancel” on the Gradle Sync modal (this just declines Android
    Studio’s overzealous offer to do some automatic stuff we don’t want)
  • Click “Cancel” on the Import Gradle Project popup (also just
    declining something automatic that we don’t want)
Any other suggestion ?

       Daniel

On Fri, Sep 25, 2015 at 2:06 PM, William Pride wpride@dimagi.com wrote:

Hello,

Did you add the project to Android Studio via the Import Project option?
If not you may be running into this issue
http://stackoverflow.com/questions/23527091/module-is-not-backed-by-gradle
.

If that doesn’t help, it would be helpful to post the IDE output log
under Help -> Show Log.

Best,
Will

On Fri, Sep 25, 2015 at 1:51 PM, Daniel Kornhauser danielke@gmail.com wrote:

Hi:

Trying to run commcare-odk from source so I can work on a
biometric authentication feature.

Followed to the letter all steps in commcare-odk/README.md

But I get the following message when I tried to compile:

Error:Configuration with name ‘default’ not found.

Attaching screenshot of the Error Show in my Android Studio

Any suggestions ?

     Thanks.

                     Daniel


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “CommCare Developers” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-developers/EXSMXw_Mk-w/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi William

Switched Gradle Home to 2.4. still not building with same error.
Tried it to build it in a linux VM and also got same error.
Attached clean log.

Daniel

idea.log (72.3 KB)

··· On Fri, Sep 25, 2015 at 3:21 PM, William Pride wrote:

Hey Daniel,

Looking at the top of your log it looks like the gradle import is failing:

Failed to import Gradle project at
‘/Users/dkor/AndroidStudioProjects/CommCareODK/commcare-odk’

So I’m guessing that Android Studio is just importing the files but not
setting up the Gradle project. Not sure but I think the issue is that
you’re running Gradle 2.2:

Could not run build action using Gradle distribution ’
https://services.gradle.org/distributions/gradle-2.2-bin.zip’.

And I believe we require Gradle 2.4. I’d recommend upgrading your Gradle
version, then trying the setup (including project import) from scratch.
I’ll update the Readme to reflect this requirement.

Best,
Will

On Fri, Sep 25, 2015 at 2:34 PM, Daniel Kornhauser danielke@gmail.com wrote:

Thanks William !

Attaching my log and a screenshot of my SDK manager.

Looked again the stack overflow link you sent but did not find any useful
suggestions.

I imported it via Import Project option as stated in the bullet points of
Readme.md:

  • From the Android Studio Welcome dashboard, click “Import project
    (Eclipse ADT, Gradle, etc.)”
  • Select AndroidStudioProjects > CommCareODK > commcare-odk and hit OK
  • Click “Cancel” on the Gradle Sync modal (this just declines Android
    Studio’s overzealous offer to do some automatic stuff we don’t want)
  • Click “Cancel” on the Import Gradle Project popup (also just
    declining something automatic that we don’t want)
Any other suggestion ?

       Daniel

On Fri, Sep 25, 2015 at 2:06 PM, William Pride wpride@dimagi.com wrote:

Hello,

Did you add the project to Android Studio via the Import Project option?
If not you may be running into this issue
http://stackoverflow.com/questions/23527091/module-is-not-backed-by-gradle
.

If that doesn’t help, it would be helpful to post the IDE output log
under Help -> Show Log.

Best,
Will

On Fri, Sep 25, 2015 at 1:51 PM, Daniel Kornhauser danielke@gmail.com wrote:

Hi:

Trying to run commcare-odk from source so I can work on a
biometric authentication feature.

Followed to the letter all steps in commcare-odk/README.md

But I get the following message when I tried to compile:

Error:Configuration with name ‘default’ not found.

Attaching screenshot of the Error Show in my Android Studio

Any suggestions ?

     Thanks.

                     Daniel


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “CommCare Developers” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-developers/EXSMXw_Mk-w/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
“CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

We’ve taken this discussion off-thread, will post the fix when we’ve
figured it out.

··· On Fri, Sep 25, 2015 at 4:29 PM, Daniel Kornhauser wrote:

Hi William

Switched Gradle Home to 2.4. still not building with same error.
Tried it to build it in a linux VM and also got same error.
Attached clean log.

Daniel

On Fri, Sep 25, 2015 at 3:21 PM, William Pride wpride@dimagi.com wrote:

Hey Daniel,

Looking at the top of your log it looks like the gradle import is failing:

Failed to import Gradle project at
’/Users/dkor/AndroidStudioProjects/CommCareODK/commcare-odk’

So I’m guessing that Android Studio is just importing the files but not
setting up the Gradle project. Not sure but I think the issue is that
you’re running Gradle 2.2:

Could not run build action using Gradle distribution ‘
https://services.gradle.org/distributions/gradle-2.2-bin.zip’.

And I believe we require Gradle 2.4. I’d recommend upgrading your Gradle
version, then trying the setup (including project import) from scratch.
I’ll update the Readme to reflect this requirement.

Best,
Will

On Fri, Sep 25, 2015 at 2:34 PM, Daniel Kornhauser danielke@gmail.com wrote:

Thanks William !

Attaching my log and a screenshot of my SDK manager.

Looked again the stack overflow link you sent but did not find any
useful suggestions.

I imported it via Import Project option as stated in the bullet points
of Readme.md:

  • From the Android Studio Welcome dashboard, click “Import project
    (Eclipse ADT, Gradle, etc.)”
  • Select AndroidStudioProjects > CommCareODK > commcare-odk and hit
    OK
  • Click “Cancel” on the Gradle Sync modal (this just declines
    Android Studio’s overzealous offer to do some automatic stuff we don’t want)
  • Click “Cancel” on the Import Gradle Project popup (also just
    declining something automatic that we don’t want)
Any other suggestion ?

       Daniel

On Fri, Sep 25, 2015 at 2:06 PM, William Pride wpride@dimagi.com wrote:

Hello,

Did you add the project to Android Studio via the Import Project
option? If not you may be running into this issue
http://stackoverflow.com/questions/23527091/module-is-not-backed-by-gradle
.

If that doesn’t help, it would be helpful to post the IDE output log
under Help -> Show Log.

Best,
Will

On Fri, Sep 25, 2015 at 1:51 PM, Daniel Kornhauser danielke@gmail.com wrote:

Hi:

Trying to run commcare-odk from source so I can work on a
biometric authentication feature.

Followed to the letter all steps in commcare-odk/README.md

But I get the following message when I tried to compile:

Error:Configuration with name ‘default’ not found.

Attaching screenshot of the Error Show in my Android Studio

Any suggestions ?

     Thanks.

                     Daniel


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “CommCare Developers” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-developers/EXSMXw_Mk-w/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.