Environment to use instead of monolithic

Hello:

I have been 6 days trying to install CommCare Cloud and HQ on single machine, but I came to the conclusion that the monolith environment from dimagi/sample-environment is outdated. The problem is that using any version of python results in a compatibility error
(probably by mixing python 2 and python 3)

My question is: Which environment should I use in order to have a monolithic installation of CommcareCLoud and HQ?