Dodoma Form Submission Problem

Forwarding this along to commcare-users.

Nick P. Amland

CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com namland08@gmail.com

··· ---------- Forwarded message ---------- From: Nick Amland Date: Fri, Apr 1, 2011 at 6:44 PM Subject: Dodoma Form Submission Problem To: Daniel Roberts , Clayton Sims , Amelia Sagoff

Hey,

I’ve known that we’ve had problems with form submissions into HQ from a
disparity between the number of forms shown in the "form submission report"
and CHV report.

Previously, I heard that we thought this might be related to incorrect date
and time on the phone. So, last week, I checked the date/time on all CHV
phones. Many of the CHVs had the correct date/time (although incorrect
timezone, but I don’t think that affects anything really), and I changed the
date/time for incorrect phones.

This week we are still had CHVs come in and complain about the number of
forms shown in the form submission report. Not all CHVs seem to have
problems though.

This week I didn’t take very good notes, but I’ll be better prepared next
week to record specific CHV complaints.

Wanted to bring this to your attention though as we really need to make sure
we’re not loosing data.

Thanks,
Nick

Nick P. Amland

CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com namland08@gmail.com

Hi Nick,

There is a bug with the version of CommCare you’re currently using
where if the CHV hits the red button while it’s “sending” initially
(but hasn’t actually been received), the phone can erroneously think
the form was sent and we lose data. This has been fixed with the
latest CommCare build (or will be released shortly).

Brian

··· On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland wrote: > Forwarding this along to commcare-users. > Nick P. Amland > CommCare Field Fellow > Dimagi, Inc. > Dodoma, Tanzania > Google Voice: 253.642.7790 > TZ Mobile: +255 762 740 996 > Email: namland@dimagi.com > > > ---------- Forwarded message ---------- > From: Nick Amland > Date: Fri, Apr 1, 2011 at 6:44 PM > Subject: Dodoma Form Submission Problem > To: Daniel Roberts , Clayton Sims , > Amelia Sagoff > > > Hey, > I've known that we've had problems with form submissions into HQ from a > disparity between the number of forms shown in the "form submission report" > and CHV report. > Previously, I heard that we thought this might be related to incorrect date > and time on the phone. So, last week, I checked the date/time on all CHV > phones. Many of the CHVs had the correct date/time (although incorrect > timezone, but I don't think that affects anything really), and I changed the > date/time for incorrect phones. > This week we are still had CHVs come in and complain about the number of > forms shown in the form submission report. Not all CHVs seem to have > problems though. > This week I didn't take very good notes, but I'll be better prepared next > week to record specific CHV complaints. > Wanted to bring this to your attention though as we really need to make sure > we're not loosing data. > Thanks, > Nick > Nick P. Amland > CommCare Field Fellow > Dimagi, Inc. > Dodoma, Tanzania > Google Voice: 253.642.7790 > TZ Mobile: +255 762 740 996 > Email: namland@dimagi.com > >

Oh, interesting. This seems potentially pretty likely to happen
particularly when it can take a while for the upload process to timeout if
the network is down, they don’t have credit, server is temporarily down
(like during migration)…even though there is a “Okay” button available.

Another reason, why upgrading to 1.1 mobile client is a priority.

Thanks,
Nick

Nick P. Amland

CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com namland08@gmail.com

··· On Sat, Apr 2, 2011 at 12:05 PM, Brian DeRenzi wrote:

Hi Nick,

There is a bug with the version of CommCare you’re currently using
where if the CHV hits the red button while it’s “sending” initially
(but hasn’t actually been received), the phone can erroneously think
the form was sent and we lose data. This has been fixed with the
latest CommCare build (or will be released shortly).

Brian

On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland namland@dimagi.com wrote:

Forwarding this along to commcare-users.
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com

---------- Forwarded message ----------
From: Nick Amland namland@dimagi.com
Date: Fri, Apr 1, 2011 at 6:44 PM
Subject: Dodoma Form Submission Problem
To: Daniel Roberts droberts@dimagi.com, Clayton Sims <csims@dimagi.com
,
Amelia Sagoff asagoff@dimagi.com

Hey,
I’ve known that we’ve had problems with form submissions into HQ from a
disparity between the number of forms shown in the "form submission
report"
and CHV report.
Previously, I heard that we thought this might be related to incorrect
date
and time on the phone. So, last week, I checked the date/time on all CHV
phones. Many of the CHVs had the correct date/time (although incorrect
timezone, but I don’t think that affects anything really), and I changed
the
date/time for incorrect phones.
This week we are still had CHVs come in and complain about the number of
forms shown in the form submission report. Not all CHVs seem to have
problems though.
This week I didn’t take very good notes, but I’ll be better prepared next
week to record specific CHV complaints.
Wanted to bring this to your attention though as we really need to make
sure
we’re not loosing data.
Thanks,
Nick
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com

Brian,

If this is the PF problem, this isn’t quite accurate as a description.

The PF problem occurred when the user hit the red button and closed CommCare
before choosing either “Send Now” or “Send Later”. If either were chosen at
any point, the form record should have been saved.

-Clayton

··· On Sat, Apr 2, 2011 at 5:05 AM, Brian DeRenzi wrote:

Hi Nick,

There is a bug with the version of CommCare you’re currently using
where if the CHV hits the red button while it’s “sending” initially
(but hasn’t actually been received), the phone can erroneously think
the form was sent and we lose data. This has been fixed with the
latest CommCare build (or will be released shortly).

Brian

On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland namland@dimagi.com wrote:

Forwarding this along to commcare-users.
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com

---------- Forwarded message ----------
From: Nick Amland namland@dimagi.com
Date: Fri, Apr 1, 2011 at 6:44 PM
Subject: Dodoma Form Submission Problem
To: Daniel Roberts droberts@dimagi.com, Clayton Sims <csims@dimagi.com
,
Amelia Sagoff asagoff@dimagi.com

Hey,
I’ve known that we’ve had problems with form submissions into HQ from a
disparity between the number of forms shown in the "form submission
report"
and CHV report.
Previously, I heard that we thought this might be related to incorrect
date
and time on the phone. So, last week, I checked the date/time on all CHV
phones. Many of the CHVs had the correct date/time (although incorrect
timezone, but I don’t think that affects anything really), and I changed
the
date/time for incorrect phones.
This week we are still had CHVs come in and complain about the number of
forms shown in the form submission report. Not all CHVs seem to have
problems though.
This week I didn’t take very good notes, but I’ll be better prepared next
week to record specific CHV complaints.
Wanted to bring this to your attention though as we really need to make
sure
we’re not loosing data.
Thanks,
Nick
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com

Hi Nick and Brian

That is such a good finding, how did you know the users are losing data
during submission? Do you have a form that CHW fill every time they submit a
form and then add it up to know the number of forms submitted?

Or do you just check on the review forms on the application and count how
many forms have been submitted then compare with what reached to the
server?

I think knowing the method might be a good lesson to many of us. I’m
wondering if there is another method out there rather than asking the end
users if they remember how many forms did he/she submit because most users
will just give an estimate number which may not give the facts.

Gayo

··· From: commcare-users@googlegroups.com [mailto:commcare-users@googlegroups.com] On Behalf Of Nick Amland Sent: Sunday, April 03, 2011 1:38 PM To: commcare-users Cc: Brian DeRenzi; Daniel Roberts; Clayton Sims; Amelia Sagoff Subject: Re: Dodoma Form Submission Problem

Oh, interesting. This seems potentially pretty likely to happen
particularly when it can take a while for the upload process to timeout if
the network is down, they don’t have credit, server is temporarily down
(like during migration)…even though there is a “Okay” button available.

Another reason, why upgrading to 1.1 mobile client is a priority.

Thanks,

Nick

Nick P. Amland

CommCare Field Fellow

Dimagi, Inc.

Dodoma, Tanzania

Google Voice: 253.642.7790

TZ Mobile: +255 762 740 996
Email: namland@dimagi.com mailto:namland08@gmail.com

On Sat, Apr 2, 2011 at 12:05 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Hi Nick,

There is a bug with the version of CommCare you’re currently using
where if the CHV hits the red button while it’s “sending” initially
(but hasn’t actually been received), the phone can erroneously think
the form was sent and we lose data. This has been fixed with the
latest CommCare build (or will be released shortly).

Brian

On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland namland@dimagi.com wrote:

Forwarding this along to commcare-users.
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996 tel:%2B255%20762%20740%20996
Email: namland@dimagi.com

---------- Forwarded message ----------
From: Nick Amland namland@dimagi.com
Date: Fri, Apr 1, 2011 at 6:44 PM
Subject: Dodoma Form Submission Problem
To: Daniel Roberts droberts@dimagi.com, Clayton Sims csims@dimagi.com,
Amelia Sagoff asagoff@dimagi.com

Hey,
I’ve known that we’ve had problems with form submissions into HQ from a
disparity between the number of forms shown in the "form submission
report"
and CHV report.
Previously, I heard that we thought this might be related to incorrect
date
and time on the phone. So, last week, I checked the date/time on all CHV
phones. Many of the CHVs had the correct date/time (although incorrect
timezone, but I don’t think that affects anything really), and I changed
the
date/time for incorrect phones.
This week we are still had CHVs come in and complain about the number of
forms shown in the form submission report. Not all CHVs seem to have
problems though.
This week I didn’t take very good notes, but I’ll be better prepared next
week to record specific CHV complaints.
Wanted to bring this to your attention though as we really need to make
sure
we’re not loosing data.
Thanks,
Nick
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996 tel:%2B255%20762%20740%20996
Email: namland@dimagi.com

Thanks for the clarification Clayton! And, great to know that the
problem is much smaller than I thought.

Brian

··· On Mon, Apr 4, 2011 at 8:03 AM, Clayton Sims wrote: > Brian, > If this is the PF problem, this isn't quite accurate as a description. > The PF problem occurred when the user hit the red button and closed CommCare > before choosing either "Send Now" or "Send Later". If either were chosen at > any point, the form record should have been saved. > -Clayton > > On Sat, Apr 2, 2011 at 5:05 AM, Brian DeRenzi wrote: >> >> Hi Nick, >> >> There is a bug with the version of CommCare you're currently using >> where if the CHV hits the red button while it's "sending" initially >> (but hasn't actually been received), the phone can erroneously think >> the form was sent and we lose data. This has been fixed with the >> latest CommCare build (or will be released shortly). >> >> Brian >> >> >> On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland wrote: >> > Forwarding this along to commcare-users. >> > Nick P. Amland >> > CommCare Field Fellow >> > Dimagi, Inc. >> > Dodoma, Tanzania >> > Google Voice: 253.642.7790 >> > TZ Mobile: +255 762 740 996 >> > Email: namland@dimagi.com >> > >> > >> > ---------- Forwarded message ---------- >> > From: Nick Amland >> > Date: Fri, Apr 1, 2011 at 6:44 PM >> > Subject: Dodoma Form Submission Problem >> > To: Daniel Roberts , Clayton Sims >> > , >> > Amelia Sagoff >> > >> > >> > Hey, >> > I've known that we've had problems with form submissions into HQ from a >> > disparity between the number of forms shown in the "form submission >> > report" >> > and CHV report. >> > Previously, I heard that we thought this might be related to incorrect >> > date >> > and time on the phone. So, last week, I checked the date/time on all >> > CHV >> > phones. Many of the CHVs had the correct date/time (although incorrect >> > timezone, but I don't think that affects anything really), and I changed >> > the >> > date/time for incorrect phones. >> > This week we are still had CHVs come in and complain about the number of >> > forms shown in the form submission report. Not all CHVs seem to have >> > problems though. >> > This week I didn't take very good notes, but I'll be better prepared >> > next >> > week to record specific CHV complaints. >> > Wanted to bring this to your attention though as we really need to make >> > sure >> > we're not loosing data. >> > Thanks, >> > Nick >> > Nick P. Amland >> > CommCare Field Fellow >> > Dimagi, Inc. >> > Dodoma, Tanzania >> > Google Voice: 253.642.7790 >> > TZ Mobile: +255 762 740 996 >> > Email: namland@dimagi.com >> > >> > > >

Hey Gayo,

You make a good point here in that CHV reports of how many forms they filled
out is not necessarily a number that is reliable nor factual.

However, in our case, this is currently what we’ve been using. But, we’re
trying to rely a little less on that assumption.

For instance, we’ve identified some instances when a CHV has reported that
they have submitted 15 forms (for instance). Then, we looked in our form
submission report and found that CHV was showing 0 forms submitted. Even
though the 15 forms may not be completely correct, we’re assuming the CHV
submitted more than 0 forms.

Less reliable but still interesting is that we’ve also verified gross
differences (more than 20 to 30 forms difference) in number forms a CHV
reports to have submitted and the number that showed up in the form
submission report.

After we upgrade to the new mobile client, we’re hoping that this will
eliminate some variables from this problem. This may help us narrow down a
possible cause. When we begin to pick up this process again, I’ll be sure
to include the CCusers email list so you can follow.

More on this soon.

Thanks,
Nick

Nick P. Amland

CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
Email: namland@dimagi.com namland08@gmail.com

··· On Mon, Apr 4, 2011 at 1:30 PM, gayo wrote:

Hi Nick and Brian

That is such a good finding, how did you know the users are losing data
during submission? Do you have a form that CHW fill every time they submit a
form and then add it up to know the number of forms submitted?

Or do you just check on the review forms on the application and count how
many forms have been submitted then compare with what reached to the
server?

I think knowing the method might be a good lesson to many of us. I’m
wondering if there is another method out there rather than asking the end
users if they remember how many forms did he/she submit because most users
will just give an estimate number which may not give the facts.

Gayo

From: commcare-users@googlegroups.com [mailto:
commcare-users@googlegroups.com] *On Behalf Of *Nick Amland
Sent: Sunday, April 03, 2011 1:38 PM
To: commcare-users
Cc: Brian DeRenzi; Daniel Roberts; Clayton Sims; Amelia Sagoff
Subject: Re: Dodoma Form Submission Problem

Oh, interesting. This seems potentially pretty likely to happen
particularly when it can take a while for the upload process to timeout if
the network is down, they don’t have credit, server is temporarily down
(like during migration)…even though there is a “Okay” button available.

Another reason, why upgrading to 1.1 mobile client is a priority.

Thanks,

Nick

Nick P. Amland

CommCare Field Fellow

Dimagi, Inc.

Dodoma, Tanzania

Google Voice: 253.642.7790

TZ Mobile: +255 762 740 996
Email: namland@dimagi.com namland08@gmail.com

On Sat, Apr 2, 2011 at 12:05 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Hi Nick,

There is a bug with the version of CommCare you’re currently using
where if the CHV hits the red button while it’s “sending” initially
(but hasn’t actually been received), the phone can erroneously think
the form was sent and we lose data. This has been fixed with the
latest CommCare build (or will be released shortly).

Brian

On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland namland@dimagi.com wrote:

Forwarding this along to commcare-users.
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com

---------- Forwarded message ----------
From: Nick Amland namland@dimagi.com
Date: Fri, Apr 1, 2011 at 6:44 PM
Subject: Dodoma Form Submission Problem
To: Daniel Roberts droberts@dimagi.com, Clayton Sims <csims@dimagi.com
,
Amelia Sagoff asagoff@dimagi.com

Hey,
I’ve known that we’ve had problems with form submissions into HQ from a
disparity between the number of forms shown in the "form submission
report"
and CHV report.
Previously, I heard that we thought this might be related to incorrect
date
and time on the phone. So, last week, I checked the date/time on all CHV
phones. Many of the CHVs had the correct date/time (although incorrect
timezone, but I don’t think that affects anything really), and I changed
the
date/time for incorrect phones.
This week we are still had CHVs come in and complain about the number of
forms shown in the form submission report. Not all CHVs seem to have
problems though.
This week I didn’t take very good notes, but I’ll be better prepared next
week to record specific CHV complaints.
Wanted to bring this to your attention though as we really need to make
sure
we’re not loosing data.
Thanks,
Nick
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996
Email: namland@dimagi.com

Hi Nick

Your explanation on this email is very helpful. Thanks,

G

··· From: Nick Amland [mailto:namland@dimagi.com] Sent: Monday, April 04, 2011 4:36 PM To: commcare-users Cc: gayo; Brian DeRenzi; Daniel Roberts; Clayton Sims; Amelia Sagoff; Jonathan Payne Subject: Re: Dodoma Form Submission Problem

Hey Gayo,

You make a good point here in that CHV reports of how many forms they filled
out is not necessarily a number that is reliable nor factual.

However, in our case, this is currently what we’ve been using. But, we’re
trying to rely a little less on that assumption.

For instance, we’ve identified some instances when a CHV has reported that
they have submitted 15 forms (for instance). Then, we looked in our form
submission report and found that CHV was showing 0 forms submitted. Even
though the 15 forms may not be completely correct, we’re assuming the CHV
submitted more than 0 forms.

Less reliable but still interesting is that we’ve also verified gross
differences (more than 20 to 30 forms difference) in number forms a CHV
reports to have submitted and the number that showed up in the form
submission report.

After we upgrade to the new mobile client, we’re hoping that this will
eliminate some variables from this problem. This may help us narrow down a
possible cause. When we begin to pick up this process again, I’ll be sure
to include the CCusers email list so you can follow.

More on this soon.

Thanks,

Nick

Nick P. Amland

CommCare Field Fellow

Dimagi, Inc.

Dodoma, Tanzania

Google Voice: 253.642.7790
Email: namland@dimagi.com mailto:namland08@gmail.com

On Mon, Apr 4, 2011 at 1:30 PM, gayo gayomhila@gmail.com wrote:

Hi Nick and Brian

That is such a good finding, how did you know the users are losing data
during submission? Do you have a form that CHW fill every time they submit a
form and then add it up to know the number of forms submitted?

Or do you just check on the review forms on the application and count how
many forms have been submitted then compare with what reached to the
server?

I think knowing the method might be a good lesson to many of us. I’m
wondering if there is another method out there rather than asking the end
users if they remember how many forms did he/she submit because most users
will just give an estimate number which may not give the facts.

Gayo

From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Nick Amland
Sent: Sunday, April 03, 2011 1:38 PM
To: commcare-users
Cc: Brian DeRenzi; Daniel Roberts; Clayton Sims; Amelia Sagoff
Subject: Re: Dodoma Form Submission Problem

Oh, interesting. This seems potentially pretty likely to happen
particularly when it can take a while for the upload process to timeout if
the network is down, they don’t have credit, server is temporarily down
(like during migration)…even though there is a “Okay” button available.

Another reason, why upgrading to 1.1 mobile client is a priority.

Thanks,

Nick

Nick P. Amland

CommCare Field Fellow

Dimagi, Inc.

Dodoma, Tanzania

Google Voice: 253.642.7790

TZ Mobile: +255 762 740 996 tel:%2B255%20762%20740%20996
Email: namland@dimagi.com mailto:namland08@gmail.com

On Sat, Apr 2, 2011 at 12:05 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Hi Nick,

There is a bug with the version of CommCare you’re currently using
where if the CHV hits the red button while it’s “sending” initially
(but hasn’t actually been received), the phone can erroneously think
the form was sent and we lose data. This has been fixed with the
latest CommCare build (or will be released shortly).

Brian

On Fri, Apr 1, 2011 at 8:51 AM, Nick Amland namland@dimagi.com wrote:

Forwarding this along to commcare-users.
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996 tel:%2B255%20762%20740%20996
Email: namland@dimagi.com

---------- Forwarded message ----------
From: Nick Amland namland@dimagi.com
Date: Fri, Apr 1, 2011 at 6:44 PM
Subject: Dodoma Form Submission Problem
To: Daniel Roberts droberts@dimagi.com, Clayton Sims csims@dimagi.com,
Amelia Sagoff asagoff@dimagi.com

Hey,
I’ve known that we’ve had problems with form submissions into HQ from a
disparity between the number of forms shown in the "form submission
report"
and CHV report.
Previously, I heard that we thought this might be related to incorrect
date
and time on the phone. So, last week, I checked the date/time on all CHV
phones. Many of the CHVs had the correct date/time (although incorrect
timezone, but I don’t think that affects anything really), and I changed
the
date/time for incorrect phones.
This week we are still had CHVs come in and complain about the number of
forms shown in the form submission report. Not all CHVs seem to have
problems though.
This week I didn’t take very good notes, but I’ll be better prepared next
week to record specific CHV complaints.
Wanted to bring this to your attention though as we really need to make
sure
we’re not loosing data.
Thanks,
Nick
Nick P. Amland
CommCare Field Fellow
Dimagi, Inc.
Dodoma, Tanzania
Google Voice: 253.642.7790
TZ Mobile: +255 762 740 996 tel:%2B255%20762%20740%20996
Email: namland@dimagi.com