Deploy error on CommCareHQ

Hi,

We have been creating a local instance of CommcareHq for testing.

We have two issues.

Within App settings we only have CommCare 2.0 (unstable) as the CommCare
version. How do we ensure we are up to the latest version within this
interface?

The above could be related to

When we go to deploy we get this error.

AttributeError at
/a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/

‘str’ object has no attribute ‘items’

Request Method:GETRequest URL:
http://dev.akmn.co.uk:8001/a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/?edit=trueDjango
Version:1.5.5Exception Type:AttributeErrorException Value:

‘str’ object has no attribute ‘items’

Exception Location:/home/cchq/www/myserver/code_root/corehq/apps/app_manager/templatetags/xforms_extras.py
in trans, line 29Python Executable:
/home/cchq/www/myserver/python_env/bin/pythonPython Version:2.7.3

Error during template rendering

In template
/home/cchq/www/myserver/code_root/corehq/apps/app_manager/templates/app_manager/managed_app.html,
error at line 7

{% load i18n %} 6 7{% block title %}{{ module.name|html_trans:langs }}{%
endblock %} 8 9 10{% block head %}{{ block.super }}

We think we have followed the instructions correctly, but may have missed
something.

Best

Tim

Hi Tim

To add new versions you need to follow the instructions here:

Regarding the error message, ‘module.name’ should be a dict. You should
check to make sure you’re running the latest version of the code. You can
also look at the application document in CouchDB to see what it looks like.
You can get the doc id from the URL.

Simon

··· On 28 March 2014 11:25, Tim Butler wrote:

Hi,

We have been creating a local instance of CommcareHq for testing.

We have two issues.

Within App settings we only have CommCare 2.0 (unstable) as the CommCare
version. How do we ensure we are up to the latest version within this
interface?

The above could be related to

When we go to deploy we get this error.

AttributeError at
/a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/

‘str’ object has no attribute ‘items’

Request Method:GET Request URL:
http://dev.akmn.co.uk:8001/a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/?edit=true Django
Version:1.5.5 Exception Type:AttributeErrorException Value:

‘str’ object has no attribute ‘items’

Exception Location:/home/cchq/www/myserver/code_root/corehq/apps/app_manager/templatetags/xforms_extras.py
in trans, line 29 Python Executable:
/home/cchq/www/myserver/python_env/bin/python Python Version:2.7.3

Error during template rendering

In template
/home/cchq/www/myserver/code_root/corehq/apps/app_manager/templates/app_manager/managed_app.html,
error at line 7

{% load i18n %} 6 7 {% block title %}{{ module.name|html_trans:langs }}{%
endblock %} 8 9 10 {% block head %}{{ block.super }}

We think we have followed the instructions correctly, but may have missed
something.

Best

Tim


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Hi Simon,

Thanks for this.

  1. Was a joy. :slight_smile:
  2. We had missed adding hotfixes, this has now been done. Deploy takes us
    to the correct page.

When we try and deploy we get Whoops, that didn't go through. Reload the
page and click Make New Version to try again.

We have a simple module and form with no Case. We will look at the logs
later, is there any likely candidates for this error?

Best

Tim

··· On Friday, 28 March 2014 09:51:58 UTC, skelly wrote: > > Hi Tim > > To add new versions you need to follow the instructions here: > https://github.com/dimagi/commcare-hq/blob/master/corehq/apps/builds/README.md > > Regarding the error message, 'module.name' should be a dict. You should > check to make sure you're running the latest version of the code. You can > also look at the application document in CouchDB to see what it looks like. > You can get the doc id from the URL. > > Simon > > > On 28 March 2014 11:25, Tim Butler <tim.bu...@gmail.com >wrote: > >> Hi, >> >> We have been creating a local instance of CommcareHq for testing. >> >> We have two issues. >> >> Within App settings we only have CommCare 2.0 (unstable) as the CommCare >> version. How do we ensure we are up to the latest version within this >> interface? >> >> The above could be related to >> >> When we go to deploy we get this error. >> >> AttributeError at >> /a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/ >> >> 'str' object has no attribute 'items' >> >> Request Method:GET Request URL: >> http://dev.akmn.co.uk:8001/a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/?edit=true Django >> Version:1.5.5 Exception Type:AttributeErrorException Value: >> >> 'str' object has no attribute 'items' >> >> Exception Location:/home/cchq/www/myserver/code_root/corehq/apps/app_manager/templatetags/xforms_extras.py >> in trans, line 29 Python Executable: >> /home/cchq/www/myserver/python_env/bin/python Python Version:2.7.3 >> >> Error during template rendering >> >> In template >> /home/cchq/www/myserver/code_root/corehq/apps/app_manager/templates/app_manager/managed_app.html, >> error at line *7* >> >> >> {% load i18n %} 6 7 {% block title %}{{ module.name|html_trans:langs }}{% >> endblock %} 8 9 10 {% block head %}{{ block.super }} >> >> >> We think we have followed the instructions correctly, but may have missed >> something. >> >> >> Best >> >> >> Tim >> >> >> >> -- >> >> > > -- > Simon Kelly > Senior Engineer | Dimagi South Africa >

Hi Tim

The best thing to do is to check the logs and see what the exception was.
You can also use couchlog to see the errors:
http://dev.akmn.co.uk:8001/couchlog

··· On 28 March 2014 13:18, Tim Butler wrote:

Hi Simon,

Thanks for this.

  1. Was a joy. :slight_smile:
  2. We had missed adding hotfixes, this has now been done. Deploy takes us
    to the correct page.

When we try and deploy we get Whoops, that didn't go through. Reload the
page and click Make New Version to try again.

We have a simple module and form with no Case. We will look at the logs
later, is there any likely candidates for this error?

Best

Tim

On Friday, 28 March 2014 09:51:58 UTC, skelly wrote:

Hi Tim

To add new versions you need to follow the instructions here:
https://github.com/dimagi/commcare-hq/blob/master/corehq/apps/builds/
README.md

Regarding the error message, 'module.name' should be a dict. You should
check to make sure you're running the latest version of the code. You can
also look at the application document in CouchDB to see what it looks like.
You can get the doc id from the URL.

Simon

On 28 March 2014 11:25, Tim Butler tim.bu...@gmail.com wrote:

Hi,

We have been creating a local instance of CommcareHq for testing.

We have two issues.

Within App settings we only have CommCare 2.0 (unstable) as the CommCare
version. How do we ensure we are up to the latest version within this
interface?

The above could be related to

When we go to deploy we get this error.

AttributeError at /a/akeman/apps/view/2c18e50089f4dfb15095ae4831c578
c2/releases/

'str' object has no attribute 'items'

Request Method:GET Request URL:http://dev.akmn.co.uk:8001/a/
akeman/apps/view/2c18e50089f4dfb15095ae4831c578c2/releases/?edit=true Django
Version:1.5.5 Exception Type:AttributeErrorException Value:

'str' object has no attribute 'items'

Exception Location:/home/cchq/www/myserver/code_
root/corehq/apps/app_manager/templatetags/xforms_extras.py in trans,
line 29 Python Executable:/home/cchq/www/myserver/python_env/bin/pythonPython Version:
2.7.3

Error during template rendering

In template /home/cchq/www/myserver/code_root/corehq/
apps/app_manager/templates/app_manager/managed_app.html, error at line
7

{% load i18n %} 6 7 {% block title %}{{ module.name|html_trans:langs }}{%
endblock %} 8 9 10 {% block head %}{{ block.super }}

We think we have followed the instructions correctly, but may have
missed something.

Best

Tim

--

--
Simon Kelly
Senior Engineer | Dimagi South Africa

--


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Simon Kelly
Senior Engineer | Dimagi South Africa

Hi Simon,

Thanks for this.

We have now got it up and running.

Best

Tim

··· > >

Ok great.

··· On 28 March 2014 15:15, Tim Butler wrote:

Hi Simon,

Thanks for this.

We have now got it up and running.

Best

Tim


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Hi Tim

Please allow us to highjack your conversation as we are having a similar
issue
When we try and deploy we get Whoops, that didn’t go through. Reload the
page and click Make New Version to try again.
We have gone ahead and followed the instructions to add builds as found in


https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2Fdimagi%2Fcommcare-hq%2Fblob%2Fmaster%2Fcorehq%2Fapps%2Fbuilds%2FREADME.md&sa=D&sntz=1&usg=AFQjCNHcaAPy8GbTojhNeqcGE2_Oz8PR3Q

How did you resolve your issue?

Regards,

Kip

··· On Friday, 28 March 2014 16:15:41 UTC+3, Tim Butler wrote: > > Hi Simon, > > Thanks for this. > > We have now got it up and running. > > Best > > Tim >> >>

Did you see any errors in the logs?

··· On Sun, Aug 10, 2014 at 11:37 AM, Kiprotich Biwott < kiprotichbiwott@gmail.com> wrote:

Hi Tim

Please allow us to highjack your conversation as we are having a similar
issue
When we try and deploy we get Whoops, that didn’t go through. Reload the
page and click Make New Version to try again.
We have gone ahead and followed the instructions to add builds as found
in https://github.com/dimagi/commcare-hq/blob/master/corehq/apps/builds/
README.md
https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2Fdimagi%2Fcommcare-hq%2Fblob%2Fmaster%2Fcorehq%2Fapps%2Fbuilds%2FREADME.md&sa=D&sntz=1&usg=AFQjCNHcaAPy8GbTojhNeqcGE2_Oz8PR3Q

How did you resolve your issue?

Regards,

Kip

On Friday, 28 March 2014 16:15:41 UTC+3, Tim Butler wrote:

Hi Simon,

Thanks for this.

We have now got it up and running.

Best

Tim


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Cory,

Couch db log shows these two errors everytime we try to deploy

Keystore does not exist: /home/xxx/www/DimagiKeyStore
http://85.159.212.245/couchlog/ajax/single/93addbec62371ce1d3829a88aafd7f5b
Internal Server Error: /a/kps/apps/save/ea15e72e6cdfc42482acfb5a2db0a86b/
http://85.159.212.245/couchlog/ajax/single/66ad8fea894d0886bbf4cba281fd654ba00a1fbf

Regards,

Kip

··· On Monday, 11 August 2014 01:09:17 UTC+3, Cory Zue wrote: > > Did you see any errors in the logs? > > > On Sun, Aug 10, 2014 at 11:37 AM, Kiprotich Biwott <kiproti...@gmail.com > wrote: > >> Hi Tim >> >> Please allow us to highjack your conversation as we are having a similar >> issue >> When we try and deploy we get Whoops, that didn't go through. Reload the >> page and click Make New Version to try again. >> We have gone ahead and followed the instructions to add builds as found >> in https://github.com/dimagi/commcare-hq/blob/master/corehq/apps/builds/ >> README.md >> >> >> How did you resolve your issue? >> >> Regards, >> >> Kip >> >> >> On Friday, 28 March 2014 16:15:41 UTC+3, Tim Butler wrote: >>> >>> Hi Simon, >>> >>> Thanks for this. >>> >>> We have now got it up and running. >>> >>> Best >>> >>> Tim >>>> >>>> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

hey,

as described in the readme, unless you need to sign the applications you
can just comment out the JAR_SIGN config and it should work.

Cory

··· On Mon, Aug 11, 2014 at 12:16 AM, Kiprotich Biwott < kiprotichbiwott@gmail.com> wrote:

Hi Cory,

Couch db log shows these two errors everytime we try to deploy

Keystore does not exist: /home/xxx/www/DimagiKeyStore
http://85.159.212.245/couchlog/ajax/single/93addbec62371ce1d3829a88aafd7f5b
Internal Server Error: /a/kps/apps/save/ea15e72e6cdfc42482acfb5a2db0a86b/
http://85.159.212.245/couchlog/ajax/single/66ad8fea894d0886bbf4cba281fd654ba00a1fbf

Regards,

Kip

On Monday, 11 August 2014 01:09:17 UTC+3, Cory Zue wrote:

Did you see any errors in the logs?

On Sun, Aug 10, 2014 at 11:37 AM, Kiprotich Biwott kiproti...@gmail.com wrote:

Hi Tim

Please allow us to highjack your conversation as we are having a similar
issue
When we try and deploy we get Whoops, that didn’t go through. Reload
the page and click Make New Version to try again.
We have gone ahead and followed the instructions to add builds as found
in https://github.com/dimagi/commcare-hq/blob/master/
corehq/apps/builds/README.md
https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2Fdimagi%2Fcommcare-hq%2Fblob%2Fmaster%2Fcorehq%2Fapps%2Fbuilds%2FREADME.md&sa=D&sntz=1&usg=AFQjCNHcaAPy8GbTojhNeqcGE2_Oz8PR3Q

How did you resolve your issue?

Regards,

Kip

On Friday, 28 March 2014 16:15:41 UTC+3, Tim Butler wrote:

Hi Simon,

Thanks for this.

We have now got it up and running.

Best

Tim


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hey,

That has worked.

Thank you of the help.

Regards,
Kip

··· On Monday, 11 August 2014 15:30:39 UTC+3, Cory Zue wrote: > > hey, > > as described in the readme, unless you need to sign the applications you > can just comment out the JAR_SIGN config and it should work. > > > https://github.com/dimagi/commcare-hq/blob/master/corehq/apps/builds/README.md > > Cory > > > On Mon, Aug 11, 2014 at 12:16 AM, Kiprotich Biwott <kiproti...@gmail.com > wrote: > >> Hi Cory, >> >> Couch db log shows these two errors everytime we try to deploy >> >> Keystore does not exist: /home/xxx/www/DimagiKeyStore >> >> Internal Server Error: /a/kps/apps/save/ea15e72e6cdfc42482acfb5a2db0a86b/ >> >> >> Regards, >> >> Kip >> >> >> On Monday, 11 August 2014 01:09:17 UTC+3, Cory Zue wrote: >> >>> Did you see any errors in the logs? >>> >>> >>> On Sun, Aug 10, 2014 at 11:37 AM, Kiprotich Biwott >> >>>> Hi Tim >>>> >>>> Please allow us to highjack your conversation as we are having a >>>> similar issue >>>> When we try and deploy we get Whoops, that didn't go through. Reload >>>> the page and click Make New Version to try again. >>>> We have gone ahead and followed the instructions to add builds as found >>>> in https://github.com/dimagi/commcare-hq/blob/master/ >>>> corehq/apps/builds/README.md >>>> >>>> >>>> How did you resolve your issue? >>>> >>>> Regards, >>>> >>>> Kip >>>> >>>> >>>> On Friday, 28 March 2014 16:15:41 UTC+3, Tim Butler wrote: >>>>> >>>>> Hi Simon, >>>>> >>>>> Thanks for this. >>>>> >>>>> We have now got it up and running. >>>>> >>>>> Best >>>>> >>>>> Tim >>>>>> >>>>>> -- >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "CommCare Developers" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to commcare-developers+unsubscribe@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >