Default Language Issue

Hi,

I have build our forms in English and filled out the second language (nya)
in Chichewa for many, but not all questions. For my mobile users, I have
selected their default language as chichewa, and yet all the questions
appear in english on the phones…?

Is there some other setting that needs to be selected?

Thanks

Hi Marko,

What type of phone are you using? An Android or a Java-based phone?
Unfortunately that default language setting on a mobile worker doesn’t yet
affect the phone language (it is used for the website and reports).

Unfortunately you need to set the default language within the application,
not on the mobile worker. To do this, go to your app on CommCareHQ and
choose the Languages setting. Then drag and drop so that nya is at the top
of the list (making it the default). Then when you build the application,
nya will be the default.

You can also manually change the language for the application on the phone.

  1. On Java Phones, login as your admin user and then go to Settings (the
    left button) and change the language ther.
  2. On Android Phones, login and choose the menu button and go to Settings.
    Then choose Change Locale. Unfortunately, you may also need to manually
    change the language on each form as well (open the form, press the menu
    button and choose Change Language).

If you’d like you can also go to our Uservoice forum (dimagi.uservoice.com)
and submit the suggestion for making the mobile worker language setting
also change the language on the phone.

Thanks,
Sheel

··· On Tue, Oct 22, 2013 at 2:44 PM, Marko Kerac wrote:

Hi,

I have build our forms in English and filled out the second language (nya)
in Chichewa for many, but not all questions. For my mobile users, I have
selected their default language as chichewa, and yet all the questions
appear in english on the phones…?

Is there some other setting that needs to be selected?

Thanks


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Sheel Shah
Project Manager | Dimagi India
t: +91 1146704670 | m: +91 9560187282

Hi,

Further to the points mentioned, i wanted to highlight an issue i have
noticed on the language (by the way i find the language change as a great
option to have, and its really easy to use).

  1. On an android phone, if i have two languages setup for my project, i
    need to click two times on the “options” button on the phone, to get the
    "Change Language" option to be selectable. The first time it shows up as a
    displayed - but disabled option. however, clicking on the options button
    again enables the “Change Language” option for the form.

  2. Additionally, i have noticed the languages do not get downloaded by
    default, rather one has to select “deploy” in the language definition page
    for the additional languages to be selected to be deployed.

  3. The Android version 2.3.6 does not support some of the indian languages
    like “kannada”. Projects using kannada on android, should not deploy their
    apps on this version of android.

  4. While creating a reminder, request for project specific languages to be
    provided as a drop down in the message language field.

Regards

Manish

··· On Tuesday, October 22, 2013 6:58:21 PM UTC+5:30, Sheel Shah wrote: > > Hi Marko, > > What type of phone are you using? An Android or a Java-based phone? > Unfortunately that default language setting on a mobile worker doesn't yet > affect the phone language (it is used for the website and reports). > > Unfortunately you need to set the default language within the application, > not on the mobile worker. To do this, go to your app on CommCareHQ and > choose the Languages setting. Then drag and drop so that nya is at the top > of the list (making it the default). Then when you build the application, > nya will be the default. > > You can also manually change the language for the application on the phone. > 1. On Java Phones, login as your admin user and then go to Settings (the > left button) and change the language ther. > 2. On Android Phones, login and choose the menu button and go to Settings. > Then choose Change Locale. Unfortunately, you may also need to manually > change the language on each form as well (open the form, press the menu > button and choose Change Language). > > If you'd like you can also go to our Uservoice forum (dimagi.uservoice.com) > and submit the suggestion for making the mobile worker language setting > also change the language on the phone. > > Thanks, > Sheel > > > On Tue, Oct 22, 2013 at 2:44 PM, Marko Kerac <marko...@gmail.com wrote: > >> Hi, >> >> I have build our forms in English and filled out the second language >> (nya) in Chichewa for many, but not all questions. For my mobile users, I >> have selected their default language as chichewa, and yet all the questions >> appear in english on the phones...? >> >> Is there some other setting that needs to be selected? >> >> Thanks >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/groups/opt_out. >> > > > > -- > Sheel Shah > Project Manager | Dimagi India > t: +91 1146704670 | m: +91 9560187282 > > >

Hi all,

Thanks for the feedback on this. I wanted to clarify on a couple of these
points:

  1. On an android phone, if i have two languages setup for my project, i
    need to click two times on the “options” button on the phone, to get the
    "Change Language" option to be selectable. The first time it shows up as a
    displayed - but disabled option. however, clicking on the options button
    again enables the “Change Language” option for the form.

This definitely sounds like a bug! Sorry about that. Can you email a bug
report including your phone version using this template?
https://confluence.dimagi.com/display/commcarepublic/Bug+Report+Template We’ll
get that cleared up ASAP.

  1. Additionally, i have noticed the languages do not get downloaded by
    default, rather one has to select “deploy” in the language definition page
    for the additional languages to be selected to be deployed.

This is an unfortunate consequence of CommCare HQ assuming that you’ll be
defining multiple languages “globally” (IE: for the CommCare menus as well
as the forms themselves). We’re also working on getting this fixed.

  1. The Android version 2.3.6 does not support some of the indian languages
    like “kannada”. Projects using kannada on android, should not deploy their
    apps on this version of android.

Android phones before Version 4.0 do have very limited language sets,
although phone font support varies. I have seen 2.3 phones which supported
Kannada script, but they are not common. I agree that it’s always dangerous
to assume that Android phones will support different fonts. Checking first
is very valuable!

  1. While creating a reminder, request for project specific languages to be

provided as a drop down in the message language field.

I’ll pass this along to the dev team. Thanks for the feedback!

··· On Mon, Oct 28, 2013 at 7:57 PM, wrote:

Regards

Manish

On Tuesday, October 22, 2013 6:58:21 PM UTC+5:30, Sheel Shah wrote:

Hi Marko,

What type of phone are you using? An Android or a Java-based phone?
Unfortunately that default language setting on a mobile worker doesn’t yet
affect the phone language (it is used for the website and reports).

Unfortunately you need to set the default language within the
application, not on the mobile worker. To do this, go to your app on
CommCareHQ and choose the Languages setting. Then drag and drop so that
nya is at the top of the list (making it the default). Then when you build
the application, nya will be the default.

You can also manually change the language for the application on the
phone.

  1. On Java Phones, login as your admin user and then go to Settings (the
    left button) and change the language ther.
  2. On Android Phones, login and choose the menu button and go to
    Settings. Then choose Change Locale. Unfortunately, you may also need to
    manually change the language on each form as well (open the form, press the
    menu button and choose Change Language).

If you’d like you can also go to our Uservoice forum (
dimagi.uservoice.com) and submit the suggestion for making the mobile
worker language setting also change the language on the phone.

Thanks,
Sheel

On Tue, Oct 22, 2013 at 2:44 PM, Marko Kerac marko...@gmail.com wrote:

Hi,

I have build our forms in English and filled out the second language
(nya) in Chichewa for many, but not all questions. For my mobile users, I
have selected their default language as chichewa, and yet all the questions
appear in english on the phones…?

Is there some other setting that needs to be selected?

Thanks


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-user…@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


Sheel Shah
Project Manager | Dimagi India
t: +91 1146704670 | m: +91 9560187282


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Clayton,

Thanks for the updates on the points. Will update the details in the link
provided.

Regards

Manish

··· On Tue, Oct 29, 2013 at 9:03 PM, Clayton Sims wrote:

Hi all,

Thanks for the feedback on this. I wanted to clarify on a couple of these
points:

On Mon, Oct 28, 2013 at 7:57 PM, manish.sharma@rxehe.com wrote:

  1. On an android phone, if i have two languages setup for my project, i
    need to click two times on the “options” button on the phone, to get the
    "Change Language" option to be selectable. The first time it shows up as a
    displayed - but disabled option. however, clicking on the options button
    again enables the “Change Language” option for the form.

This definitely sounds like a bug! Sorry about that. Can you email a bug
report including your phone version using this template?
https://confluence.dimagi.com/display/commcarepublic/Bug+Report+Template We’ll
get that cleared up ASAP.

  1. Additionally, i have noticed the languages do not get downloaded by
    default, rather one has to select “deploy” in the language definition page
    for the additional languages to be selected to be deployed.

This is an unfortunate consequence of CommCare HQ assuming that you’ll be
defining multiple languages “globally” (IE: for the CommCare menus as well
as the forms themselves). We’re also working on getting this fixed.

  1. The Android version 2.3.6 does not support some of the indian
    languages like “kannada”. Projects using kannada on android, should not
    deploy their apps on this version of android.

Android phones before Version 4.0 do have very limited language sets,
although phone font support varies. I have seen 2.3 phones which supported
Kannada script, but they are not common. I agree that it’s always dangerous
to assume that Android phones will support different fonts. Checking first
is very valuable!

  1. While creating a reminder, request for project specific languages to be

provided as a drop down in the message language field.

I’ll pass this along to the dev team. Thanks for the feedback!

Regards

Manish

On Tuesday, October 22, 2013 6:58:21 PM UTC+5:30, Sheel Shah wrote:

Hi Marko,

What type of phone are you using? An Android or a Java-based phone?
Unfortunately that default language setting on a mobile worker doesn’t yet
affect the phone language (it is used for the website and reports).

Unfortunately you need to set the default language within the
application, not on the mobile worker. To do this, go to your app on
CommCareHQ and choose the Languages setting. Then drag and drop so that
nya is at the top of the list (making it the default). Then when you build
the application, nya will be the default.

You can also manually change the language for the application on the
phone.

  1. On Java Phones, login as your admin user and then go to Settings (the
    left button) and change the language ther.
  2. On Android Phones, login and choose the menu button and go to
    Settings. Then choose Change Locale. Unfortunately, you may also need to
    manually change the language on each form as well (open the form, press the
    menu button and choose Change Language).

If you’d like you can also go to our Uservoice forum (
dimagi.uservoice.com) and submit the suggestion for making the mobile
worker language setting also change the language on the phone.

Thanks,
Sheel

On Tue, Oct 22, 2013 at 2:44 PM, Marko Kerac marko...@gmail.com wrote:

Hi,

I have build our forms in English and filled out the second language
(nya) in Chichewa for many, but not all questions. For my mobile users, I
have selected their default language as chichewa, and yet all the questions
appear in english on the phones…?

Is there some other setting that needs to be selected?

Thanks


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-user…@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


Sheel Shah
Project Manager | Dimagi India
t: +91 1146704670 | m: +91 9560187282


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/pUrs9y9xMN0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Regards

Manish Sharma

mailto: manish.sharma@rxehe.com
mobile: +91 98805 68628

I’m facing similar issue, as i have 3 languages in the app, the English one is the default. the questions in English and translated to other languages, when i select the other languages, the app still in English and the other languages not appear