Connection timeouts during deploy

Our client based in Zimbabwe is running into connection timeouts with some components during a deploy. One consistent one is:

TASK [kafka : Download Kafka] ***************************************************************************************************************************************************************
fatal: [192.168.100.21]: FAILED! => {“changed”: false, “dest”: “/opt/kafka_2.10-0.8.2.2.tgz”, “elapsed”: 10, “msg”: “Connection failure: timed out”, “url”: “http://archive.apache.org/dist/kafka/0.8.2.2/kafka_2.10-0.8.2.2.tgz”}

It seems the timeout is 10 seconds and it’s taking longer than that for the server to respond. They were able to manually download the file in their browser, though the server is a bit slow to respond initially.

Is there a way we can increase the timeout through a parameter or perhaps a script edit?
Thanks!

Hi Ed, it looks like that download happens here, using the get_url command. The ansible docs show an optional timeout paramer that defaults to 10 seconds.

That could probably be modified as needed. It’d be nice if there’s some way to globally change the default timeout, but I’m not sure what sort of options there are for that.

1 Like

That’s helpful Ethan, thanks!