CommCare Sync Setup

Hi

I've been struggling to set up CommCare sync for our project. I have reviewed the help site and the GitHub repo steps but I'm not sure how to proceed.

What I have done thus far:

  1. Able to run Data export tool successfully on Command prompt and create the data config file
  2. Installed Docker Desktop - as suggested by the GitHub repo

I'm not sure how to proceed after this. What steps do I follow on Docker or is there something else that I need to do. I'm stuck at the make init step.

Please can someone elaborate on the step by step process to have it setup?

Thanks in advance!

What is the issue you are having with make init? If you are getting error messages in the console can you paste them? Also, confirming you also installed docker-compose in addition to Docker desktop?

Note: on older versions of windows you may need to install make separately, as per makefile - How to install and use "make" in Windows? - Stack Overflow

Note 2: The make file is just a wrapper around docker-compose commands. If you inspect the contents of the Makefile in the repository, you can also run the commands manually without using make (e.g. docker-compose up -d).

Hi Cory

The error is "no configuration file provided: not found" when I run the "docker-compose up -d" command on Command prompt

Sorry, I think I figured it out.

I had to move the commcare-sync folder to the root directory of the .docker folder to make it run.

I have managed to run the following commands:

start: ## Start the docker containers
@echo "Starting the docker containers"
@docker-compose up -d
@echo "Containers started - http://localhost:8000"

stop: ## Stop Containers
@docker-compose down

build: ## Build Containers
@docker-compose build

How do I go from here?

Is your app online at http://localhost:8000/ now? (you can try opening it in a browser to check).

If so, you can start testing/configuring it according to this guide CommCare Sync: web application for managing your data warehouse - CommCare Public - Global Site

What is your goal in choosing to set up CommCare Sync? How you use it (including where and how you install it) will depend on how it's being used, who needs access to it, etc.

Hi Cory

Yes, I've managed to get it online at http://localhost:8000/
I've login to CommCare Sync and in the process of setting up the exports and projects

My goal is sync our data to our ArcGIS and also to connect to PowerBI and other custom PowerApps for organizational purposes.

Thank you so much for your assistance!

1 Like


i have this error, can someone help me

Hi Json

That error means that there is a database table missing. The usual reason for this is that the database migrations weren't run.

Are you installing CommCare Sync manually? If so you'll need to run python manage.py migrate in order to have the database set up.

Very helpful. Thanks a lot @Simon_Kelly

I can't create the database because I'm not given access. What to do in this case @Simon_Kelly ?


Hi

You need to a command to create the first user. You can do that via the command line as follows:

python manage.py createsuperuser

Then you will be able to log in.

If you wish to allow signups you can do that by following the instructions here: System Administration — CommCare Sync Ansible documentation

Hi thank you @Simon. It work properly.
But when I run, I see this screen:

Could you send the rest of the error output please. The bit I need is at the bottom.

From what I can see though it looks like it could be an issue connecting to the database.

Hi @Simon_Kelly

Indeed, I think I missed something in the connection to the database.

where to run the python manage.py migrate?

thanks

@jsonacosta202 C:\Users\itrebi\Commcare_Sync\commcare-sync>