Commcare mobile app not working

we are facing this problem. how can we fix this?

Do you see this issue on just one or two devices, or is this a more prevalent problem?

The error message suggests that the app installed on the device is corrupt. It also mentions 112 quarantined forms. You may read more about what that means here. That page also describes how to investigate the affected forms.

Have you already attempted to reinstall the app?

Hi @Ethan_Soergel ,

We are seeing this error right after logging in. So we don’t have the option to go to the menu and see the list of quarantined forms. That’s what we couldn’t find in existing commcare android documentations.
->We didn’t attempt to re-install because of fear of data loss.

Sorry for not mentioning that before.

Hey Anteneh,

This error generally happens when the CommCare application files are deleted from the Android file system. This can happen either through manual user intervention or some other apps (like storage cleaning apps or file explorer apps) deleting these files on the Android file system.

You should be able to check the contents of CommCare’s directory under “Android/data” to verify whether xml files for all these forms exist there.

Furthermore, We have revamped the UI for this error significantly in the newer CommCare releases and have introduced things like auto-recovery that re-downloads any missing app configuration files for the app. So it’s highly recommended that you try updating CommCare in an attempt to auto-fix this error. Though if the forms had not been synced to the server and doesn’t exist on file storage I am afraid they have been lost and can’t be recovered.