Case list empty please help

Hi,

I have 2 forms in a single module using case management. The first form
opens a case and the second form requires selecting a case in order to
complete the form.

But the case list for the second form is empty even though I’ve set the
case type at module level, saved case properties from Form 1 and referenced
those case properties in Form2.

I’m probably not saving case properties in the way I’m supposed to. But I
can’t figure out exactly what I’m doing wrong.

Could you please take a look at my set up and troubleshoot?

I have set up case management for each form in the following way:

Form 1:

  • set to “register a case”
  • 7 case properties saved

Form 2:

  • set to “update a case”
  • hidden questions that exactly match saved case properties questions used
    in Form 1 (hidden to prevent user from changing responses)
  • displayed questions that exactly match saved case properties questions
    used in Form 1 (in order for user to update responses)
  • several new questions not appearing in or related to Form 1
  • saved ALL 7 case properties from Form 1 in case management settings tab
  • saved 4 NEW case properties from questions in Form 2 (not listed as case
    properties or questions in Form 1) in case management settings tab

I should also mentioned that Form 2 was set up after data for Form 1 has
already been collected. I will also be adding 2 more follow-up forms.

Can you please tell why my case list is empty and what I should do to
correct.

Thanks,
Lameez

When you do the above testing, are you always using the same phone? I was
wondering if the second user might be on a different phone … and might be
logged in as a different user, who was not in a case sharing group with the
first user. BUT, I know that is a longshot. --Eric

also, if they were on two different phones, it’s also possible you hadn’t
pressed sync on the second phone? But I bet you are using only one phone.

Hi Eric,

Thanks for your feedback.

Turns out this was just me being stupid haha!

In the original survey the data for Form 1 was already collected. But in
the Test Module I'd forgotten to fill out the first form so of course there
were no cases listed in the second.

Tested it this morning and it works!

It does however prove my theory that commcare case management can drive you
bonkers! :slight_smile:

Lameez

··· On 2 Feb 2017 12:00, "Eric Stephan" wrote:

When you do the above testing, are you always using the same phone? I was
wondering if the second user might be on a different phone .. and might be
logged in as a different user, who was not in a case sharing group with the
first user. BUT, I know that is a longshot. --Eric

--
You received this message because you are subscribed to a topic in the
Google Groups "commcare-users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/commcare-users/ub3ekyB0INc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.