Case export issue related to date range and # of cases

In December, my organization contacted CommCare support because we were receiving an error message when we tried to export our case data. At the time, we were advised to export the data in smaller batches (e.g., 6/1/17 to 11/30/17 and then 12/1/17 to 12/31/17) and combine the two exports as a temporary solution until the issue was solved. We did this, and it worked well.

Recently, we did a similar export (6/1/17 - 11/30/17) + (12/1/17-12/31/17) + (1/1/18 - 1/14/18) and then tried exporting the full range of data, 6/1/17 - 1/14/18. Both exports worked without error messages coming up; however, the number of cases/rows in the two resultant databases were vastly different. The first, pasted-together export had 2,471 cases, and the second, single export had only 1,644. We redid each type of export multiple times and got the same result. Further, an initial comparison of the cases that were present/missing in each export did not reveal a consistent pattern we could identify, nor did there appear to be duplicate cases in the first export (I thought the issue might have been duplication due to cases being “last modified” in multiple date ranges in the first export, but I don’t think that is the case).

Any insight into what could be causing this discrepancy would be greatly appreciated. Thank you!

Hi Rachel,

That sounds quite troubling, and like something our engineering team needs
to know about.

Can you Report an Issue from the CommCare HQ interface along with this
context information so someone can look into the export data for your
specific project space on HQ and figure out what is causing this
discrepency?
-Clayton

Thank you for your quick reply, Clayton!

Our team reached out about this last week (Ticket 268559) but were still
pending resolution this morning, so I thought I’d see if anyone on the
forum had ideas. We got a message from the support team later this
afternoon, and it sounds like they are looking into it but are still not
sure what caused the discrepancy.