Can not sync forms to commcarehq from phone

Hi All,

I am unable to sync forms to the server even after setting up apache proxy
server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission as
the request body instead.

Hi Patrick

Please describe what didn’t work about the instruction on the PR:

··· On 2 March 2015 at 15:38, Patrick Toroitich wrote:

Hi All,

I am unable to sync forms to the server even after setting up apache proxy
server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission as
the request body instead.


You received this message because you are subscribed to the Google Groups
“CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Thanks Cory,

But it means now that i wont be able to access commcarehq from the public ip
and for the purpose of testing i wont still be able to sync forms if i am
outside the local network.

or elaborate further if i did not understand you properly.

··· On Monday, March 2, 2015 at 4:38:43 PM UTC+3, Patrick Toroitich wrote: > > Hi All, > > I am unable to sync forms to the server even after setting up apache proxy > server with the following error: > > 2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission. > Response is: > Content-Type: text/html; charset=utf-8 > > If you use multipart/form-data, please name your file xml_submission_file. > You may also do a normal (non-multipart) post with the xml submission as > the request body instead. > >

Thanks Kelly,

However im not sure how to do that. may be guide me through.

should i start commcarehq by just executing manag.py run server
or should i still point it to the public ip on the local settings i,e
manage.py run server mypublicip

Regards

··· On Monday, March 2, 2015 at 4:38:43 PM UTC+3, Patrick Toroitich wrote: > > Hi All, > > I am unable to sync forms to the server even after setting up apache proxy > server with the following error: > > 2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission. > Response is: > Content-Type: text/html; charset=utf-8 > > If you use multipart/form-data, please name your file xml_submission_file. > You may also do a normal (non-multipart) post with the xml submission as > the request body instead. > >

Kelly what settings or configuration file do i need to change?

··· On Monday, March 2, 2015 at 4:38:43 PM UTC+3, Patrick Toroitich wrote: > > Hi All, > > I am unable to sync forms to the server even after setting up apache proxy > server with the following error: > > 2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission. > Response is: > Content-Type: text/html; charset=utf-8 > > If you use multipart/form-data, please name your file xml_submission_file. > You may also do a normal (non-multipart) post with the xml submission as > the request body instead. > >

Hi Patrick,

I noticed your recent comment
https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76890858.
Cory and Will are both on this thread, so no need to ping them on the
github issue as well.

If you could start by describing what didn’t work about the instructions
Simon linked to (
https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76703830),
then we’ll be able to help you work through it.

Cheers,
Danny

··· On Mon, Mar 2, 2015 at 8:50 PM, Simon Kelly wrote:

Hi Patrick

Please describe what didn’t work about the instruction on the PR:
https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76703830

On 2 March 2015 at 15:38, Patrick Toroitich pattorolimo@gmail.com wrote:

Hi All,

I am unable to sync forms to the server even after setting up apache
proxy server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission as
the request body instead.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Patrick

What Cory is saying is that Django should run locally on port 8000 but
requests should go through Apache which will be running on port 80. Apache
is configured to proxy requests through to the Django worker. So you will
still be able to access it from your public IP.

··· On 4 March 2015 at 06:50, Patrick Toroitich wrote:

Thanks Cory,

But it means now that i wont be able to access commcarehq from the public
ip
and for the purpose of testing i wont still be able to sync forms if i am
outside the local network.

or elaborate further if i did not understand you properly.

On Monday, March 2, 2015 at 4:38:43 PM UTC+3, Patrick Toroitich wrote:

Hi All,

I am unable to sync forms to the server even after setting up apache
proxy server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission as
the request body instead.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

Hi Patrick,

If you have specific questions please follow up with those in as much
detail as possible.

I believe we have provided all of the information necessary to unblock you

  • or at least until you are able to follow up with more information about
    the specific problems you are facing.

Perhaps you should also consider using the hosted version of CommCare HQ,
as it is quite a large project to setup and maintain.

Cory

··· On Thu, Mar 5, 2015 at 8:40 AM, Patrick Toroitich wrote:

Kelly what settings or configuration file do i need to change?

On Monday, March 2, 2015 at 4:38:43 PM UTC+3, Patrick Toroitich wrote:

Hi All,

I am unable to sync forms to the server even after setting up apache
proxy server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission as
the request body instead.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Robert,

I downloaded the apache config file edited the necessary lines as per the
instructions on the file like
pointing it to my actual commcarehq installation.

I placed the file in the /etc/apache2/sites-available directory, disabled
default.conf and run the following command
sudo a2ensite myfile.conf that i placed in the directory above.

tried to sync the saved form on my samsung tab and still receive the
earlier error as mentioned in


Below is apache logs

Enter code here…Tue Mar 03 09:37:16 2015] [notice] Apache/2.2.22 (Ubuntu)
configured – resuming normal operations
[Tue Mar 03 09:37:53 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:37:53 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:46:30 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:46:30 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:52:06 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:52:06 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:58:17 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 09:58:18 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:00:05 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:00:05 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 10:03:41 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:03:42 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:07:05 2015] [notice] SIGUSR1 received. Doing graceful
restart
apache2: Could not reliably determine the server’s fully qualified domain
name, using 127.0.1.1 for ServerName
[Tue Mar 03 10:07:05 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:07:16 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:07:17 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:14:50 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:14:51 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:20:06 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:20:06 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 10:24:13 2015] [error] [client 190.79.154.127] client sent
HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/tmUnblock.cgi
[Tue Mar 03 10:42:01 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:42:01 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 11:14:02 2015] [error] [client 75.141.104.130] client sent
HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/tmUnblock.cgi
[Tue Mar 03 11:24:04 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 11:24:04 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 14:10:46 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 14:10:46 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 14:10:51 2015] [error] proxy: HTTP: disabled connection for
(localhost)
[Tue Mar 03 14:23:12 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 14:23:12 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)

··· On Tuesday, March 3, 2015 at 9:06:31 AM UTC+3, Daniel Roberts wrote: > > Hi Patrick, > > I noticed your recent comment > https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76890858. > Cory and Will are both on this thread, so no need to ping them on the > github issue as well. > > If you could start by describing what didn't work about the instructions > Simon linked to ( > https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76703830), > then we'll be able to help you work through it. > > Cheers, > Danny > > On Mon, Mar 2, 2015 at 8:50 PM, Simon Kelly <ske...@dimagi.com > wrote: > >> Hi Patrick >> >> Please describe what didn't work about the instruction on the PR: >> https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76703830 >> >> On 2 March 2015 at 15:38, Patrick Toroitich <patto...@gmail.com > wrote: >> >>> Hi All, >>> >>> I am unable to sync forms to the server even after setting up apache >>> proxy server with the following error: >>> >>> 2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission. >>> Response is: >>> Content-Type: text/html; charset=utf-8 >>> >>> If you use multipart/form-data, please name your file >>> xml_submission_file. >>> You may also do a normal (non-multipart) post with the xml submission as >>> the request body instead. >>> >>> -- >>> >>> --- >>> You received this message because you are subscribed to the Google >>> Groups "CommCare Developers" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to commcare-developers+unsubscribe@googlegroups.com >>> . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> >> >> -- >> Simon Kelly >> Senior Engineer | Dimagi South Africa >> >> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

Hi Patrick

From the logs it looks like apache wasn’t able to connect to your local
Django instance. Make sure it is running and serving requests on port 8000.

Also don’t forget that you need to update your BASE_ADDRESS setting and
then create a new build of the app and install it on your phone.

··· On 3 March 2015 at 13:43, Patrick Toroitich wrote:

Hi Robert,

I downloaded the apache config file edited the necessary lines as per the
instructions on the file like
pointing it to my actual commcarehq installation.

I placed the file in the /etc/apache2/sites-available directory, disabled
default.conf and run the following command
sudo a2ensite myfile.conf that i placed in the directory above.

tried to sync the saved form on my samsung tab and still receive the
earlier error as mentioned in https://github.com/
dimagi/commcare-hq/issues/5417#issuecomment-76890858
Below is apache logs

Enter code here…Tue Mar 03 09:37:16 2015] [notice] Apache/2.2.22 (Ubuntu
) configured – resuming normal operations
[Tue Mar 03 09:37:53 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:37:53 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:46:30 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:46:30 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:52:06 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:52:06 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:58:17 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 09:58:18 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:00:05 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:00:05 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 10:03:41 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:03:42 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:07:05 2015] [notice] SIGUSR1 received. Doing graceful
restart
apache2: Could not reliably determine the server’s fully qualified domain
name, using 127.0.1.1 for ServerName
[Tue Mar 03 10:07:05 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:07:16 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:07:17 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:14:50 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:14:51 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:20:06 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:20:06 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 10:24:13 2015] [error] [client 190.79.154.127] client sent
HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/tmUnblock.cgi
[Tue Mar 03 10:42:01 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:42:01 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 11:14:02 2015] [error] [client 75.141.104.130] client sent
HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/tmUnblock.cgi
[Tue Mar 03 11:24:04 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 11:24:04 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 14:10:46 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 14:10:46 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 14:10:51 2015] [error] proxy: HTTP: disabled connection for
(localhost)
[Tue Mar 03 14:23:12 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 14:23:12 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)

On Tuesday, March 3, 2015 at 9:06:31 AM UTC+3, Daniel Roberts wrote:

Hi Patrick,

I noticed your recent comment https://github.com/
dimagi/commcare-hq/issues/5417#issuecomment-76890858. Cory and Will are
both on this thread, so no need to ping them on the github issue as well.

If you could start by describing what didn’t work about the instructions
Simon linked to (https://github.com/dimagi/commcare-hq/issues/5417#
issuecomment-76703830), then we’ll be able to help you work through it.

Cheers,
Danny

On Mon, Mar 2, 2015 at 8:50 PM, Simon Kelly ske...@dimagi.com wrote:

Hi Patrick

Please describe what didn’t work about the instruction on the PR:
https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76703830

On 2 March 2015 at 15:38, Patrick Toroitich patto...@gmail.com wrote:

Hi All,

I am unable to sync forms to the server even after setting up apache
proxy server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file
xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission
as the request body instead.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa

sure Kelly my development machine is on a public ip
and changed the Base_Address to match the public ip of that machine

··· On Tuesday, March 3, 2015 at 2:50:23 PM UTC+3, skelly wrote: > > Hi Patrick > > From the logs it looks like apache wasn't able to connect to your local > Django instance. Make sure it is running and serving requests on port 8000. > > Also don't forget that you need to update your BASE_ADDRESS setting and > then create a new build of the app and install it on your phone. > > On 3 March 2015 at 13:43, Patrick Toroitich <patto...@gmail.com > wrote: > >> Hi Robert, >> >> I downloaded the apache config file edited the necessary lines as per the >> instructions on the file like >> pointing it to my actual commcarehq installation. >> >> I placed the file in the /etc/apache2/sites-available directory, disabled >> default.conf and run the following command >> sudo a2ensite myfile.conf that i placed in the directory above. >> >> tried to sync the saved form on my samsung tab and still receive the >> earlier error as mentioned in https://github.com/ >> dimagi/commcare-hq/issues/5417#issuecomment-76890858 >> Below is apache logs >> >> >> Enter code here...Tue Mar 03 09:37:16 2015] [notice] Apache/2.2.22 ( >> Ubuntu) configured -- resuming normal operations >> [Tue Mar 03 09:37:53 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 09:37:53 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 09:46:30 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 09:46:30 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 09:52:06 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 09:52:06 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 09:58:17 2015] [notice] caught SIGTERM, shutting down >> [Tue Mar 03 09:58:18 2015] [notice] Apache/2.2.22 (Ubuntu) configured -- >> resuming normal operations >> [Tue Mar 03 10:00:05 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 10:00:05 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 10:03:41 2015] [notice] caught SIGTERM, shutting down >> [Tue Mar 03 10:03:42 2015] [notice] Apache/2.2.22 (Ubuntu) configured -- >> resuming normal operations >> [Tue Mar 03 10:07:05 2015] [notice] SIGUSR1 received. Doing graceful >> restart >> apache2: Could not reliably determine the server's fully qualified >> domain name, using 127.0.1.1 for ServerName >> [Tue Mar 03 10:07:05 2015] [notice] Apache/2.2.22 (Ubuntu) configured -- >> resuming normal operations >> [Tue Mar 03 10:07:16 2015] [notice] caught SIGTERM, shutting down >> [Tue Mar 03 10:07:17 2015] [notice] Apache/2.2.22 (Ubuntu) configured -- >> resuming normal operations >> [Tue Mar 03 10:14:50 2015] [notice] caught SIGTERM, shutting down >> [Tue Mar 03 10:14:51 2015] [notice] Apache/2.2.22 (Ubuntu) configured -- >> resuming normal operations >> [Tue Mar 03 10:20:06 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 10:20:06 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 10:24:13 2015] [error] [client 190.79.154.127] client sent >> HTTP/1.1 request without hostname (see RFC2616 section 14.23): >> /tmUnblock.cgi >> [Tue Mar 03 10:42:01 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 10:42:01 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 11:14:02 2015] [error] [client 75.141.104.130] client sent >> HTTP/1.1 request without hostname (see RFC2616 section 14.23): >> /tmUnblock.cgi >> [Tue Mar 03 11:24:04 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 11:24:04 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 14:10:46 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 14:10:46 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> [Tue Mar 03 14:10:51 2015] [error] proxy: HTTP: disabled connection for >> (localhost) >> [Tue Mar 03 14:23:12 2015] [error] (111)Connection refused: proxy: HTTP: >> attempt to connect to 127.0.0.1:8000 (localhost) failed >> [Tue Mar 03 14:23:12 2015] [error] ap_proxy_connect_backend disabling >> worker for (localhost) >> >> >> >> >> >> On Tuesday, March 3, 2015 at 9:06:31 AM UTC+3, Daniel Roberts wrote: >>> >>> Hi Patrick, >>> >>> I noticed your recent comment https://github.com/ >>> dimagi/commcare-hq/issues/5417#issuecomment-76890858. Cory and Will are >>> both on this thread, so no need to ping them on the github issue as well. >>> >>> If you could start by describing what didn't work about the instructions >>> Simon linked to (https://github.com/dimagi/commcare-hq/issues/5417# >>> issuecomment-76703830), then we'll be able to help you work through it. >>> >>> Cheers, >>> Danny >>> >>> On Mon, Mar 2, 2015 at 8:50 PM, Simon Kelly wrote: >>> >>>> Hi Patrick >>>> >>>> Please describe what didn't work about the instruction on the PR: >>>> https://github.com/dimagi/commcare-hq/issues/5417#issuecomment-76703830 >>>> >>>> On 2 March 2015 at 15:38, Patrick Toroitich wrote: >>>> >>>>> Hi All, >>>>> >>>>> I am unable to sync forms to the server even after setting up apache >>>>> proxy server with the following error: >>>>> >>>>> 2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission. >>>>> Response is: >>>>> Content-Type: text/html; charset=utf-8 >>>>> >>>>> If you use multipart/form-data, please name your file >>>>> xml_submission_file. >>>>> You may also do a normal (non-multipart) post with the xml submission >>>>> as the request body instead. >>>>> >>>>> -- >>>>> >>>>> --- >>>>> You received this message because you are subscribed to the Google >>>>> Groups "CommCare Developers" group. >>>>> To unsubscribe from this group and stop receiving emails from it, send >>>>> an email to commcare-developers+unsubscribe@googlegroups.com. >>>>> For more options, visit https://groups.google.com/d/optout. >>>>> >>>> >>>> >>>> >>>> -- >>>> Simon Kelly >>>> Senior Engineer | Dimagi South Africa >>>> >>>> -- >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "CommCare Developers" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to commcare-developers+unsubscribe@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> -- >> >> --- >> You received this message because you are subscribed to the Google Groups >> "CommCare Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-developers+unsubscribe@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Simon Kelly > Senior Engineer | Dimagi South Africa >

It looks like apache is connecting to localhost. You should run django on
localhost and let apache be the only thing on the public IP

··· On Tue, Mar 3, 2015 at 6:56 AM, Patrick Toroitich wrote:

sure Kelly my development machine is on a public ip
and changed the Base_Address to match the public ip of that machine

On Tuesday, March 3, 2015 at 2:50:23 PM UTC+3, skelly wrote:

Hi Patrick

From the logs it looks like apache wasn’t able to connect to your local
Django instance. Make sure it is running and serving requests on port 8000.

Also don’t forget that you need to update your BASE_ADDRESS setting and
then create a new build of the app and install it on your phone.

On 3 March 2015 at 13:43, Patrick Toroitich patto...@gmail.com wrote:

Hi Robert,

I downloaded the apache config file edited the necessary lines as per
the instructions on the file like
pointing it to my actual commcarehq installation.

I placed the file in the /etc/apache2/sites-available directory,
disabled default.conf and run the following command
sudo a2ensite myfile.conf that i placed in the directory above.

tried to sync the saved form on my samsung tab and still receive the
earlier error as mentioned in https://github.com/dimagi/
commcare-hq/issues/5417#issuecomment-76890858
Below is apache logs

Enter code here…Tue Mar 03 09:37:16 2015] [notice] Apache/2.2.22 (
Ubuntu) configured – resuming normal operations
[Tue Mar 03 09:37:53 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:37:53 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:46:30 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:46:30 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:52:06 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 09:52:06 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 09:58:17 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 09:58:18 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:00:05 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:00:05 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 10:03:41 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:03:42 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:07:05 2015] [notice] SIGUSR1 received. Doing graceful
restart
apache2: Could not reliably determine the server’s fully qualified
domain name, using 127.0.1.1 for ServerName
[Tue Mar 03 10:07:05 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:07:16 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:07:17 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:14:50 2015] [notice] caught SIGTERM, shutting down
[Tue Mar 03 10:14:51 2015] [notice] Apache/2.2.22 (Ubuntu) configured –
resuming normal operations
[Tue Mar 03 10:20:06 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:20:06 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 10:24:13 2015] [error] [client 190.79.154.127] client sent
HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/tmUnblock.cgi
[Tue Mar 03 10:42:01 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 10:42:01 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 11:14:02 2015] [error] [client 75.141.104.130] client sent
HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/tmUnblock.cgi
[Tue Mar 03 11:24:04 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 11:24:04 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 14:10:46 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 14:10:46 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)
[Tue Mar 03 14:10:51 2015] [error] proxy: HTTP: disabled connection for
(localhost)
[Tue Mar 03 14:23:12 2015] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:8000 (localhost) failed
[Tue Mar 03 14:23:12 2015] [error] ap_proxy_connect_backend disabling
worker for (localhost)

On Tuesday, March 3, 2015 at 9:06:31 AM UTC+3, Daniel Roberts wrote:

Hi Patrick,

I noticed your recent comment https://github.com/dim
agi/commcare-hq/issues/5417#issuecomment-76890858. Cory and Will are
both on this thread, so no need to ping them on the github issue as well.

If you could start by describing what didn’t work about the
instructions Simon linked to (https://github.com/dimagi/com
mcare-hq/issues/5417#issuecomment-76703830), then we’ll be able to
help you work through it.

Cheers,
Danny

On Mon, Mar 2, 2015 at 8:50 PM, Simon Kelly ske...@dimagi.com wrote:

Hi Patrick

Please describe what didn’t work about the instruction on the PR:
https://github.com/dimagi/commcare-hq/issues/5417#issuec
omment-76703830

On 2 March 2015 at 15:38, Patrick Toroitich patto...@gmail.com wrote:

Hi All,

I am unable to sync forms to the server even after setting up apache
proxy server with the following error:

2015-03-02 13:38:02,905 ERROR Status code 400 for a form submission.
Response is:
Content-Type: text/html; charset=utf-8

If you use multipart/form-data, please name your file
xml_submission_file.
You may also do a normal (non-multipart) post with the xml submission
as the request body instead.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “CommCare Developers” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Simon Kelly
Senior Engineer | Dimagi South Africa


You received this message because you are subscribed to the Google Groups
"CommCare Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.