Application access settings

Hi Girdhari,

I’m cc-ing the commcare-users list since we have recently bumped into this
problem elsewhere. Essentially the short answer is that the jad and jar
files are paired. The application signing process only works with the exact
same jad and jar files. So when you copy the jad and jar onto the phone you
have to make sure that both are the exact versions that were built together
by CommCareHQ. If you have an old jad with a new jar or vice/versa the
signing won’t work properly.

More information about diagnosing this problem is available on the wiki:
https://wiki.commcarehq.org/display/commcarepublic/Nokia+Phone+Permissions

cheers,
Cory

··· On Sun, Jul 3, 2011 at 2:27 PM, Girdhari Bora wrote:

Hi Neal,****


Thanks again for the timely help the other day. I need more of it with the
query below – please see if you can help me with the same (will put them on
forum as well) as well.****


· In NOKIA , both C2-01 and 2700c, which we are using –
loading (copying) the application for the first time enables us to set the
“Application access”, but any subsequent change in the file (deleting
old one and pasting the new one) grays out the “Always allowed” option,
making it not selectable. We are having this problem with all the sets and
Amelia did tell me of some firmware issues but I feel it seems more like
certificate issue or some settings somewhere. I am still struggling with a
solution, I hope there’s one as rural health workers find it very
irritating, so do I.



warm regards,****

girdhari****