API's: Getting a list of lookup tables and lookup table data

Hi,

According to your documentation, this is how to get a list of lookup tables:

So when I try to do this:
curl -v -u myemail:mypassword ‘https://www.commcarehq.org/a/mydomain/api/v0.3/fixture/

It fails with a 404.
What am I doing wrong?

Hi,
Could you try with the latest version of the api (v0.5)? I don’t believe that v0.3 had the fixture resource.
This would mean your url would be of the form https://www.commcarehq.org/a/mydomain/api/v0.5/fixture/
Hope that helps!
-Farid

Ok, what level of subscription do I need?
{“error”: “Your current subscription does not have access to this feature”}

To access the data APIs you need a Pro plan or above: https://www.dimagi.com/commcare/pricing/

Hi, we have pro plan or above, why is this happening?

The URL is https://www.commcarehq.org/a/guatemala-operacionesgt

That is odd, your project should have the appropriate subscription, and it doesn’t look like you’re doing anything incorrectly. That error only occurs if the project doesn’t have access to the API. Are you also using other APIs? Have you in the past? Could you report an error through the site so the support team can investigate?

Today I tried again and it started working. The same exact command I just scrolled up through my terminal history and it worked. Guess it needed a day?