Advanced form display condition

Hi,
I have been trying to add display conditions to forms. This is the
condition I have put:

(./interested_growing_crops=1 or ./Crops_grown=1) and ./Mini_reset=0

However, when deployed the form does not appear. All the 3 variables have
been added as case management to the respective forms. Please help us on
how we can solve it.

Thanks,
Prachi

Hi Prachi,

I don’t see anything that’s clearly incorrect about the expression you’ve
placed on the forms.

I think my first suggestion would be to add a form to your module quickly
that just displays the output of each one of those variables and runs the
expression inside of the form to ensure that the data looks correct as a
quick double-check, or potentially add each one of those variables to the
Case Detail screen you see before the module is shown.

If the variables are showing up correctly in the case detail or form and
the expression isn’t behaving as expected, I’d submit a ticket on
CommCareHQ since the support team could review the data more directly.

-Clayton

··· On Fri, Apr 14, 2017 at 7:44 AM, Prachi Patel wrote:

Hi,
I have been trying to add display conditions to forms. This is the
condition I have put:

(./interested_growing_crops=1 or ./Crops_grown=1) and ./Mini_reset=0

However, when deployed the form does not appear. All the 3 variables have
been added as case management to the respective forms. Please help us on
how we can solve it.

Thanks,
Prachi


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hey Clayton,
Thanks for the help. It is sorted now. Tried doing it using labels.

Thanks,
Prachi

··· On Fri, Apr 14, 2017 at 6:55 PM Clayton Sims wrote:

Hi Prachi,

I don’t see anything that’s clearly incorrect about the expression you’ve
placed on the forms.

I think my first suggestion would be to add a form to your module quickly
that just displays the output of each one of those variables and runs the
expression inside of the form to ensure that the data looks correct as a
quick double-check, or potentially add each one of those variables to the
Case Detail screen you see before the module is shown.

If the variables are showing up correctly in the case detail or form and
the expression isn’t behaving as expected, I’d submit a ticket on
CommCareHQ since the support team could review the data more directly.

-Clayton

On Fri, Apr 14, 2017 at 7:44 AM, Prachi Patel prachi@cms-india.org wrote:

Hi,
I have been trying to add display conditions to forms. This is the
condition I have put:

(./interested_growing_crops=1 or ./Crops_grown=1) and ./Mini_reset=0

However, when deployed the form does not appear. All the 3 variables have
been added as case management to the respective forms. Please help us on
how we can solve it.

Thanks,
Prachi


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/-uP2tAMzLgM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.