Upcoming changes to supported device and software versions for CommCare mobile

Hi CommCare users,

I’m sending this email to provide notice for upcoming changes to the devices and upgrade paths that are supported by the CommCare mobile application.

Our next upcoming Android release of CommCare 2.44.0 will deprecate future support for:

  • Devices running versions of Android OS below 4.0, including all devices running Android 2.2-3.2
  • Upgrading CommCare’s mobile app directly from CommCare version 2.3.0 (released Dec 18, 2012) or below

If you are concerned about ongoing support for your project as a result of this change, you can read about how to manage them in our online documentation, which outlines the consequences of these kinds of changes and how each can be mitigated.

I want to communicate that we take the decision to deprecate support for older hardware or app installs quite seriously, and based on our analytics, we expect this change to not affect the ongoing operation of any CommCare deployment. Users of forked-source versions of CommCare or who have opted out of analytics and are using extreme legacy versions of CommCare (2.3.0 or below) are advised to upgrade to the current Play Store release (Currently 2.43.1) or to sideload to any version after 2.4.0 immediately to ensure ongoing continuity of usage.

-Clayton Sims
CTO, Dimagi