Synch through a wifi hotspot

Hello Commcare users,

I was wondering if there was a way to synch data or do an app update if the cell phone is connected to the Internet through wifi to a private hotspot (other cell phone connected to the mobile internet network)?

Basically If only one mobile user has Mobile internet access can he share his Internet access for other mobile users to synch their data aswell?

I tried to do so but whereas the shared Internet connection is working Commcare seems like not to allow data exchange. Is there a technical detail I am missing or is this normal?

Thanks for your help

Nico

Nico,

I don’t know of any reason that this shouldn’t work - from the perspective
of CommCare, internet via tethering should be the same as internet via
regular Wi-Fi or data. Does the tethered phone give the “unable to connect
to server” error when you try to sync? What happens when you run the
Connection Test (from the settings menu on the home screen)? Does the
internet on the phone otherwise work?

-Will

··· On Thu, Mar 10, 2016 at 5:59 PM, wrote:

Hello Commcare users,

I was wondering if there was a way to synch data or do an app update if
the cell phone is connected to the Internet through wifi to a private
hotspot (other cell phone connected to the mobile internet network)?

Basically If only one mobile user has Mobile internet access can he share
his Internet access for other mobile users to synch their data aswell?

I tried to do so but whereas the shared Internet connection is working
Commcare seems like not to allow data exchange. Is there a technical detail
I am missing or is this normal?

Thanks for your help

Nico


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hello Will,

Thanks for the quick answer.

“unable to connect to server” is indeed the message I get. Otherwise the internet on the phone does work. This is why I wondered if it was related to Commcare or not.
I have not run the Connection Test but I will try when I have the opportunity.

Do you think the internet signal is just to weak?

Hello Will,

Thanks for the quick answer.

“unable to connect to server” is indeed the message I get. Otherwise the internet on the phone does work. This is why I wondered if it was related to Commcare or not.
I have not run the Connection Test but I will try when I have the opportunity.

Do you think the internet signal is just to weak?

Nicolas,

Many groups have used hotspots or device tethering to submit data, and we
believe that it should work.

Bandwidth and latency concerns can definitely be amplified by these
techniques, though, so a connection which is already somewhat shaky can be
pushed over the edge by the additional setup.

One technique I would try would be to use the phone’s browser to navigate
and log into the CommCareHQ website itself, which will verify whether both
the network is working and whether there are any addition problems with the
Secure Communications layer that we use (which wouldn’t be tested by
browsing to google, since that traffic is unencrypted).

-Clayton

··· On Thu, Mar 10, 2016 at 10:35 AM, wrote:

Hello Will,

Thanks for the quick answer.

“unable to connect to server” is indeed the message I get. Otherwise the
internet on the phone does work. This is why I wondered if it was related
to Commcare or not.
I have not run the Connection Test but I will try when I have the
opportunity.

Do you think the internet signal is just to weak?


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hello Clayton,

Thanks for the answer. I am happy to hear that it should work. I am going to try out what you have suggested.

I ll let you know.

Merci encore,

Nico