SF Monitoring Too app - feedback

Hi Jeffrey,

Thanks for your question!

The issue about numeric selection vs. scrolling is related to CommCare
Settings/CommCare Sense and Item Selection Mode. I’m also copying
commcare-users in case this is helpful for others.

  1. In the Structure and Configuration space where you build your
    application, click on the Application Name.
  2. Scroll down below Supported Languages, you’ll see Application Media,
    User Interface Translations etc.
  3. You’re interested in CommCare Settings. Click on that.
  4. In this section, look at the CommCare UI settings. You’ll see that
    you’ve got your application set to CommCare Sense TRUE, which means by
    default you are getting the settings designed for low literate users, such
    as numeric selection for form/module selection, one question per screen and
    others. (Clayton can probably comment on which features are included in the
    Sense mode).
  5. When you have CommCare Sense selected as TRUE, you cannot change the
    Item Selection Mode. It is set by default to Numeric. If you’d like your
    advanced users to be able to scroll through module and forms in your
    application, please make the CommCare Sense FALSE. The Item Selection Mode
    will automatically switch to Scrolling, unless you want numeric selection.

FYI there are other settings in this section too, such as enabling your
application to automatically send data from the application or manual send.
I think you might prefer auto-send still, so please change that if you
switch off the Sense mode. You can also change the user login screen so
that it is hidden and set to auto login. Would be good to discuss with the
team before deciding whether you want to enable some of these settings.

Thanks,

Mohini