Restore non deployed changes

Hi guys,

I’m a new user of Commcare application, so please can any one help me to
solve the following issue?

I previously deployed v196, then after I added other modules and every
change I made I saved them but I didn’t deployed these changes in a new
version.

But as we’re having issue on opening incomplete forms on the tablets, I
reverted a very old version (v171) and the issues were solved.

After solving these issues, I wanted to return on a module that I added
after v196 to continue working on it but I received an error saying “Oaps,
the module is missing”.

Is it possible to restore the changes that I made after v196 but which was
not yet deployed?

Thanks a lot!!

Hey Elysa,

I’m sorry to report that this is not possible - once you have reverted to a
build the current working copy of the application is deleted. We recommend
making frequent builds to ensure that no changes are lost. Hope you didn’t
lose too much work!

best,
Cory

··· On Fri, Oct 2, 2015 at 6:30 PM, elysa wrote:

Hi guys,

I’m a new user of Commcare application, so please can any one help me to
solve the following issue?

I previously deployed v196, then after I added other modules and every
change I made I saved them but I didn’t deployed these changes in a new
version.

But as we’re having issue on opening incomplete forms on the tablets, I
reverted a very old version (v171) and the issues were solved.

After solving these issues, I wanted to return on a module that I added
after v196 to continue working on it but I received an error saying “Oaps,
the module is missing”.

Is it possible to restore the changes that I made after v196 but which was
not yet deployed?

Thanks a lot!!


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks a lot for explaining to me what happened and to the advice too,
anyway I got a lesson!!

··· On Sat, Oct 3, 2015 at 7:21 AM, Cory Zue wrote:

Hey Elysa,

I’m sorry to report that this is not possible - once you have reverted to
a build the current working copy of the application is deleted. We
recommend making frequent builds to ensure that no changes are lost. Hope
you didn’t lose too much work!

best,
Cory

On Fri, Oct 2, 2015 at 6:30 PM, elysa tuyishime.elyse@gmail.com wrote:

Hi guys,

I’m a new user of Commcare application, so please can any one help me to
solve the following issue?

I previously deployed v196, then after I added other modules and every
change I made I saved them but I didn’t deployed these changes in a new
version.

But as we’re having issue on opening incomplete forms on the tablets, I
reverted a very old version (v171) and the issues were solved.

After solving these issues, I wanted to return on a module that I added
after v196 to continue working on it but I received an error saying “Oaps,
the module is missing”.

Is it possible to restore the changes that I made after v196 but which
was not yet deployed?

Thanks a lot!!


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/euhR3HTVeHk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Elyse Tuyishime
*Mobile: *+250 783 604 124

Skype: tuyishime.elyse

God Bless you!!