[Resolved] Issues with a deploy (update)

I'm updating a monolith server from 2021-05-10_13.24 to 2021-08-25_08.48
It's failing on the manage migrate_multi step with an unknown command: 'populate_user_role'

Any ideas how to resolve this?

Another question - has the fab rollback command been deprecated? Is there a way to roll back a deployment currently?

Hi Ed

There should be some more message content with instructions. I'm not sure why it's now showing. You need to do the following:

commcare-cloud <env> fab setup_limited_release --set code_branch=4f5a5ef0a9b5ef9873a9b2dce5646d7aa881c416

commcare-cloud <env> django-manage --release <release created by previous command> populate_user_role

commcare-cloud <env> deploy commcare
1 Like

Hey Simon, thanks for the feedback. Unfortunately it's still not working - it halts on the deploy commcare with the same error after performing the first two successfully. I'll post logs and edit them in here shortly

EDIT output for fab setup_limited_release: https://pastebin.com/raw/06NYuHdp
output for --release populate_user_role: https://pastebin.com/raw/nE7iPtD9
output for deploy commcare: https://pastebin.com/raw/dyNzB1Pz

Hi Ed, I see the issue, I'll put out a fix but in the mean time you can run the following:

commcare-cloud <env> django-manage --release 2021-08-26_11.38 migrate_multi

(edited: there was no need to fake the migration when running from the correct release)

1 Like

Good timing on the edit hehe :slight_smile:
EDIT and we're back in business, thanks again Simon!