Please upgrade to Ubuntu 18.04

Hi all,

CommCare’s new supported OS is Ubuntu 18.04 LTS.

For a number of years now, CommCare’s supported OS was Ubuntu 14.04 LTS, which reached End of Life this past April, 2019. This means it will no longer receive even critical, security-related releases.

In addition to this, maintainers who continue using Ubuntu 14.04 LTS will have to do so without the support of our tooling including (newer versions of) commcare-cloud. We will no longer be testing on Ubuntu 14.04, so any changes to CommCare or to versions of its third party open source dependencies (postgresql, elasticsearch, etc) may result in the inability to deploy new versions of CommCare on that operating system.

Cheers,
Danny