Local installation

After running the command:
commcare-cloud monolith deploy-stack --first-time -e 'CCHQ_IS_FRESH_INSTALL=1'

I am getting the error "unable to fetch some archives".

Is there a work around to solve this issue?

Note I have tries the following command and still getting the same error
commcare-cloud monolith deploy-stack --skip-check -e 'CCHQ_IS_FRESH_INSTALL=1'

Can you give more context about where that error happens? That could be a network error or it could mean an archive or package is no longer available.

Here is a screenshot

It updated the package list when I run:
commcare-cloud monolith deploy-stack --first-time -e 'CCHQ_IS_FRESH_INSTALL=1'

Then it fails when it tries to install the packages.

(tagging @Simon_Kelly so he gets a notification)

That looks like an issue outside of our control and potentially a transient issue since I was able to find the file it was looking for:


If the issue persists you could try updating /etc/apt/sources.list to use a different mirror as described here: https://linuxconfig.org/ubuntu-mirrors

Thank you @Simon_Kelly

You are right. I did a rerun of the script without changing the /etc/apt/sources.list and it has continued to install the packages.

1 Like

Hey @Simon_Kelly. Thanks again. We managed to install commcare and now we're getting an error when we punch in this command: $ commcare-cloud cluster django-manage create_kafka_topics.

We can create a new ticket for this but just wanted to see if you have a gut feel for what could be wrong.

@EzraMungai will paste the image in a minute.

Screenshot 2022-05-18 171703

Screenshot 2022-05-18 171747

You should try and restart Kafka and Zookeeper:

cchq <env> service kafka restart

(this should restart both services)

If the problem persists you'll need to check the Kafka logs for any clues.

I restarted the services with the command:

commcare-cloud monolith service kafka restart

and getting the error " could not get the requested service zookeeper"

Then, when I check the zookeeper-server.service logs i get the following

It looks like the Zookeeper configuration is missing. You could try re-run the Kafka playbook:

cchq <env> ap deploy_kafka.yml

It didn't work. Zookeper is still down but the playbook run. It seems the configuration is there so the command just run through and nothing changed.

I found a work around to this problem to this issue.

The folder /opt/zookeeper/conf/ and copied the zoo_sample.cfg to zoo.cfg then restarted zookeeper.

After this I run the create kafka topics command.


Thank you for your assistance. I managed to install commcare successfully.

Just one more question. Is there a way to upload custom certificates that are not from letsencrypt?

I have not tested this but I think it should be possible by setting up the configuration as follows:


letsencrypt_cchq_ssl: False
nginx_combined_cert_value: '{{ ssl_secrets.commcare_cert }}'
nginx_key_value: '{{ ssl_secrets.commcare_key }}'


  commcare_cert: |
    -----END CERTIFICATE-----
    -----END CERTIFICATE-----
  commcare_key: |
    -----BEGIN PRIVATE KEY-----
    -----END PRIVATE KEY-----