Import cases problem

I am trying to set a property to — for selected cases and I’m using an
amended, ‘cut down’ case export to do this.

After importing the case importer reports that cases have been imported but
when I re-export the cases the property has not been cleared (set to —).
They have the same values as they did before the import.

A funny thing happens when I specify the import and I wonder if this is
part of the problem. The Excel field name is d.location_retailer but this
name is not available from the property dropdown menu. The closest is:
dlocation_retailer (without the period). In fact all property names with a
period in them appear with the period missing in the dropdown.

Help!

Hey Simon,

Periods are not allowed in case property names. It sounds like that is
definitely part of the problem, and it may be a UX issue on our side if
we’re not properly telling you that on import.

Could you try with a set of property names that don’t have periods in them
and let us know if that fixes it for you?

thanks,
Cory

··· On Tue, Nov 3, 2015 at 11:42 PM, Simon Berry wrote:

I am trying to set a property to — for selected cases and I’m using an
amended, ‘cut down’ case export to do this.

After importing the case importer reports that cases have been imported
but when I re-export the cases the property has not been cleared (set to
—). They have the same values as they did before the import.

A funny thing happens when I specify the import and I wonder if this is
part of the problem. The Excel field name is d.location_retailer but this
name is not available from the property dropdown menu. The closest is:
dlocation_retailer (without the period). In fact all property names with a
period in them appear with the period missing in the dropdown.

Help!


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for the response. I have never used periods in property names. They seem to be system generated. Many of the property names that I specified when building the App now have ‘d.’ In front of them in case exports.

Simon

Apologies if this message is a bit cryptic, it was sent from my phone.

Simon Berry
counterpart project manager | KYTS Project
ceo and founder | ColaLife
+44 7932 107109 (UK)
+260 975572175 (Zambia)
skype: sxberry

··· > On 4 Nov 2015, at 09:55, Cory Zue wrote: > > Hey Simon, > > Periods are not allowed in case property names. It sounds like that is definitely part of the problem, and it may be a UX issue on our side if we're not properly telling you that on import. > > Could you try with a set of property names that don't have periods in them and let us know if that fixes it for you? > > thanks, > Cory > >> On Tue, Nov 3, 2015 at 11:42 PM, Simon Berry wrote: >> I am trying to set a property to --- for selected cases and I'm using an amended, 'cut down' case export to do this. >> >> After importing the case importer reports that cases have been imported but when I re-export the cases the property has not been cleared (set to ---). They have the same values as they did before the import. >> >> A funny thing happens when I specify the import and I wonder if this is part of the problem. The Excel field name is d.location_retailer but this name is not available from the property dropdown menu. The closest is: dlocation_retailer (without the period). In fact all property names with a period in them appear with the period missing in the dropdown. >> >> Help! >> >> -- >> You received this message because you are subscribed to the Google Groups "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an email to commcare-users+unsubscribe@googlegroups.com. >> For more options, visit https://groups.google.com/d/optout. > > -- > You received this message because you are subscribed to a topic in the Google Groups "commcare-users" group. > To unsubscribe from this topic, visit https://groups.google.com/d/topic/commcare-users/rM_zKm5-1pg/unsubscribe. > To unsubscribe from this group and all its topics, send an email to commcare-users+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout.

Hi Simon,

On the case export page, I would recommend creating a new custom export to
download the data - this should give you correctly named columns.

When importing data using the case importer, you can also use the dropdowns
to match columns in your Excel sheet to known case properties (so they
don’t need to be named exactly the same).

Thanks,
Sheel

··· On Wed, Nov 4, 2015 at 9:45 AM, Simon Berry wrote:

Thanks for the response. I have never used periods in property names. They
seem to be system generated. Many of the property names that I specified
when building the App now have ‘d.’ In front of them in case exports.

Simon

Apologies if this message is a bit cryptic, it was sent from my phone.

Simon Berry
counterpart project manager | KYTS Project
ceo and founder | ColaLife
+44 7932 107109 (UK)
+260 975572175 (Zambia)
skype: sxberry

On 4 Nov 2015, at 09:55, Cory Zue czue@dimagi.com wrote:

Hey Simon,

Periods are not allowed in case property names. It sounds like that is
definitely part of the problem, and it may be a UX issue on our side if
we’re not properly telling you that on import.

Could you try with a set of property names that don’t have periods in them
and let us know if that fixes it for you?

thanks,
Cory

On Tue, Nov 3, 2015 at 11:42 PM, Simon Berry simon@colalife.org wrote:

I am trying to set a property to — for selected cases and I’m using an
amended, ‘cut down’ case export to do this.

After importing the case importer reports that cases have been imported
but when I re-export the cases the property has not been cleared (set to
—). They have the same values as they did before the import.

A funny thing happens when I specify the import and I wonder if this is
part of the problem. The Excel field name is d.location_retailer but this
name is not available from the property dropdown menu. The closest is:
dlocation_retailer (without the period). In fact all property names with a
period in them appear with the period missing in the dropdown.

Help!


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “commcare-users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/commcare-users/rM_zKm5-1pg/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah

Hi Sheel

Creating a custom export was a great tip. Things make much more sense now!

I’m pretty sure that creating a case import from a pared down and modified
custom export will work.

Thanks

Simon

··· On Wednesday, November 4, 2015 at 6:37:15 PM UTC+2, Sheel Shah wrote: > > Hi Simon, > > On the case export page, I would recommend creating a new custom export to > download the data - this should give you correctly named columns. > > When importing data using the case importer, you can also use the > dropdowns to match columns in your Excel sheet to known case properties (so > they don't need to be named exactly the same). > > Thanks, > Sheel > > On Wed, Nov 4, 2015 at 9:45 AM, Simon Berry <si...@colalife.org > wrote: > >> Thanks for the response. I have never used periods in property names. >> They seem to be system generated. Many of the property names that I >> specified when building the App now have 'd.' In front of them in case >> exports. >> >> Simon >> >> >> Apologies if this message is a bit cryptic, it was sent from my phone. >> >> Simon Berry >> counterpart project manager | KYTS Project >> ceo and founder | ColaLife >> +44 7932 107109 (UK) >> +260 975572175 (Zambia) >> skype: sxberry >> >> On 4 Nov 2015, at 09:55, Cory Zue <cz...@dimagi.com > wrote: >> >> Hey Simon, >> >> Periods are not allowed in case property names. It sounds like that is >> definitely part of the problem, and it may be a UX issue on our side if >> we're not properly telling you that on import. >> >> Could you try with a set of property names that don't have periods in >> them and let us know if that fixes it for you? >> >> thanks, >> Cory >> >> On Tue, Nov 3, 2015 at 11:42 PM, Simon Berry <si...@colalife.org > wrote: >> >>> I am trying to set a property to --- for selected cases and I'm using an >>> amended, 'cut down' case export to do this. >>> >>> After importing the case importer reports that cases have been imported >>> but when I re-export the cases the property has not been cleared (set to >>> ---). They have the same values as they did before the import. >>> >>> A funny thing happens when I specify the import and I wonder if this is >>> part of the problem. The Excel field name is d.location_retailer but this >>> name is not available from the property dropdown menu. The closest is: >>> dlocation_retailer (without the period). In fact all property names with a >>> period in them appear with the period missing in the dropdown. >>> >>> Help! >>> >>> -- >>> You received this message because you are subscribed to the Google >>> Groups "commcare-users" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to commcare-user...@googlegroups.com . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> -- >> You received this message because you are subscribed to a topic in the >> Google Groups "commcare-users" group. >> To unsubscribe from this topic, visit >> https://groups.google.com/d/topic/commcare-users/rM_zKm5-1pg/unsubscribe. >> To unsubscribe from this group and all its topics, send an email to >> commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Sheel Shah > Project Manager | Dimagi > m: +1.781.428.5419 | skype: sheel_shah > > >