I am getting error on the forms that run's fine on validator

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine and I
uploaded my xforms on CCHQ 1.0 without any error but when I try to build the
app, I am getting the error bellow. Anyone with an idea of what might be
wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

Hey Gayo,

When you get that message it means that there will be a yellow error box on
the page of one of the forms. Looking quickly at your domain, it looks like
actually none of the forms have problems. If that’s the case and you’re
still getting that error then that’s a bug I need to fix! I’ll try and catch
you on Skype so we can figure this out.

Best,
Danny

··· 2011/4/12 gayo

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine and I
uploaded my xforms on CCHQ 1.0 without any error but when I try to build the
app, I am getting the error bellow. Anyone with an idea of what might be
wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

Hello Danny,

I am getting the same error when trying to build (domain: Deoghar) and
similarly my form does not flag any problems.

Thanks,
Derek

··· On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts wrote:

Hey Gayo,

When you get that message it means that there will be a yellow error box on
the page of one of the forms. Looking quickly at your domain, it looks like
actually none of the forms have problems. If that’s the case and you’re
still getting that error then that’s a bug I need to fix! I’ll try and catch
you on Skype so we can figure this out.

Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine and
I uploaded my xforms on CCHQ 1.0 without any error but when I try to build
the app, I am getting the error bellow. Anyone with an idea of what might be
wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

Thank you for raising this issue, Gayo and Derek. It’s a really terrible
bug! I’ll be working on it, and I’ll let you know when it’s been fixed.

Best,
Danny

··· 2011/4/12 Derek Treatman

Hello Danny,

I am getting the same error when trying to build (domain: Deoghar) and
similarly my form does not flag any problems.

Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.comwrote:

Hey Gayo,

When you get that message it means that there will be a yellow error box
on the page of one of the forms. Looking quickly at your domain, it looks
like actually none of the forms have problems. If that’s the case and you’re
still getting that error then that’s a bug I need to fix! I’ll try and catch
you on Skype so we can figure this out.

Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine and
I uploaded my xforms on CCHQ 1.0 without any error but when I try to build
the app, I am getting the error bellow. Anyone with an idea of what might be
wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

OK I found the issue. It doesn’t like non-ascii characters in the language
names. This makes sense because they should really be language codes not
language names. You can use either two or three letter codes, (columns 1 and
3 of http://www.sil.org/iso639-3/codes.asp); so for English you can use “en"
or “eng” and for Hindi you can use “hi” or “hin”, etc. Please don’t user
"Hindi” or “English”, etc. as the names of your languages.

I will change the interface to make this clearer, but for know you just have
to know. Sorry about the confusion.

Danny

··· 2011/4/12 Derek Treatman

Hello Danny,

I am getting the same error when trying to build (domain: Deoghar) and
similarly my form does not flag any problems.

Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.comwrote:

Hey Gayo,

When you get that message it means that there will be a yellow error box
on the page of one of the forms. Looking quickly at your domain, it looks
like actually none of the forms have problems. If that’s the case and you’re
still getting that error then that’s a bug I need to fix! I’ll try and catch
you on Skype so we can figure this out.

Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine and
I uploaded my xforms on CCHQ 1.0 without any error but when I try to build
the app, I am getting the error bellow. Anyone with an idea of what might be
wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

To clarify— for the meantime please use two-letter codes for English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter codes for
everything, and following these guidelines will make everything run smoothly
now, and make the transition to three-letter-only smooth later.

I’m working on an interface that will restrict input to help you correctly
input these codes.

Cheers,
Danny

··· 2011/4/13 Daniel Roberts

OK I found the issue. It doesn’t like non-ascii characters in the language
names. This makes sense because they should really be language codes not
language names. You can use either two or three letter codes, (columns 1 and
3 of http://www.sil.org/iso639-3/codes.asp); so for English you can use
"en" or “eng” and for Hindi you can use “hi” or “hin”, etc. Please don’t
user “Hindi” or “English”, etc. as the names of your languages.

I will change the interface to make this clearer, but for know you just
have to know. Sorry about the confusion.

Danny

2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,

I am getting the same error when trying to build (domain: Deoghar) and
similarly my form does not flag any problems.

Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.comwrote:

Hey Gayo,

When you get that message it means that there will be a yellow error box
on the page of one of the forms. Looking quickly at your domain, it looks
like actually none of the forms have problems. If that’s the case and you’re
still getting that error then that’s a bug I need to fix! I’ll try and catch
you on Skype so we can figure this out.

Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine
and I uploaded my xforms on CCHQ 1.0 without any error but when I try to
build the app, I am getting the error bellow. Anyone with an idea of what
might be wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

Dear CommCare Users,

CommCare HQ now helps and encourages you to use the correct language codes.
Check to see if the language codes you’ve already set up match the standard
by going to the your application (under Applications on CommCare HQ) and
playing with the autocomplete menu under “Supported Languages”. Also, HQ
will help you identify languages that don’t match the standard within your
forms, and give you suggestions on how to change them and a one-click way to
do so.

Enjoy,
Danny

··· 2011/4/13 Daniel Roberts

To clarify— for the meantime please use two-letter codes for English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter codes for
everything, and following these guidelines will make everything run smoothly
now, and make the transition to three-letter-only smooth later.

I’m working on an interface that will restrict input to help you correctly
input these codes.

Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in the language
names. This makes sense because they should really be language codes not
language names. You can use either two or three letter codes, (columns 1 and
3 of http://www.sil.org/iso639-3/codes.asp); so for English you can use
"en" or “eng” and for Hindi you can use “hi” or “hin”, etc. Please don’t
user “Hindi” or “English”, etc. as the names of your languages.

I will change the interface to make this clearer, but for know you just
have to know. Sorry about the confusion.

Danny

2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,

I am getting the same error when trying to build (domain: Deoghar) and
similarly my form does not flag any problems.

Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.comwrote:

Hey Gayo,

When you get that message it means that there will be a yellow error box
on the page of one of the forms. Looking quickly at your domain, it looks
like actually none of the forms have problems. If that’s the case and you’re
still getting that error then that’s a bug I need to fix! I’ll try and catch
you on Skype so we can figure this out.

Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running fine
and I uploaded my xforms on CCHQ 1.0 without any error but when I try to
build the app, I am getting the error bellow. Anyone with an idea of what
might be wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

··· On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts wrote: > Dear CommCare Users, > CommCare HQ now helps and encourages you to use the correct language codes. > Check to see if the language codes you've already set up match the standard > by going to the your application (under Applications on CommCare HQ) and > playing with the autocomplete menu under "Supported Languages". Also, HQ > will help you identify languages that don't match the standard within your > forms, and give you suggestions on how to change them and a one-click way to > do so. > Enjoy, > Danny > > 2011/4/13 Daniel Roberts >> >> To clarify--- for the meantime please use two-letter codes for English=en, >> Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare build for >> the phones uses these two letter codes. For everything else, use >> three-letter codes. Eventually we will be using three-letter codes for >> everything, and following these guidelines will make everything run smoothly >> now, and make the transition to three-letter-only smooth later. >> I'm working on an interface that will restrict input to help you correctly >> input these codes. >> Cheers, >> Danny >> >> >> 2011/4/13 Daniel Roberts >>> >>> OK I found the issue. It doesn't like non-ascii characters in the >>> language names. This makes sense because they should really be language >>> *codes* not language names. You can use either two or three letter codes, >>> (columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so for English >>> you can use "en" or "eng" and for Hindi you can use "hi" or "hin", etc. >>> Please *don't* user "Hindi" or "English", etc. as the names of your >>> languages. >>> I will change the interface to make this clearer, but for know you just >>> have to know. Sorry about the confusion. >>> Danny >>> 2011/4/12 Derek Treatman >>>> >>>> Hello Danny, >>>> I am getting the same error when trying to build (domain: Deoghar) and >>>> similarly my form does not flag any problems. >>>> Thanks, >>>> Derek >>>> >>>> On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts wrote: >>>>> >>>>> Hey Gayo, >>>>> When you get that message it means that there will be a yellow error >>>>> box on the page of one of the forms. Looking quickly at your domain, it >>>>> looks like actually none of the forms have problems. If that's the case and >>>>> you're still getting that error then that's a bug I need to fix! I'll try >>>>> and catch you on Skype so we can figure this out. >>>>> Best, >>>>> Danny >>>>> >>>>> 2011/4/12 gayo >>>>>> >>>>>> Hi again >>>>>> >>>>>> I'm still playing the game of using CCHQ 1.0 >>>>>> >>>>>> I did test all my xforms on the validator, all forms are running fine >>>>>> and I uploaded my xforms on CCHQ 1.0 without any error but when I try to >>>>>> build the app, I am getting the error bellow. Anyone with an idea of what >>>>>> might be wrong? >>>>>> >>>>>> error "One or more forms are invalid: check all your forms for error >>>>>> messages" >>>>>> >>>>>> Gayo >>>> >>> >> > >

Hey Brian,

Great question that I forgot to address. Yes. The drop down is technically
just a helper; everything will still work if you “make up” your own code.
But please don’t. Here is a much more comprehensive list that includes many
local and less widely spoken languages:
http://www.sil.org/iso639-3/codes.asp, so if it’s not in the drop-down let
us know and look up the correct code in the meantime.

Cheers,
Danny

··· 2011/4/19 Brian DeRenzi

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct language
codes.
Check to see if the language codes you’ve already set up match the
standard
by going to the your application (under Applications on CommCare HQ) and
playing with the autocomplete menu under “Supported Languages”. Also, HQ
will help you identify languages that don’t match the standard within
your
forms, and give you suggestions on how to change them and a one-click way
to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,

Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare build
for

the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter codes for
everything, and following these guidelines will make everything run
smoothly

now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly

input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in the
language names. This makes sense because they should really be language
codes not language names. You can use either two or three letter
codes,

(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so for
English

you can use “en” or “eng” and for Hindi you can use “hi” or “hin”, etc.
Please don’t user “Hindi” or “English”, etc. as the names of your
languages.
I will change the interface to make this clearer, but for know you just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain: Deoghar) and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a yellow error
box on the page of one of the forms. Looking quickly at your domain,
it

looks like actually none of the forms have problems. If that’s the
case and

you’re still getting that error then that’s a bug I need to fix! I’ll
try

and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running
fine

and I uploaded my xforms on CCHQ 1.0 without any error but when I
try to

build the app, I am getting the error bellow. Anyone with an idea of
what

might be wrong?

error “One or more forms are invalid: check all your forms for error
messages”

Gayo

Cool, good to know!

··· On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts wrote: > Hey Brian, > Great question that I forgot to address. Yes. The drop down is technically > just a helper; everything will still work if you "make up" your own code. > But please don't. Here is a much more comprehensive list that includes many > local and less widely spoken > languages: http://www.sil.org/iso639-3/codes.asp, so if it's not in the > drop-down let us know and look up the correct code in the meantime. > Cheers, > Danny > > > 2011/4/19 Brian DeRenzi >> >> Hi Danny, >> >> Are you still allowed to enter whatever you want in the autocomplete >> menu? One piece of consistent feedback from our latin american >> colleagues is the need/desire to be able to use local languages that >> likely will not be on the list. Is this still possible? >> >> Thanks, >> Brian >> >> >> On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts wrote: >> > Dear CommCare Users, >> > CommCare HQ now helps and encourages you to use the correct language >> > codes. >> > Check to see if the language codes you've already set up match the >> > standard >> > by going to the your application (under Applications on CommCare HQ) and >> > playing with the autocomplete menu under "Supported Languages". Also, HQ >> > will help you identify languages that don't match the standard within >> > your >> > forms, and give you suggestions on how to change them and a one-click >> > way to >> > do so. >> > Enjoy, >> > Danny >> > >> > 2011/4/13 Daniel Roberts >> >> >> >> To clarify--- for the meantime please use two-letter codes for >> >> English=en, >> >> Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare >> >> build for >> >> the phones uses these two letter codes. For everything else, use >> >> three-letter codes. Eventually we will be using three-letter codes for >> >> everything, and following these guidelines will make everything run >> >> smoothly >> >> now, and make the transition to three-letter-only smooth later. >> >> I'm working on an interface that will restrict input to help you >> >> correctly >> >> input these codes. >> >> Cheers, >> >> Danny >> >> >> >> >> >> 2011/4/13 Daniel Roberts >> >>> >> >>> OK I found the issue. It doesn't like non-ascii characters in the >> >>> language names. This makes sense because they should really be >> >>> language >> >>> *codes* not language names. You can use either two or three letter >> >>> codes, >> >>> (columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so for >> >>> English >> >>> you can use "en" or "eng" and for Hindi you can use "hi" or "hin", >> >>> etc. >> >>> Please *don't* user "Hindi" or "English", etc. as the names of your >> >>> languages. >> >>> I will change the interface to make this clearer, but for know you >> >>> just >> >>> have to know. Sorry about the confusion. >> >>> Danny >> >>> 2011/4/12 Derek Treatman >> >>>> >> >>>> Hello Danny, >> >>>> I am getting the same error when trying to build (domain: Deoghar) >> >>>> and >> >>>> similarly my form does not flag any problems. >> >>>> Thanks, >> >>>> Derek >> >>>> >> >>>> On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts wrote: >> >>>>> >> >>>>> Hey Gayo, >> >>>>> When you get that message it means that there will be a yellow error >> >>>>> box on the page of one of the forms. Looking quickly at your domain, >> >>>>> it >> >>>>> looks like actually none of the forms have problems. If that's the >> >>>>> case and >> >>>>> you're still getting that error then that's a bug I need to fix! >> >>>>> I'll try >> >>>>> and catch you on Skype so we can figure this out. >> >>>>> Best, >> >>>>> Danny >> >>>>> >> >>>>> 2011/4/12 gayo >> >>>>>> >> >>>>>> Hi again >> >>>>>> >> >>>>>> I'm still playing the game of using CCHQ 1.0 >> >>>>>> >> >>>>>> I did test all my xforms on the validator, all forms are running >> >>>>>> fine >> >>>>>> and I uploaded my xforms on CCHQ 1.0 without any error but when I >> >>>>>> try to >> >>>>>> build the app, I am getting the error bellow. Anyone with an idea >> >>>>>> of what >> >>>>>> might be wrong? >> >>>>>> >> >>>>>> error "One or more forms are invalid: check all your forms for >> >>>>>> error >> >>>>>> messages" >> >>>>>> >> >>>>>> Gayo >> >>>> >> >>> >> >> >> > >> > > >

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

··· On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi wrote: > Cool, good to know! > > On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts wrote: >> Hey Brian, >> Great question that I forgot to address. Yes. The drop down is technically >> just a helper; everything will still work if you "make up" your own code. >> But please don't. Here is a much more comprehensive list that includes many >> local and less widely spoken >> languages: http://www.sil.org/iso639-3/codes.asp, so if it's not in the >> drop-down let us know and look up the correct code in the meantime. >> Cheers, >> Danny >> >> >> 2011/4/19 Brian DeRenzi >>> >>> Hi Danny, >>> >>> Are you still allowed to enter whatever you want in the autocomplete >>> menu? One piece of consistent feedback from our latin american >>> colleagues is the need/desire to be able to use local languages that >>> likely will not be on the list. Is this still possible? >>> >>> Thanks, >>> Brian >>> >>> >>> On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts wrote: >>> > Dear CommCare Users, >>> > CommCare HQ now helps and encourages you to use the correct language >>> > codes. >>> > Check to see if the language codes you've already set up match the >>> > standard >>> > by going to the your application (under Applications on CommCare HQ) and >>> > playing with the autocomplete menu under "Supported Languages". Also, HQ >>> > will help you identify languages that don't match the standard within >>> > your >>> > forms, and give you suggestions on how to change them and a one-click >>> > way to >>> > do so. >>> > Enjoy, >>> > Danny >>> > >>> > 2011/4/13 Daniel Roberts >>> >> >>> >> To clarify--- for the meantime please use two-letter codes for >>> >> English=en, >>> >> Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare >>> >> build for >>> >> the phones uses these two letter codes. For everything else, use >>> >> three-letter codes. Eventually we will be using three-letter codes for >>> >> everything, and following these guidelines will make everything run >>> >> smoothly >>> >> now, and make the transition to three-letter-only smooth later. >>> >> I'm working on an interface that will restrict input to help you >>> >> correctly >>> >> input these codes. >>> >> Cheers, >>> >> Danny >>> >> >>> >> >>> >> 2011/4/13 Daniel Roberts >>> >>> >>> >>> OK I found the issue. It doesn't like non-ascii characters in the >>> >>> language names. This makes sense because they should really be >>> >>> language >>> >>> *codes* not language names. You can use either two or three letter >>> >>> codes, >>> >>> (columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so for >>> >>> English >>> >>> you can use "en" or "eng" and for Hindi you can use "hi" or "hin", >>> >>> etc. >>> >>> Please *don't* user "Hindi" or "English", etc. as the names of your >>> >>> languages. >>> >>> I will change the interface to make this clearer, but for know you >>> >>> just >>> >>> have to know. Sorry about the confusion. >>> >>> Danny >>> >>> 2011/4/12 Derek Treatman >>> >>>> >>> >>>> Hello Danny, >>> >>>> I am getting the same error when trying to build (domain: Deoghar) >>> >>>> and >>> >>>> similarly my form does not flag any problems. >>> >>>> Thanks, >>> >>>> Derek >>> >>>> >>> >>>> On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts wrote: >>> >>>>> >>> >>>>> Hey Gayo, >>> >>>>> When you get that message it means that there will be a yellow error >>> >>>>> box on the page of one of the forms. Looking quickly at your domain, >>> >>>>> it >>> >>>>> looks like actually none of the forms have problems. If that's the >>> >>>>> case and >>> >>>>> you're still getting that error then that's a bug I need to fix! >>> >>>>> I'll try >>> >>>>> and catch you on Skype so we can figure this out. >>> >>>>> Best, >>> >>>>> Danny >>> >>>>> >>> >>>>> 2011/4/12 gayo >>> >>>>>> >>> >>>>>> Hi again >>> >>>>>> >>> >>>>>> I'm still playing the game of using CCHQ 1.0 >>> >>>>>> >>> >>>>>> I did test all my xforms on the validator, all forms are running >>> >>>>>> fine >>> >>>>>> and I uploaded my xforms on CCHQ 1.0 without any error but when I >>> >>>>>> try to >>> >>>>>> build the app, I am getting the error bellow. Anyone with an idea >>> >>>>>> of what >>> >>>>>> might be wrong? >>> >>>>>> >>> >>>>>> error "One or more forms are invalid: check all your forms for >>> >>>>>> error >>> >>>>>> messages" >>> >>>>>> >>> >>>>>> Gayo >>> >>>> >>> >>> >>> >> >>> > >>> > >> >> >

fyi, if you pick a language code you haven’t defined translations for, all
you get is a null pointer exception when you try to launch commcare.

··· On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically

just a helper; everything will still work if you “make up” your own
code.

But please don’t. Here is a much more comprehensive list that includes
many

local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in the
drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct language
codes.
Check to see if the language codes you’ve already set up match the
standard
by going to the your application (under Applications on CommCare HQ)
and

playing with the autocomplete menu under “Supported Languages”. Also,
HQ

will help you identify languages that don’t match the standard within
your
forms, and give you suggestions on how to change them and a one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare
build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter codes
for

everything, and following these guidelines will make everything run
smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in the
language names. This makes sense because they should really be
language
codes not language names. You can use either two or three letter
codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so for
English
you can use “en” or “eng” and for Hindi you can use “hi” or “hin”,
etc.
Please don’t user “Hindi” or “English”, etc. as the names of your
languages.
I will change the interface to make this clearer, but for know you
just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain: Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts < droberts@dimagi.com> wrote:

Hey Gayo,
When you get that message it means that there will be a yellow
error

box on the page of one of the forms. Looking quickly at your
domain,

it
looks like actually none of the forms have problems. If that’s
the

case and
you’re still getting that error then that’s a bug I need to fix!
I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but when
I

try to
build the app, I am getting the error bellow. Anyone with an
idea

of what
might be wrong?

error “One or more forms are invalid: check all your forms for
error
messages”

Gayo

(seems like a bug in that maybe it should give a more useful error message?)

··· On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos wrote: > fyi, if you pick a language code you haven't defined translations for, all > you get is a null pointer exception when you try to launch commcare. > > On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi wrote: >> >> As an example, what do you use for swahili? >> >> http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s >> >> There seem to be 2 options (plus another one for congolese swahili). >> There also seem to be 29 varieties of Arabic. Is it just up to the >> organization for which to pick? >> >> >> On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi wrote: >> > Cool, good to know! >> > >> > On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts wrote: >> >> Hey Brian, >> >> Great question that I forgot to address. Yes. The drop down is >> >> technically >> >> just a helper; everything will still work if you "make up" your own >> >> code. >> >> But please don't. Here is a much more comprehensive list that includes >> >> many >> >> local and less widely spoken >> >> languages: http://www.sil.org/iso639-3/codes.asp, so if it's not in the >> >> drop-down let us know and look up the correct code in the meantime. >> >> Cheers, >> >> Danny >> >> >> >> >> >> 2011/4/19 Brian DeRenzi >> >>> >> >>> Hi Danny, >> >>> >> >>> Are you still allowed to enter whatever you want in the autocomplete >> >>> menu? One piece of consistent feedback from our latin american >> >>> colleagues is the need/desire to be able to use local languages that >> >>> likely will not be on the list. Is this still possible? >> >>> >> >>> Thanks, >> >>> Brian >> >>> >> >>> >> >>> On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts wrote: >> >>> > Dear CommCare Users, >> >>> > CommCare HQ now helps and encourages you to use the correct language >> >>> > codes. >> >>> > Check to see if the language codes you've already set up match the >> >>> > standard >> >>> > by going to the your application (under Applications on CommCare HQ) >> >>> > and >> >>> > playing with the autocomplete menu under "Supported Languages". >> >>> > Also, HQ >> >>> > will help you identify languages that don't match the standard >> >>> > within >> >>> > your >> >>> > forms, and give you suggestions on how to change them and a >> >>> > one-click >> >>> > way to >> >>> > do so. >> >>> > Enjoy, >> >>> > Danny >> >>> > >> >>> > 2011/4/13 Daniel Roberts >> >>> >> >> >>> >> To clarify--- for the meantime please use two-letter codes for >> >>> >> English=en, >> >>> >> Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare >> >>> >> build for >> >>> >> the phones uses these two letter codes. For everything else, use >> >>> >> three-letter codes. Eventually we will be using three-letter codes >> >>> >> for >> >>> >> everything, and following these guidelines will make everything run >> >>> >> smoothly >> >>> >> now, and make the transition to three-letter-only smooth later. >> >>> >> I'm working on an interface that will restrict input to help you >> >>> >> correctly >> >>> >> input these codes. >> >>> >> Cheers, >> >>> >> Danny >> >>> >> >> >>> >> >> >>> >> 2011/4/13 Daniel Roberts >> >>> >>> >> >>> >>> OK I found the issue. It doesn't like non-ascii characters in the >> >>> >>> language names. This makes sense because they should really be >> >>> >>> language >> >>> >>> *codes* not language names. You can use either two or three letter >> >>> >>> codes, >> >>> >>> (columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so for >> >>> >>> English >> >>> >>> you can use "en" or "eng" and for Hindi you can use "hi" or "hin", >> >>> >>> etc. >> >>> >>> Please *don't* user "Hindi" or "English", etc. as the names of >> >>> >>> your >> >>> >>> languages. >> >>> >>> I will change the interface to make this clearer, but for know you >> >>> >>> just >> >>> >>> have to know. Sorry about the confusion. >> >>> >>> Danny >> >>> >>> 2011/4/12 Derek Treatman >> >>> >>>> >> >>> >>>> Hello Danny, >> >>> >>>> I am getting the same error when trying to build (domain: >> >>> >>>> Deoghar) >> >>> >>>> and >> >>> >>>> similarly my form does not flag any problems. >> >>> >>>> Thanks, >> >>> >>>> Derek >> >>> >>>> >> >>> >>>> On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts wrote: >> >>> >>>>> >> >>> >>>>> Hey Gayo, >> >>> >>>>> When you get that message it means that there will be a yellow >> >>> >>>>> error >> >>> >>>>> box on the page of one of the forms. Looking quickly at your >> >>> >>>>> domain, >> >>> >>>>> it >> >>> >>>>> looks like actually none of the forms have problems. If that's >> >>> >>>>> the >> >>> >>>>> case and >> >>> >>>>> you're still getting that error then that's a bug I need to fix! >> >>> >>>>> I'll try >> >>> >>>>> and catch you on Skype so we can figure this out. >> >>> >>>>> Best, >> >>> >>>>> Danny >> >>> >>>>> >> >>> >>>>> 2011/4/12 gayo >> >>> >>>>>> >> >>> >>>>>> Hi again >> >>> >>>>>> >> >>> >>>>>> I'm still playing the game of using CCHQ 1.0 >> >>> >>>>>> >> >>> >>>>>> I did test all my xforms on the validator, all forms are >> >>> >>>>>> running >> >>> >>>>>> fine >> >>> >>>>>> and I uploaded my xforms on CCHQ 1.0 without any error but when >> >>> >>>>>> I >> >>> >>>>>> try to >> >>> >>>>>> build the app, I am getting the error bellow. Anyone with an >> >>> >>>>>> idea >> >>> >>>>>> of what >> >>> >>>>>> might be wrong? >> >>> >>>>>> >> >>> >>>>>> error "One or more forms are invalid: check all your forms for >> >>> >>>>>> error >> >>> >>>>>> messages" >> >>> >>>>>> >> >>> >>>>>> Gayo >> >>> >>>> >> >>> >>> >> >>> >> >> >>> > >> >>> > >> >> >> >> >> > > >

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

··· -----Original Message----- From: commcare-users@googlegroups.com [mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi Sent: Wednesday, April 20, 2011 6:16 AM To: commcare-users@googlegroups.com Subject: Re: I am getting error on the forms that run's fine on validator

(seems like a bug in that maybe it should give a more useful error message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for, all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that includes
many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match the
standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare
build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter codes
for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in the
language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a yellow
error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If that’s
the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with an
idea
of what
might be wrong?

error “One or more forms are invalid: check all your forms for
error
messages”

Gayo

Dear Gayo,

To clarify, while it is true that we currently do not support integration
with a bitbucket repository, we DO support uploading of completely custom
xforms. So, when you click ‘+’ to add a new form, or when you’re editing an
existing xform, you are given the choice between jumping into the form
designer or uploading your own form. This route should address whatever
desire commcare users may have to implement advanced functionality that is
beyond the scope of the form designer. Note, though, that you cannot upload
custom suites and profiles, as these must be configured on the HQ 1.0
website.

We continue to recommend that most forms be built in the form designer, and
that uploading your own form be used only for advanced functionality.

Peace,

Rowena

··· On Wed, Apr 20, 2011 at 7:08 AM, gayo wrote:

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

-----Original Message-----
From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi
Sent: Wednesday, April 20, 2011 6:16 AM
To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on validator

(seems like a bug in that maybe it should give a more useful error
message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for,
all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts <droberts@dimagi.com wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that
includes

many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match the
standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current
CommCare

build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter
codes

for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in
the

language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a yellow
error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If that’s
the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with an
idea
of what
might be wrong?

error "One or more forms are invalid: check all your forms
for

error
messages"

Gayo

Dear Gayo,

Another possibility for completely custom applications in for which you
configure the profile and suite files by hand is a feature which we haven’t
been supporting but could bring back up to speed that lets you build an
application from a bitbucket url. We will discuss internally how to
prioritize this feature but we will eventually have this feature.

We will keep you updated on progress.

Danny

··· 2011/4/20 Rowena Luk

Dear Gayo,

To clarify, while it is true that we currently do not support integration
with a bitbucket repository, we DO support uploading of completely custom
xforms. So, when you click ‘+’ to add a new form, or when you’re editing an
existing xform, you are given the choice between jumping into the form
designer or uploading your own form. This route should address whatever
desire commcare users may have to implement advanced functionality that is
beyond the scope of the form designer. Note, though, that you cannot upload
custom suites and profiles, as these must be configured on the HQ 1.0
website.

We continue to recommend that most forms be built in the form designer, and
that uploading your own form be used only for advanced functionality.

Peace,

Rowena

On Wed, Apr 20, 2011 at 7:08 AM, gayo gayomhila@gmail.com wrote:

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

-----Original Message-----
From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi
Sent: Wednesday, April 20, 2011 6:16 AM
To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on validator

(seems like a bug in that maybe it should give a more useful error
message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for,
all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts < droberts@dimagi.com> wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that
includes

many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the
autocomplete

menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages
that

likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match
the

standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current
CommCare

build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter
codes

for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in
the

language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a
yellow

error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If
that’s

the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with an
idea
of what
might be wrong?

error "One or more forms are invalid: check all your forms
for

error
messages"

Gayo

i would like this ‘link to bitbucket’ feature

··· On Thu, Apr 21, 2011 at 3:35 AM, Daniel Roberts wrote:

Dear Gayo,

Another possibility for completely custom applications in for which you
configure the profile and suite files by hand is a feature which we haven’t
been supporting but could bring back up to speed that lets you build an
application from a bitbucket url. We will discuss internally how to
prioritize this feature but we will eventually have this feature.

We will keep you updated on progress.

Danny

2011/4/20 Rowena Luk rluk@dimagi.com

Dear Gayo,

To clarify, while it is true that we currently do not support integration
with a bitbucket repository, we DO support uploading of completely custom
xforms. So, when you click ‘+’ to add a new form, or when you’re editing an
existing xform, you are given the choice between jumping into the form
designer or uploading your own form. This route should address whatever
desire commcare users may have to implement advanced functionality that is
beyond the scope of the form designer. Note, though, that you cannot upload
custom suites and profiles, as these must be configured on the HQ 1.0
website.

We continue to recommend that most forms be built in the form designer,
and that uploading your own form be used only for advanced functionality.

Peace,

Rowena

On Wed, Apr 20, 2011 at 7:08 AM, gayo gayomhila@gmail.com wrote:

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do
it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

-----Original Message-----
From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi
Sent: Wednesday, April 20, 2011 6:16 AM
To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on validator

(seems like a bug in that maybe it should give a more useful error
message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for,
all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts < droberts@dimagi.com> wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that
includes

many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not
in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the
autocomplete

menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages
that

likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match
the

standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current
CommCare

build for
the phones uses these two letter codes. For everything else,
use

three-letter codes. Eventually we will be using three-letter
codes

for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help
you

correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in
the

language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp);
so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a
yellow

error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If
that’s

the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with
an

idea
of what
might be wrong?

error "One or more forms are invalid: check all your forms
for

error
messages"

Gayo

The link to bitbucket would be very helpful. There could be several advantages of using bitbucket but here are what I find very useful to CommCare users implementers;-

  1.        We have people who help on xforms and commit changes but are not suppose to build or access data from the field for privacy issues. 
    
  2.        Working on local machine and test the xform before committing the changes is another advantage
    
  3.        When working in a group I found assigning issues and resolving through bitbucket is a huge benefit 
    

Gayo

··· From: commcare-users@googlegroups.com [mailto:commcare-users@googlegroups.com] On Behalf Of Drew Roos Sent: Thursday, April 21, 2011 5:09 AM To: commcare-users@googlegroups.com Subject: Re: I am getting error on the forms that run's fine on validator

i would like this ‘link to bitbucket’ feature

On Thu, Apr 21, 2011 at 3:35 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear Gayo,

Another possibility for completely custom applications in for which you configure the profile and suite files by hand is a feature which we haven’t been supporting but could bring back up to speed that lets you build an application from a bitbucket url. We will discuss internally how to prioritize this feature but we will eventually have this feature.

We will keep you updated on progress.

Danny

2011/4/20 Rowena Luk rluk@dimagi.com

Dear Gayo,

To clarify, while it is true that we currently do not support integration with a bitbucket repository, we DO support uploading of completely custom xforms. So, when you click ‘+’ to add a new form, or when you’re editing an existing xform, you are given the choice between jumping into the form designer or uploading your own form. This route should address whatever desire commcare users may have to implement advanced functionality that is beyond the scope of the form designer. Note, though, that you cannot upload custom suites and profiles, as these must be configured on the HQ 1.0 website.

We continue to recommend that most forms be built in the form designer, and that uploading your own form be used only for advanced functionality.

Peace,

Rowena

On Wed, Apr 20, 2011 at 7:08 AM, gayo gayomhila@gmail.com wrote:

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

-----Original Message-----
From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi
Sent: Wednesday, April 20, 2011 6:16 AM
To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on validator

(seems like a bug in that maybe it should give a more useful error message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for, all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3 http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s &letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that includes
many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match the
standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current CommCare
build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter codes
for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in the
language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a yellow
error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If that’s
the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with an
idea
of what
might be wrong?

error “One or more forms are invalid: check all your forms for
error
messages”

Gayo

OK. There’s plenty of interest and so I’ll prioritize this feature and bring
it back to life. I’ll give you a timeline once I’ve begun work on it later
this week.

Cheers,
Danny

··· 2011/4/21 gayo

The link to bitbucket would be very helpful. There could be several
advantages of using bitbucket but here are what I find very useful to
CommCare users implementers;-

  1.        We have people who help on xforms and commit changes but are
    

not suppose to build or access data from the field for privacy issues.

  1.        Working on local machine and test the xform before committing
    

the changes is another advantage

  1.        When working in a group I found assigning issues and
    

resolving through bitbucket is a huge benefit

Gayo

From: commcare-users@googlegroups.com [mailto:
commcare-users@googlegroups.com] *On Behalf Of *Drew Roos
Sent: Thursday, April 21, 2011 5:09 AM

To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on
validator

i would like this ‘link to bitbucket’ feature

On Thu, Apr 21, 2011 at 3:35 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear Gayo,

Another possibility for completely custom applications in for which you
configure the profile and suite files by hand is a feature which we haven’t
been supporting but could bring back up to speed that lets you build an
application from a bitbucket url. We will discuss internally how to
prioritize this feature but we will eventually have this feature.

We will keep you updated on progress.

Danny

2011/4/20 Rowena Luk rluk@dimagi.com

Dear Gayo,

To clarify, while it is true that we currently do not support integration
with a bitbucket repository, we DO support uploading of completely custom
xforms. So, when you click ‘+’ to add a new form, or when you’re editing an
existing xform, you are given the choice between jumping into the form
designer or uploading your own form. This route should address whatever
desire commcare users may have to implement advanced functionality that is
beyond the scope of the form designer. Note, though, that you cannot upload
custom suites and profiles, as these must be configured on the HQ 1.0
website.

We continue to recommend that most forms be built in the form designer, and
that uploading your own form be used only for advanced functionality.

Peace,

Rowena

On Wed, Apr 20, 2011 at 7:08 AM, gayo gayomhila@gmail.com wrote:

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

-----Original Message-----
From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi
Sent: Wednesday, April 20, 2011 6:16 AM
To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on validator

(seems like a bug in that maybe it should give a more useful error
message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for,
all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts <droberts@dimagi.com wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that
includes

many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the autocomplete
menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages that
likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match the
standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current
CommCare

build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter
codes

for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in
the

language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a yellow
error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If that’s
the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with an
idea
of what
might be wrong?

error "One or more forms are invalid: check all your forms
for

error
messages"

Gayo

Before this is actively part of CCHQ 1.0, it’s worth noting that the build
from bitbucket functionality still works on CCHQ 0.9, so if fully custom
(profile/suite/xform) applications are needed, you can build them from there
and just set the relevant profile parameters to have the app submit to
www.commcarehq.org instead of data.commcarehq.org.

-Clayton

··· On Thu, Apr 21, 2011 at 8:41 AM, Daniel Roberts wrote:

OK. There’s plenty of interest and so I’ll prioritize this feature and
bring it back to life. I’ll give you a timeline once I’ve begun work on it
later this week.

Cheers,
Danny

2011/4/21 gayo gayomhila@gmail.com

The link to bitbucket would be very helpful. There could be several
advantages of using bitbucket but here are what I find very useful to
CommCare users implementers;-

  1.        We have people who help on xforms and commit changes but are
    

not suppose to build or access data from the field for privacy issues.

  1.        Working on local machine and test the xform before
    

committing the changes is another advantage

  1.        When working in a group I found assigning issues and
    

resolving through bitbucket is a huge benefit

Gayo

From: commcare-users@googlegroups.com [mailto:
commcare-users@googlegroups.com] *On Behalf Of *Drew Roos
Sent: Thursday, April 21, 2011 5:09 AM

To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on
validator

i would like this ‘link to bitbucket’ feature

On Thu, Apr 21, 2011 at 3:35 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear Gayo,

Another possibility for completely custom applications in for which you
configure the profile and suite files by hand is a feature which we haven’t
been supporting but could bring back up to speed that lets you build an
application from a bitbucket url. We will discuss internally how to
prioritize this feature but we will eventually have this feature.

We will keep you updated on progress.

Danny

2011/4/20 Rowena Luk rluk@dimagi.com

Dear Gayo,

To clarify, while it is true that we currently do not support integration
with a bitbucket repository, we DO support uploading of completely custom
xforms. So, when you click ‘+’ to add a new form, or when you’re editing an
existing xform, you are given the choice between jumping into the form
designer or uploading your own form. This route should address whatever
desire commcare users may have to implement advanced functionality that is
beyond the scope of the form designer. Note, though, that you cannot upload
custom suites and profiles, as these must be configured on the HQ 1.0
website.

We continue to recommend that most forms be built in the form designer,
and that uploading your own form be used only for advanced functionality.

Peace,

Rowena

On Wed, Apr 20, 2011 at 7:08 AM, gayo gayomhila@gmail.com wrote:

I understand there is no interaction between bitbucket repository and the
current CCHQ 1.0 which means all the modifications and editing of xforms
need to happen using the xform editor on CCHQ.
Can someone list down what are the changes we need to avoid or if we do it
may affect the current module and form settings? Would appreciate much if
someone point to a link of such a documentation.

Gayo

-----Original Message-----
From: commcare-users@googlegroups.com
[mailto:commcare-users@googlegroups.com] On Behalf Of Brian DeRenzi
Sent: Wednesday, April 20, 2011 6:16 AM
To: commcare-users@googlegroups.com
Subject: Re: I am getting error on the forms that run’s fine on validator

(seems like a bug in that maybe it should give a more useful error
message?)

On Tue, Apr 19, 2011 at 7:19 PM, Drew Roos droos@dimagi.com wrote:

fyi, if you pick a language code you haven’t defined translations for,
all
you get is a null pointer exception when you try to launch commcare.

On Wed, Apr 20, 2011 at 12:36 AM, Brian DeRenzi bderenzi@gmail.com wrote:

As an example, what do you use for swahili?

http://www.sil.org/iso639-3/codes.asp?order=639_3&letter=s

There seem to be 2 options (plus another one for congolese swahili).
There also seem to be 29 varieties of Arabic. Is it just up to the
organization for which to pick?

On Tue, Apr 19, 2011 at 1:03 PM, Brian DeRenzi bderenzi@gmail.com wrote:

Cool, good to know!

On Tue, Apr 19, 2011 at 12:39 PM, Daniel Roberts < droberts@dimagi.com> wrote:

Hey Brian,
Great question that I forgot to address. Yes. The drop down is
technically
just a helper; everything will still work if you “make up” your own
code.
But please don’t. Here is a much more comprehensive list that
includes

many
local and less widely spoken
languages: http://www.sil.org/iso639-3/codes.asp, so if it’s not in
the

drop-down let us know and look up the correct code in the meantime.
Cheers,
Danny

2011/4/19 Brian DeRenzi bderenzi@gmail.com

Hi Danny,

Are you still allowed to enter whatever you want in the
autocomplete

menu? One piece of consistent feedback from our latin american
colleagues is the need/desire to be able to use local languages
that

likely will not be on the list. Is this still possible?

Thanks,
Brian

On Tue, Apr 19, 2011 at 10:04 AM, Daniel Roberts droberts@dimagi.com wrote:

Dear CommCare Users,
CommCare HQ now helps and encourages you to use the correct
language

codes.
Check to see if the language codes you’ve already set up match
the

standard
by going to the your application (under Applications on CommCare
HQ)

and
playing with the autocomplete menu under “Supported Languages”.
Also, HQ
will help you identify languages that don’t match the standard
within
your
forms, and give you suggestions on how to change them and a
one-click
way to
do so.
Enjoy,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

To clarify— for the meantime please use two-letter codes for
English=en,
Swahili=sw, Spanish=es, Afrikaans=af, because the current
CommCare

build for
the phones uses these two letter codes. For everything else, use
three-letter codes. Eventually we will be using three-letter
codes

for
everything, and following these guidelines will make everything
run

smoothly
now, and make the transition to three-letter-only smooth later.
I’m working on an interface that will restrict input to help you
correctly
input these codes.
Cheers,
Danny

2011/4/13 Daniel Roberts droberts@dimagi.com

OK I found the issue. It doesn’t like non-ascii characters in
the

language names. This makes sense because they should really be
language
codes not language names. You can use either two or three
letter

codes,
(columns 1 and 3 of http://www.sil.org/iso639-3/codes.asp); so
for

English
you can use “en” or “eng” and for Hindi you can use “hi” or
"hin",

etc.
Please don’t user “Hindi” or “English”, etc. as the names of
your
languages.
I will change the interface to make this clearer, but for know
you

just
have to know. Sorry about the confusion.
Danny
2011/4/12 Derek Treatman derek.treatman@gmail.com

Hello Danny,
I am getting the same error when trying to build (domain:
Deoghar)
and
similarly my form does not flag any problems.
Thanks,
Derek

On Tue, Apr 12, 2011 at 8:02 PM, Daniel Roberts droberts@dimagi.com wrote:

Hey Gayo,
When you get that message it means that there will be a
yellow

error
box on the page of one of the forms. Looking quickly at your
domain,
it
looks like actually none of the forms have problems. If
that’s

the
case and
you’re still getting that error then that’s a bug I need to
fix!

I’ll try
and catch you on Skype so we can figure this out.
Best,
Danny

2011/4/12 gayo gayomhila@gmail.com

Hi again

I’m still playing the game of using CCHQ 1.0

I did test all my xforms on the validator, all forms are
running
fine
and I uploaded my xforms on CCHQ 1.0 without any error but
when

I
try to
build the app, I am getting the error bellow. Anyone with an
idea
of what
might be wrong?

error "One or more forms are invalid: check all your forms
for

error
messages"

Gayo