Hmm... Form submissions now never show up in data exports!

Hi folks –

Hmm, I’ve been working with an app I haven’t done much on since april.

Over the last few days, I’ve done a fair amount of stuff – mainly adding a
second language, adding bulk translations, and some changes, especially to
a walk-in form.

On that walk-in form, I really changed it – I realized that there would
never be follow-up forms for that one, so I changed it from being a
"registers a case" to a “does not use cases.” I thought that would just
make it a flat form that would nicely send its data into the cloud database
and not take up extra memory on the phone. (note it’s very possible that
the nature of these changes has no bearing on my problem below.)

After making that change and also cutting several questions from that
walkin form, I went to see how the data was appearing when exported.

I found that after earlier today, (I guess about 8:30pm or so on Saturday
night BKK time) suddenly no forms that I’m submitting are appearing when I
export data. I re-built a brand new custom export – didn’t help. Then
I thought, OK, my many changes must have screwed something up. I reverted
the whole application back to its ancient version back in april. entered
new data into that follow up form and STILL nothing showing up in the
export forms export!!

**** OK, now I have gone in more depth and I have entered new data into a
DIFFERENT form in that app, and then made a fresh custom export for
forms… and it fails to show the new forms data in that one too!! Any
thought what is happening?

**** But I have gone to “submit history” and I see that the forms were
indeed recognized as submitted on CommCareHQ! What the heck. I bet this is
something embarrassingly simple.

… the project space is: https://www.commcarehq.org/a/marps-v4/
… the app is called “2 Clinic”
… the form I was working when this all seemed to start happening is
called “walk-in registration for clinic.”

Thoughts on why my data isn’t showing in exports?

Eric

Here is another way of pointing to this same problem…

– When I go to the Export Forms page, and I look in the section under
"export full forms," I see that in the column for “Total submissions” next
to “walk-in registration for clinic” is … 18

… but when I export the forms – either by that full-forms-export OR by
the custom export that I set up, only 13 are coming out! none of the new
ones I have added last night are appearing in there, etc…

Can you give advice? Thanks! --Eric

Hey Eric,

Can you check your date ranges in the form export? You may just be missing
today.

Thanks,
Sheel

··· On Jun 14, 2015 05:05, "Eric Stephan" wrote:

Here is another way of pointing to this same problem…

– When I go to the Export Forms page, and I look in the section under
"export full forms," I see that in the column for “Total submissions” next
to “walk-in registration for clinic” is … 18

… but when I export the forms – either by that full-forms-export OR by
the custom export that I set up, only 13 are coming out! none of the
new ones I have added last night are appearing in there, etc…

Can you give advice? Thanks! --Eric


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Sheel –

Yep, I really did try that, but it didn’t help. Note that it does often
say that the end date is what looks like “yesterday” but I think that’s
just a thing about my timezone being ahead of its clock. Because, even if
I do manually set it to be one day later, when I hit submit it
automatically resets to being the day it already had. The app clearly
thinks that it is set to the latest possible date.

Also, even if I was missing one day, I think I’d still be seeing the new
ones I saw yesterday.

https://www.commcarehq.org/a/marps-v4/data/excel_export_data/ is where I
am doing all this… And you can see I have made several new custom
exports, trying to get a fresh start!!

Any thoughts? This is odd… And seems to apply to forms in BOTH my apps,
I believe.

Hey Eric,

I think you need to hit Apply after changing the date range for the export.
Is that what you mean by Submit?

Can your report an issue from that project/link and potentially include
links to the forms that aren’t showing up in the export? We can then take a
look what is going on.

Thanks,
Sheel

··· On Jun 14, 2015 12:13, "Eric Stephan" wrote:

Hi Sheel –

Yep, I really did try that, but it didn’t help. Note that it does often
say that the end date is what looks like “yesterday” but I think that’s
just a thing about my timezone being ahead of its clock. Because, even if
I do manually set it to be one day later, when I hit submit it
automatically resets to being the day it already had. The app clearly
thinks that it is set to the latest possible date.

Also, even if I was missing one day, I think I’d still be seeing the new
ones I saw yesterday.

https://www.commcarehq.org/a/marps-v4/data/excel_export_data/ is where I
am doing all this… And you can see I have made several new custom
exports, trying to get a fresh start!!

Any thoughts? This is odd… And seems to apply to forms in BOTH my
apps, I believe.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Sheel -- Good lord, now it is working fine. Maybe I was just being
completely dense about that date-range/apply button :slight_smile: ... I just remember
that when I was changing dates in that, a couple of times it seemed to
magically "snap back" to the previous day (possibly because the server
still thought it was the previous day owing to time zones somehow.)
Anyway, if I ever see that snapping-back happening again I'll may more
attention and let you guys know if appropriate. Probably this was just me
being dense. THANKS! --Eric