Filtering form by user

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+Registration+Data)
we have created “emp-1” for required users and used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman

Aman,

That statement looks like it should work. To clarify for my understanding:
there are users whom you have set this user registration data “emp” to be 1
but the form still is not showing up for them? Are there any users for whom
this value isn’t set or is set to 0 but the form is showing up for them?

Thanks,
Will

··· On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some of
them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman

··· On 9 Jul 2014 19:01, "William Pride" wrote:

Aman,

That statement looks like it should work. To clarify for my understanding:
there are users whom you have set this user registration data “emp” to be 1
but the form still is not showing up for them? Are there any users for whom
this value isn’t set or is set to 0 but the form is showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hey Aman,

The display condition you listed looks a bit incorrect. If you want the
form to only show for users where emp is equal to 1, please use the
following:
count(instance(‘commcaresession’)/session/user/data/emp)>0 and
instance(‘commcaresession’)/session/user/data/emp = ‘1’

Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Regards,
Sheel

··· On Wed, Jul 9, 2014 at 10:40 AM, Aman Sen wrote:

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some of
them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman
On 9 Jul 2014 19:01, “William Pride” wpride@dimagi.com wrote:

Aman,

That statement looks like it should work. To clarify for my
understanding: there are users whom you have set this user registration
data “emp” to be 1 but the form still is not showing up for them? Are there
any users for whom this value isn’t set or is set to 0 but the form is
showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah

Thanks Sheel.

Regards
Aman

··· On 10 Jul 2014 00:16, "Sheel Shah" wrote:

Hey Aman,

The display condition you listed looks a bit incorrect. If you want the
form to only show for users where emp is equal to 1, please use the
following:
count(instance(‘commcaresession’)/session/user/data/emp)>0 and
instance(‘commcaresession’)/session/user/data/emp = ‘1’

Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Regards,
Sheel

On Wed, Jul 9, 2014 at 10:40 AM, Aman Sen amansen@gmail.com wrote:

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some of
them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman
On 9 Jul 2014 19:01, “William Pride” wpride@dimagi.com wrote:

Aman,

That statement looks like it should work. To clarify for my
understanding: there are users whom you have set this user registration
data “emp” to be 1 but the form still is not showing up for them? Are there
any users for whom this value isn’t set or is set to 0 but the form is
showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi

This even does not help. We have same problem

regards

aman

··· On Thu, Jul 10, 2014 at 12:15 AM, Sheel Shah wrote:

Hey Aman,

The display condition you listed looks a bit incorrect. If you want the
form to only show for users where emp is equal to 1, please use the
following:
count(instance(‘commcaresession’)/session/user/data/emp)>0 and
instance(‘commcaresession’)/session/user/data/emp = ‘1’

Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Regards,
Sheel

On Wed, Jul 9, 2014 at 10:40 AM, Aman Sen amansen@gmail.com wrote:

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some of
them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman
On 9 Jul 2014 19:01, “William Pride” wpride@dimagi.com wrote:

Aman,

That statement looks like it should work. To clarify for my
understanding: there are users whom you have set this user registration
data “emp” to be 1 but the form still is not showing up for them? Are there
any users for whom this value isn’t set or is set to 0 but the form is
showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Aman,

Did you follow these steps:
Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Please let me know if you need additional guidance on clearing user data.
Its probably easiest to remove and reinstall the application.

If that doesn’t work, can you please Report an Issue from your project and
we can take a look?

Thanks,
Sheel

··· On Thu, Jul 10, 2014 at 1:13 AM, Aman Sen wrote:

Hi

This even does not help. We have same problem

regards

aman

On Thu, Jul 10, 2014 at 12:15 AM, Sheel Shah sshah@dimagi.com wrote:

Hey Aman,

The display condition you listed looks a bit incorrect. If you want the
form to only show for users where emp is equal to 1, please use the
following:
count(instance(‘commcaresession’)/session/user/data/emp)>0 and
instance(‘commcaresession’)/session/user/data/emp = ‘1’

Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Regards,
Sheel

On Wed, Jul 9, 2014 at 10:40 AM, Aman Sen amansen@gmail.com wrote:

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some of
them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman
On 9 Jul 2014 19:01, “William Pride” wpride@dimagi.com wrote:

Aman,

That statement looks like it should work. To clarify for my
understanding: there are users whom you have set this user registration
data “emp” to be 1 but the form still is not showing up for them? Are there
any users for whom this value isn’t set or is set to 0 but the form is
showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and
used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah

Yes Sheel I had followed every steps . I clear user data by menu setting.
I thing that is the way what we should do.

But don’t know some features do not worj for us.

Regards

Aman

··· On 10 Jul 2014 20:35, "Sheel Shah" wrote:

Hi Aman,

Did you follow these steps:
Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Please let me know if you need additional guidance on clearing user data.
Its probably easiest to remove and reinstall the application.

If that doesn’t work, can you please Report an Issue from your project and
we can take a look?

Thanks,
Sheel

On Thu, Jul 10, 2014 at 1:13 AM, Aman Sen amansen@gmail.com wrote:

Hi

This even does not help. We have same problem

regards

aman

On Thu, Jul 10, 2014 at 12:15 AM, Sheel Shah sshah@dimagi.com wrote:

Hey Aman,

The display condition you listed looks a bit incorrect. If you want the
form to only show for users where emp is equal to 1, please use the
following:
count(instance(‘commcaresession’)/session/user/data/emp)>0 and
instance(‘commcaresession’)/session/user/data/emp = ‘1’

Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Regards,
Sheel

On Wed, Jul 9, 2014 at 10:40 AM, Aman Sen amansen@gmail.com wrote:

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some
of them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman
On 9 Jul 2014 19:01, “William Pride” wpride@dimagi.com wrote:

Aman,

That statement looks like it should work. To clarify for my
understanding: there are users whom you have set this user registration
data “emp” to be 1 but the form still is not showing up for them? Are there
any users for whom this value isn’t set or is set to 0 but the form is
showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and
used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks Aman, Can you please Report an Issue from your project and we can
take a look at how you have things setup.

Sheel

··· On Thu, Jul 10, 2014 at 11:26 AM, Aman Sen wrote:

Yes Sheel I had followed every steps . I clear user data by menu setting.
I thing that is the way what we should do.

But don’t know some features do not worj for us.

Regards

Aman
On 10 Jul 2014 20:35, “Sheel Shah” sshah@dimagi.com wrote:

Hi Aman,

Did you follow these steps:
Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Please let me know if you need additional guidance on clearing user data.
Its probably easiest to remove and reinstall the application.

If that doesn’t work, can you please Report an Issue from your project
and we can take a look?

Thanks,
Sheel

On Thu, Jul 10, 2014 at 1:13 AM, Aman Sen amansen@gmail.com wrote:

Hi

This even does not help. We have same problem

regards

aman

On Thu, Jul 10, 2014 at 12:15 AM, Sheel Shah sshah@dimagi.com wrote:

Hey Aman,

The display condition you listed looks a bit incorrect. If you want
the form to only show for users where emp is equal to 1, please use the
following:
count(instance(‘commcaresession’)/session/user/data/emp)>0 and
instance(‘commcaresession’)/session/user/data/emp = ‘1’

Also, you may need to clear user data for existing phones, and then
re-login as the new user to force the phone to download the updated custom
registration data.

Regards,
Sheel

On Wed, Jul 9, 2014 at 10:40 AM, Aman Sen amansen@gmail.com wrote:

Thanks for prompt replying. But it is not opening for them as well.
Issue is that we have 30 users with registration value emp=1 and some
of them have already filled the form before setting value and some of them
not. Not it is opening to them who has already administrated but not
opening to them who has not administrated.

Thanks

Regards

Aman
On 9 Jul 2014 19:01, “William Pride” wpride@dimagi.com wrote:

Aman,

That statement looks like it should work. To clarify for my
understanding: there are users whom you have set this user registration
data “emp” to be 1 but the form still is not showing up for them? Are there
any users for whom this value isn’t set or is set to 0 but the form is
showing up for them?

Thanks,
Will

On Wed, Jul 9, 2014 at 4:25 AM, Aman Sen amansen@gmail.com wrote:

Hi

We are trying to filter one form by user. As suggested in (
https://help.commcarehq.org/display/commcarepublic/Custom+
Registration+Data) we have created “emp-1” for required users and
used if(count(instance(‘commcaresession’)/session/user/data/emp)>0,
instance(‘commcaresession’)/session/user/data/emp,0)=1 in display condition
of that particular form but now it only is displaying that form for those
users who have already filled that form but it is not displaying for those
user who is recently joined.

Does anyone has any idea? Could anyone help us.

regards

aman


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google
Groups “commcare-users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Sheel Shah
Project Manager | Dimagi
m: +1.781.428.5419 | skype: sheel_shah