Excel importer - dates

Hi,

I am trying to use the Excel importer with mixed success. A couple of the
fields that I want to add / update are dates and I can’t seem to get this
to work. I have tried several different date formats in the excel document
(02/12/2013, 2013-12-02 and 41457) and have been selecting the data type as
’date’ on the matching page on CommCare but none of these seem to be
working. There isn’t any guidance on the help site for the excel importer
that I can see that tells you which date format to use.

Thanks

Jenny

Hi Jenny,

Is the column formatted as a date in Excel? What you’re doing seems to be
correct.

If you can send me a sample of the Excel doc you’re trying to upload, I can
take a look at what is going on.

Thanks,
Sheel

··· On Fri, Jan 3, 2014 at 1:06 AM, Jennifer Hall wrote:

Hi,

I am trying to use the Excel importer with mixed success. A couple of the
fields that I want to add / update are dates and I can’t seem to get this
to work. I have tried several different date formats in the excel document
(02/12/2013, 2013-12-02 and 41457) and have been selecting the data type as
’date’ on the matching page on CommCare but none of these seem to be
working. There isn’t any guidance on the help site for the excel importer
that I can see that tells you which date format to use.

Thanks

Jenny


You received this message because you are subscribed to the Google Groups
"commcare-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to commcare-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Sheel Shah
Project Manager | Dimagi India
t: +91 1146704670 | m: +91 9560187282

Hi Sheel,

I have tried it with the column formatted as a date in excel in several
different ways and I have tried it with the date formatted as text and then
not selecting the data type ‘date’ on the matching page but none of it is
working. What was happening is yesterday is that the date case properties
were being added (they are new case properties) but the dates within the
case properties were wrong (the same date in each one, although not always
using the same date column in excel) and no matter what I tried I couldn’t
change them. Today I can’t even get the case properties to be added! At
the moment I am just trying it with a single case to make it quicker while
I figure it out, but I do need to do this with all my data. After each
attempt it does say 1 rows were matched and updated. but nothing seems
to be happening.

If you give me your email address I’ll send the file.

Thanks for your help,

Jenny

··· On Friday, January 3, 2014 7:01:14 AM UTC, Sheel Shah wrote: > > Hi Jenny, > > Is the column formatted as a date in Excel? What you're doing seems to be > correct. > > If you can send me a sample of the Excel doc you're trying to upload, I > can take a look at what is going on. > > Thanks, > Sheel > > > On Fri, Jan 3, 2014 at 1:06 AM, Jennifer Hall <jenny_...@yahoo.co.uk wrote: > >> Hi, >> >> I am trying to use the Excel importer with mixed success. A couple of >> the fields that I want to add / update are dates and I can't seem to get >> this to work. I have tried several different date formats in the excel >> document (02/12/2013, 2013-12-02 and 41457) and have been selecting the >> data type as 'date' on the matching page on CommCare but none of these seem >> to be working. There isn't any guidance on the help site for the excel >> importer that I can see that tells you which date format to use. >> >> Thanks >> >> Jenny >> >> -- >> You received this message because you are subscribed to the Google Groups >> "commcare-users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to commcare-user...@googlegroups.com . >> For more options, visit https://groups.google.com/groups/opt_out. >> > > > > -- > Sheel Shah > Project Manager | Dimagi India > t: +91 1146704670 | m: +91 9560187282 > > >

Hi Jenny,

Thanks - you can send me the file to sshah@dimagi.com.

Sheel

··· On Fri, Jan 3, 2014 at 3:19 PM, Jennifer Hall wrote: > Hi Sheel, > > I have tried it with the column formatted as a date in excel in several > different ways and I have tried it with the date formatted as text and then > not selecting the data type 'date' on the matching page but none of it is > working. What was happening is yesterday is that the date case properties > were being added (they are new case properties) but the dates within the > case properties were wrong (the same date in each one, although not always > using the same date column in excel) and no matter what I tried I couldn't > change them. Today I can't even get the case properties to be added! At > the moment I am just trying it with a single case to make it quicker while I > figure it out, but I do need to do this with all my data. After each > attempt it does say 1 rows were matched and updated. but nothing seems to > be happening. > > If you give me your email address I'll send the file. > > Thanks for your help, > > Jenny > > > On Friday, January 3, 2014 7:01:14 AM UTC, Sheel Shah wrote: >> >> Hi Jenny, >> >> Is the column formatted as a date in Excel? What you're doing seems to be >> correct. >> >> If you can send me a sample of the Excel doc you're trying to upload, I >> can take a look at what is going on. >> >> Thanks, >> Sheel >> >> >> On Fri, Jan 3, 2014 at 1:06 AM, Jennifer Hall wrote: >>> >>> Hi, >>> >>> I am trying to use the Excel importer with mixed success. A couple of >>> the fields that I want to add / update are dates and I can't seem to get >>> this to work. I have tried several different date formats in the excel >>> document (02/12/2013, 2013-12-02 and 41457) and have been selecting the data >>> type as 'date' on the matching page on CommCare but none of these seem to be >>> working. There isn't any guidance on the help site for the excel importer >>> that I can see that tells you which date format to use. >>> >>> Thanks >>> >>> Jenny >>> >>> -- >>> You received this message because you are subscribed to the Google Groups >>> "commcare-users" group. >>> To unsubscribe from this group and stop receiving emails from it, send an >>> email to commcare-user...@googlegroups.com. >>> >>> For more options, visit https://groups.google.com/groups/opt_out. >> >> >> >> >> -- >> Sheel Shah >> Project Manager | Dimagi India >> t: +91 1146704670 | m: +91 9560187282 >> >> > -- > You received this message because you are subscribed to the Google Groups > "commcare-users" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to commcare-users+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/groups/opt_out.


Sheel Shah
Project Manager | Dimagi India
t: +91 1146704670 | m: +91 9560187282